summaryrefslogtreecommitdiff
path: root/src/lib/malloc/malloc.go
diff options
context:
space:
mode:
authorRob Pike <r@golang.org>2009-05-05 17:05:39 -0700
committerRob Pike <r@golang.org>2009-05-05 17:05:39 -0700
commitb6708b2dad4af458e69fde7fc596ecdce03280d0 (patch)
tree11cfc1b980ecce9cb0eec06f49cc53ce05faf350 /src/lib/malloc/malloc.go
parent658b10477a16151de7e4d51657993f95445f11ee (diff)
downloadgolang-b6708b2dad4af458e69fde7fc596ecdce03280d0.tar.gz
directory-per-package step 1: move files from lib/X.go to lib/X/X.go
no substantive changes except: - new Makefiles, all auto-generated - go/src/lib/Makefile has been extensively edited R=rsc OCL=28310 CL=28310
Diffstat (limited to 'src/lib/malloc/malloc.go')
-rw-r--r--src/lib/malloc/malloc.go24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/lib/malloc/malloc.go b/src/lib/malloc/malloc.go
new file mode 100644
index 000000000..8e4397a0b
--- /dev/null
+++ b/src/lib/malloc/malloc.go
@@ -0,0 +1,24 @@
+// Copyright 2009 The Go Authors. All rights reserved.
+// Use of this source code is governed by a BSD-style
+// license that can be found in the LICENSE file.
+
+// Go declarations for malloc.
+// The actual functions are written in C
+// and part of the runtime library.
+
+package malloc
+
+type Stats struct {
+ Alloc uint64;
+ Sys uint64;
+ Stacks uint64;
+ InusePages uint64;
+ NextGC uint64;
+ EnableGC bool;
+}
+
+func Alloc(uint64) *byte
+func Free(*byte)
+func GetStats() *Stats
+func Lookup(*byte) (*byte, uintptr)
+func GC()