summaryrefslogtreecommitdiff
path: root/src/lib/regexp
diff options
context:
space:
mode:
authorRuss Cox <rsc@golang.org>2009-04-16 00:18:37 -0700
committerRuss Cox <rsc@golang.org>2009-04-16 00:18:37 -0700
commit3e17b48cc202908701338c9d839bbb679d93a334 (patch)
tree1d4cd32e489588dee8ecbc1c0c90d924ee9aeae5 /src/lib/regexp
parent5a1a92a0559e505bf7a8b50a56d9f28d4b3da765 (diff)
downloadgolang-3e17b48cc202908701338c9d839bbb679d93a334.tar.gz
regenerate Makefiles.
fix bug in RPC.go (import "RPC" not "rpc.pb") R=r DELTA=483 (261 added, 64 deleted, 158 changed) OCL=27547 CL=27549
Diffstat (limited to 'src/lib/regexp')
-rw-r--r--src/lib/regexp/Makefile23
1 files changed, 16 insertions, 7 deletions
diff --git a/src/lib/regexp/Makefile b/src/lib/regexp/Makefile
index 6b63b7dcf..86cf44a28 100644
--- a/src/lib/regexp/Makefile
+++ b/src/lib/regexp/Makefile
@@ -4,16 +4,22 @@
# DO NOT EDIT. Automatically generated by gobuild.
# gobuild -m >Makefile
-O=6
+
+O_arm=5
+O_amd64=6
+O_386=8
+OS=568vq
+
+O=$(O_$(GOARCH))
GC=$(O)g
-CC=$(O)c -w
+CC=$(O)c -FVw
AS=$(O)a
-AR=$(O)ar
+AR=6ar
default: packages
clean:
- rm -f *.$O *.a $O.out
+ rm -f *.[$(OS)] *.a [$(OS)].out
test: packages
gotest
@@ -34,16 +40,20 @@ coverage: packages
O1=\
regexp.$O\
-regexp.a: a1
-a1: $(O1)
+phases: a1
+regexp.a: phases
+
+a1: $(O1)
$(AR) grc regexp.a regexp.$O
rm -f $(O1)
+
newpkg: clean
$(AR) grc regexp.a
$(O1): newpkg
+$(O2): a1
nuke: clean
rm -f $(GOROOT)/pkg/regexp.a
@@ -52,4 +62,3 @@ packages: regexp.a
install: packages
cp regexp.a $(GOROOT)/pkg/regexp.a
-