summaryrefslogtreecommitdiff
path: root/src/libbio
diff options
context:
space:
mode:
authorSergio Luis O. B. Correia <sergio@larces.uece.br>2009-11-23 17:32:51 -0800
committerSergio Luis O. B. Correia <sergio@larces.uece.br>2009-11-23 17:32:51 -0800
commit4d33b8a8cd75101d60aeef4bd38fca472943b3dd (patch)
treeb739091738e77c3d0fdbd27f77d22ed0e281dc32 /src/libbio
parent60c09d05acbb176013a749977f7b047930822a07 (diff)
downloadgolang-4d33b8a8cd75101d60aeef4bd38fca472943b3dd.tar.gz
go: makes it build for the case $GOROOT has whitespaces
the bash scripts and makefiles for building go didn't take into account the fact $GOROOT / $GOBIN could both be directories containing whitespaces, and was not possible to build it in such a situation. this commit adjusts the various makefiles/scripts to make it aware of that possibility, and now it builds successfully when using a path with whitespaces as well. Fixes issue 115. R=rsc, dsymonds1 http://codereview.appspot.com/157067 Committer: Russ Cox <rsc@golang.org>
Diffstat (limited to 'src/libbio')
-rw-r--r--src/libbio/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/libbio/Makefile b/src/libbio/Makefile
index bcd78347f..32fdedd91 100644
--- a/src/libbio/Makefile
+++ b/src/libbio/Makefile
@@ -45,10 +45,10 @@ OFILES=\
bwrite.$O\
HFILES=\
- $(GOROOT)/include/bio.h\
+ ../../include/bio.h
install: $(LIB)
- cp $(LIB) $(GOROOT)/lib
+ cp $(LIB) ../../lib
$(LIB): $(OFILES)
ar rsc $(LIB) $(OFILES)
@@ -62,4 +62,4 @@ clean:
rm -f $(OFILES) *.6 6.out $(LIB)
nuke: clean
- rm -f $(GOROOT)/lib/$(LIB)
+ rm -f ../../lib/$(LIB)