summaryrefslogtreecommitdiff
path: root/src/pkg/crypto/aes
diff options
context:
space:
mode:
authorSergio Luis O. B. Correia <sergio@larces.uece.br>2009-11-23 17:32:51 -0800
committerSergio Luis O. B. Correia <sergio@larces.uece.br>2009-11-23 17:32:51 -0800
commit4d33b8a8cd75101d60aeef4bd38fca472943b3dd (patch)
treeb739091738e77c3d0fdbd27f77d22ed0e281dc32 /src/pkg/crypto/aes
parent60c09d05acbb176013a749977f7b047930822a07 (diff)
downloadgolang-4d33b8a8cd75101d60aeef4bd38fca472943b3dd.tar.gz
go: makes it build for the case $GOROOT has whitespaces
the bash scripts and makefiles for building go didn't take into account the fact $GOROOT / $GOBIN could both be directories containing whitespaces, and was not possible to build it in such a situation. this commit adjusts the various makefiles/scripts to make it aware of that possibility, and now it builds successfully when using a path with whitespaces as well. Fixes issue 115. R=rsc, dsymonds1 http://codereview.appspot.com/157067 Committer: Russ Cox <rsc@golang.org>
Diffstat (limited to 'src/pkg/crypto/aes')
-rw-r--r--src/pkg/crypto/aes/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/pkg/crypto/aes/Makefile b/src/pkg/crypto/aes/Makefile
index f7352cb91..07d759b4b 100644
--- a/src/pkg/crypto/aes/Makefile
+++ b/src/pkg/crypto/aes/Makefile
@@ -2,7 +2,7 @@
# Use of this source code is governed by a BSD-style
# license that can be found in the LICENSE file.
-include $(GOROOT)/src/Make.$(GOARCH)
+include ../../../Make.$(GOARCH)
TARG=crypto/aes
GOFILES=\
@@ -10,4 +10,4 @@ GOFILES=\
cipher.go\
const.go\
-include $(GOROOT)/src/Make.pkg
+include ../../../Make.pkg