summaryrefslogtreecommitdiff
path: root/src/pkg/netchan/netchan_test.go
diff options
context:
space:
mode:
authorRuss Cox <rsc@golang.org>2010-06-21 13:05:38 -0700
committerRuss Cox <rsc@golang.org>2010-06-21 13:05:38 -0700
commit57bae4ad607c850a598ca819e5770eb6f920bcbb (patch)
tree97a7c116a9e677d98a0c88ff622421be6215b283 /src/pkg/netchan/netchan_test.go
parentf81fce331b39e659f86ef190c83c1e30c00f5b74 (diff)
downloadgolang-57bae4ad607c850a598ca819e5770eb6f920bcbb.tar.gz
pkg/Makefile: allow DISABLE_NET_TESTS=1 to disable network tests
netchan, rpc, websocket: run test servers on 127.0.0.1, to avoid conflict with OS X firewall. TBR=r CC=golang-dev http://codereview.appspot.com/1689046
Diffstat (limited to 'src/pkg/netchan/netchan_test.go')
-rw-r--r--src/pkg/netchan/netchan_test.go6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/pkg/netchan/netchan_test.go b/src/pkg/netchan/netchan_test.go
index ca3f4d4c7..01fc0f327 100644
--- a/src/pkg/netchan/netchan_test.go
+++ b/src/pkg/netchan/netchan_test.go
@@ -72,7 +72,7 @@ func importSend(imp *Importer, t *testing.T) {
}
func TestExportSendImportReceive(t *testing.T) {
- exp, err := NewExporter("tcp", ":0")
+ exp, err := NewExporter("tcp", "127.0.0.1:0")
if err != nil {
t.Fatal("new exporter:", err)
}
@@ -85,7 +85,7 @@ func TestExportSendImportReceive(t *testing.T) {
}
func TestExportReceiveImportSend(t *testing.T) {
- exp, err := NewExporter("tcp", ":0")
+ exp, err := NewExporter("tcp", "127.0.0.1:0")
if err != nil {
t.Fatal("new exporter:", err)
}
@@ -98,7 +98,7 @@ func TestExportReceiveImportSend(t *testing.T) {
}
func TestClosingExportSendImportReceive(t *testing.T) {
- exp, err := NewExporter("tcp", ":0")
+ exp, err := NewExporter("tcp", "127.0.0.1:0")
if err != nil {
t.Fatal("new exporter:", err)
}