summaryrefslogtreecommitdiff
path: root/src/pkg/utf8/Makefile
diff options
context:
space:
mode:
authorRuss Cox <rsc@golang.org>2009-08-12 13:18:37 -0700
committerRuss Cox <rsc@golang.org>2009-08-12 13:18:37 -0700
commitfc30062047876ed5e09983e0314265811973d2d3 (patch)
treefb8ce575f8d1f4edc0212dfd8848524f459c64d5 /src/pkg/utf8/Makefile
parentb1b3e70a5e9acb46914588167a43eea1bba7a529 (diff)
downloadgolang-fc30062047876ed5e09983e0314265811973d2d3.tar.gz
convert low-level (used by testing) packages to
whole-package compilation. new Makefiles, tests now in separate package bytes flag fmt io math once os reflect strconv sync time utf8 delete import "xxx" in package xxx. inside package xxx, xxx is not declared anymore so s/xxx.//g delete file and package level forward declarations. note the new internal_test.go and sync and strconv to provide public access to internals during testing. the installed version of the package omits that file and thus does not open the internals to all clients. R=r OCL=33065 CL=33097
Diffstat (limited to 'src/pkg/utf8/Makefile')
-rw-r--r--src/pkg/utf8/Makefile57
1 files changed, 4 insertions, 53 deletions
diff --git a/src/pkg/utf8/Makefile b/src/pkg/utf8/Makefile
index b5ad083b2..b33adaa8a 100644
--- a/src/pkg/utf8/Makefile
+++ b/src/pkg/utf8/Makefile
@@ -2,59 +2,10 @@
# Use of this source code is governed by a BSD-style
# license that can be found in the LICENSE file.
-# DO NOT EDIT. Automatically generated by gobuild.
-# gobuild -m >Makefile
-
-D=
-
include $(GOROOT)/src/Make.$(GOARCH)
-AR=gopack
-
-default: packages
-
-clean:
- rm -rf *.[$(OS)] *.a [$(OS)].out _obj
-
-test: packages
- gotest
-
-coverage: packages
- gotest
- 6cov -g `pwd` | grep -v '_test\.go:'
-
-%.$O: %.go
- $(GC) -I_obj $*.go
-
-%.$O: %.c
- $(CC) $*.c
-
-%.$O: %.s
- $(AS) $*.s
-
-O1=\
- utf8.$O\
-
-
-phases: a1
-_obj$D/utf8.a: phases
-
-a1: $(O1)
- $(AR) grc _obj$D/utf8.a utf8.$O
- rm -f $(O1)
-
-
-newpkg: clean
- mkdir -p _obj$D
- $(AR) grc _obj$D/utf8.a
-
-$(O1): newpkg
-$(O2): a1
-
-nuke: clean
- rm -f $(GOROOT)/pkg/$(GOOS)_$(GOARCH)$D/utf8.a
-packages: _obj$D/utf8.a
+TARG=utf8
+GOFILES=\
+ utf8.go\
-install: packages
- test -d $(GOROOT)/pkg && mkdir -p $(GOROOT)/pkg/$(GOOS)_$(GOARCH)$D
- cp _obj$D/utf8.a $(GOROOT)/pkg/$(GOOS)_$(GOARCH)$D/utf8.a
+include $(GOROOT)/src/Make.pkg