summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--doc/contribute.html7
1 files changed, 5 insertions, 2 deletions
diff --git a/doc/contribute.html b/doc/contribute.html
index 1c9301d18..26451f56c 100644
--- a/doc/contribute.html
+++ b/doc/contribute.html
@@ -64,7 +64,7 @@ The basic form is illustrated by <a href="../src/pkg/container/vector/Makefile">
</p>
<pre>
-include $(GOROOT)/src/Make.$(GOARCH)
+include ../../../Make.$(GOARCH)
TARG=container/vector
GOFILES=\
@@ -72,12 +72,15 @@ GOFILES=\
stringvector.go\
vector.go\
-include $(GOROOT)/src/Make.pkg
+include ../../../Make.pkg
</pre>
<p>
The first and last lines <code>include</code> standard definitions and rules,
+<code>$(GOROOT)/src/Make.$(GOARCH)</code> and <code>$(GOROOT)/src/Make.pkg</code>,
so that the body of the <code>Makefile</code> need only specify two variables.
+For packages to be installed in the Go tree, use a relative path instead of
+<code>$(GOROOT)/src</code>, so that make will work correctly even if <code>$(GOROOT)</code> contains spaces.
</p>
<p>