summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--src/pkg/syscall/Makefile1
-rw-r--r--src/pkg/syscall/syscall_386.go7
-rw-r--r--src/pkg/syscall/syscall_amd64.go7
-rw-r--r--src/pkg/syscall/syscall_arm.go7
4 files changed, 22 insertions, 0 deletions
diff --git a/src/pkg/syscall/Makefile b/src/pkg/syscall/Makefile
index 5673da9d2..ca3338b10 100644
--- a/src/pkg/syscall/Makefile
+++ b/src/pkg/syscall/Makefile
@@ -9,6 +9,7 @@ GOFILES=\
errstr.go\
exec.go\
syscall.go\
+ syscall_$(GOARCH).go\
syscall_$(GOOS).go\
syscall_$(GOOS)_$(GOARCH).go\
zerrors_$(GOOS)_$(GOARCH).go\
diff --git a/src/pkg/syscall/syscall_386.go b/src/pkg/syscall/syscall_386.go
new file mode 100644
index 000000000..cb948b87a
--- /dev/null
+++ b/src/pkg/syscall/syscall_386.go
@@ -0,0 +1,7 @@
+// Copyright 2010 The Go Authors. All rights reserved.
+// Use of this source code is governed by a BSD-style
+// license that can be found in the LICENSE file.
+
+package syscall
+
+const ARCH = "386"
diff --git a/src/pkg/syscall/syscall_amd64.go b/src/pkg/syscall/syscall_amd64.go
new file mode 100644
index 000000000..75c3eac6f
--- /dev/null
+++ b/src/pkg/syscall/syscall_amd64.go
@@ -0,0 +1,7 @@
+// Copyright 2010 The Go Authors. All rights reserved.
+// Use of this source code is governed by a BSD-style
+// license that can be found in the LICENSE file.
+
+package syscall
+
+const ARCH = "amd64"
diff --git a/src/pkg/syscall/syscall_arm.go b/src/pkg/syscall/syscall_arm.go
new file mode 100644
index 000000000..b9d1ca0c0
--- /dev/null
+++ b/src/pkg/syscall/syscall_arm.go
@@ -0,0 +1,7 @@
+// Copyright 2010 The Go Authors. All rights reserved.
+// Use of this source code is governed by a BSD-style
+// license that can be found in the LICENSE file.
+
+package syscall
+
+const ARCH = "arm"