summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--debian/golang-go.prerm21
2 files changed, 27 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 867b3f474..d2b03d739 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+golang (2:1.4.2-3) UNRELEASED; urgency=medium
+
+ * Add missing "prerm" for our new alternatives (thanks piuparts).
+
+ -- Tianon Gravi <admwiggin@gmail.com> Tue, 05 May 2015 23:25:05 +0000
+
golang (2:1.4.2-2) unstable; urgency=medium
* Move "go" and "gofmt" into "/usr/lib/go" and use alternatives to provide
diff --git a/debian/golang-go.prerm b/debian/golang-go.prerm
new file mode 100644
index 000000000..71a0d1a8c
--- /dev/null
+++ b/debian/golang-go.prerm
@@ -0,0 +1,21 @@
+#!/bin/sh
+set -e
+
+case "$1" in
+ remove|deconfigure)
+ update-alternatives --remove go /usr/lib/go/bin/go
+ ;;
+
+ upgrade|failed-upgrade)
+ ;;
+
+ *)
+ echo >&2 "prerm called with unknown argument: $1"
+ exit 0
+ ;;
+esac
+
+
+#DEBHELPER#
+
+exit 0