summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules4
-rwxr-xr-xdebian/test.bash4
3 files changed, 7 insertions, 3 deletions
diff --git a/debian/control b/debian/control
index aa3051adb..6f97898df 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Ondřej Surý <ondrej@debian.org>
Vcs-Browser: http://git.debian.org/?p=pkg-google/golang.git
Vcs-Git: git://git.debian.org/pkg-google/golang.git
-Build-Depends: debhelper (>= 7.4.10), bison, ed, mawk | awk, perl
+Build-Depends: debhelper (>= 7.4.10), bison, ed, mawk | awk, perl, bash, netbase
Build-Depends-Indep: po-debconf
Standards-Version: 3.9.3
Homepage: http://golang.org/
diff --git a/debian/rules b/debian/rules
index 96106224f..cc8776bb4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,7 +24,7 @@ override_dh_auto_build: debian/build.stamp
override_dh_auto_test:
:
-# $(no_check) || { cd src && bash ./run.bash --no-rebuild; }
+ $(no_check) || { cd $(CURDIR)/src && $(CURDIR)/debian/test.bash $(GOROOT)/pkg/tool/$(GOHOSTOS)_$(GOHOSTARCH); }
override_dh_compress:
dh_compress -Xusr/share/doc/$(PACKAGE)-doc/html -Xusr/share/doc/$(PACKAGE)-doc/godoc
@@ -41,7 +41,7 @@ override_dh_strip:
debian/build.stamp:
rm -f debian/build.stamp
mkdir -p $(GOBIN)
- +cd src && bash ./make.bash
+ +cd src && bash ./make.bash --no-banner
>debian/build.stamp
opt_no_act =
diff --git a/debian/test.bash b/debian/test.bash
new file mode 100755
index 000000000..d8f6c055f
--- /dev/null
+++ b/debian/test.bash
@@ -0,0 +1,4 @@
+#!/usr/bin/env bash
+set -e
+eval $($1/dist env -p)
+bash run.bash --no-rebuild --banner