summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--usr/austin/ptrace/Makefile13
-rw-r--r--usr/austin/ptrace/ptrace_linux.go5
-rw-r--r--usr/austin/ptrace/regs_linux_amd64.go1
3 files changed, 13 insertions, 6 deletions
diff --git a/usr/austin/ptrace/Makefile b/usr/austin/ptrace/Makefile
new file mode 100644
index 000000000..2158abc93
--- /dev/null
+++ b/usr/austin/ptrace/Makefile
@@ -0,0 +1,13 @@
+# Copyright 2009 The Go Authors. All rights reserved.
+# Use of this source code is governed by a BSD-style
+# license that can be found in the LICENSE file.
+
+include $(GOROOT)/src/Make.$(GOARCH)
+
+TARG=ptrace
+GOFILES=\
+ process.go\
+ ptrace_linux.go\
+ regs_$(GOOS)_$(GOARCH).go\
+
+include $(GOROOT)/src/Make.pkg
diff --git a/usr/austin/ptrace/ptrace_linux.go b/usr/austin/ptrace/ptrace_linux.go
index 489c8d43c..5bf7072e2 100644
--- a/usr/austin/ptrace/ptrace_linux.go
+++ b/usr/austin/ptrace/ptrace_linux.go
@@ -9,7 +9,6 @@ import (
"fmt";
"io";
"os";
- "ptrace";
"runtime";
"strconv";
"strings";
@@ -98,8 +97,6 @@ func (ts threadState) String() string {
* Basic types
*/
-type thread struct
-
// A breakpoint stores information about a single breakpoint,
// including its program counter, the overwritten text if the
// breakpoint is installed.
@@ -176,8 +173,6 @@ type thread struct {
exitStatus int;
}
-func (p *process) newThread(tid int, signal int, cloned bool) (*thread, os.Error)
-
/*
* Errors
*/
diff --git a/usr/austin/ptrace/regs_linux_amd64.go b/usr/austin/ptrace/regs_linux_amd64.go
index c843bb134..3b2a058d1 100644
--- a/usr/austin/ptrace/regs_linux_amd64.go
+++ b/usr/austin/ptrace/regs_linux_amd64.go
@@ -6,7 +6,6 @@ package ptrace
import (
"os";
- "ptrace";
"strconv";
"syscall";
)