summaryrefslogtreecommitdiff
path: root/src/cmd/8a/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/cmd/8a/Makefile')
-rw-r--r--src/cmd/8a/Makefile25
1 files changed, 5 insertions, 20 deletions
diff --git a/src/cmd/8a/Makefile b/src/cmd/8a/Makefile
index 78d361dbd..27290ddd7 100644
--- a/src/cmd/8a/Makefile
+++ b/src/cmd/8a/Makefile
@@ -1,25 +1,10 @@
-# Copyright 2009 The Go Authors. All rights reserved.
+# Copyright 2012 The Go Authors. All rights reserved.
# Use of this source code is governed by a BSD-style
# license that can be found in the LICENSE file.
-include ../../Make.inc
-O:=$(HOST_O)
+include ../../Make.dist
-TARG=8a
+install: y.tab.h
-HFILES=\
- a.h\
- y.tab.h\
- ../8l/8.out.h\
-
-OFILES=\
- y.tab.$O\
- lex.$O\
- ../8l/enam.$O\
-
-YFILES=\
- a.y\
-
-include ../../Make.ccmd
-
-lex.$O: ../cc/macbody ../cc/lexbody
+y.tab.h: a.y
+ LANG=C LANGUAGE=en_US.UTF8 bison -d -v -y a.y