summaryrefslogtreecommitdiff
path: root/src/cmd/godefs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/cmd/godefs/Makefile')
-rw-r--r--src/cmd/godefs/Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/src/cmd/godefs/Makefile b/src/cmd/godefs/Makefile
index 49244f152..b5c76fb0f 100644
--- a/src/cmd/godefs/Makefile
+++ b/src/cmd/godefs/Makefile
@@ -2,7 +2,8 @@
# Use of this source code is governed by a BSD-style
# license that can be found in the LICENSE file.
-include ../../Make.conf
+include ../../Make.inc
+O:=$(HOST_O)
TARG=godefs
OFILES=\
@@ -12,13 +13,4 @@ OFILES=\
HFILES=a.h
-$(TARG): $(OFILES)
- $(LD) -o $(TARG) -L"$(GOROOT)"/lib $(OFILES) -lbio -l9
-
-clean:
- rm -f *.$O $(TARG)
-
-install: $(TARG)
- cp $(TARG) "$(GOBIN)"/$(TARG)
-
-$(OFILES): $(HFILES)
+include ../../Make.ccmd