summaryrefslogtreecommitdiff
path: root/src/cmd/gofmt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/cmd/gofmt/Makefile')
-rw-r--r--src/cmd/gofmt/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/cmd/gofmt/Makefile b/src/cmd/gofmt/Makefile
new file mode 100644
index 000000000..dc5b060e6
--- /dev/null
+++ b/src/cmd/gofmt/Makefile
@@ -0,0 +1,19 @@
+# Copyright 2009 The Go Authors. All rights reserved.
+# Use of this source code is governed by a BSD-style
+# license that can be found in the LICENSE file.
+
+include ../../Make.inc
+
+TARG=gofmt
+GOFILES=\
+ gofmt.go\
+ rewrite.go\
+ simplify.go\
+
+include ../../Make.cmd
+
+test: $(TARG)
+ ./test.sh
+
+testshort:
+ gotest -test.short