summaryrefslogtreecommitdiff
path: root/src/cmd/goinstall/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/cmd/goinstall/Makefile')
-rw-r--r--src/cmd/goinstall/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/cmd/goinstall/Makefile b/src/cmd/goinstall/Makefile
index 6ddb32be7..aaf202ee7 100644
--- a/src/cmd/goinstall/Makefile
+++ b/src/cmd/goinstall/Makefile
@@ -10,5 +10,20 @@ GOFILES=\
main.go\
make.go\
parse.go\
+ syslist.go\
+
+CLEANFILES+=syslist.go
include ../../Make.cmd
+
+syslist.go:
+ echo '// Generated automatically by make.' >$@
+ echo 'package main' >>$@
+ echo 'const goosList = "$(GOOS_LIST)"' >>$@
+ echo 'const goarchList = "$(GOARCH_LIST)"' >>$@
+
+test:
+ gotest
+
+testshort:
+ gotest -test.short