summaryrefslogtreecommitdiff
path: root/src/cmd/gotest
diff options
context:
space:
mode:
Diffstat (limited to 'src/cmd/gotest')
-rw-r--r--src/cmd/gotest/Makefile4
-rwxr-xr-xsrc/cmd/gotest/gotest2
2 files changed, 3 insertions, 3 deletions
diff --git a/src/cmd/gotest/Makefile b/src/cmd/gotest/Makefile
index 8a1f02386..b20b1daff 100644
--- a/src/cmd/gotest/Makefile
+++ b/src/cmd/gotest/Makefile
@@ -10,5 +10,5 @@ clean:
@true
install: $(TARG)
- ! test -f $(GOBIN)/$(TARG) || chmod u+w $(GOBIN)/$(TARG)
- cp $(TARG) $(GOBIN)/$(TARG)
+ ! test -f "$(GOBIN)"/$(TARG) || chmod u+w "$(GOBIN)"/$(TARG)
+ cp $(TARG) "$(GOBIN)"/$(TARG)
diff --git a/src/cmd/gotest/gotest b/src/cmd/gotest/gotest
index 5f87b4791..75fd19217 100755
--- a/src/cmd/gotest/gotest
+++ b/src/cmd/gotest/gotest
@@ -21,7 +21,7 @@ if [ ! -f [Mm]akefile ]; then
exit 2
fi
-. $GOROOT/src/Make.$GOARCH
+. "$GOROOT"/src/Make.$GOARCH
if [ -z "$O" ]; then
echo 'missing $O - maybe no Make.$GOARCH?' 1>&2
exit 2