summaryrefslogtreecommitdiff
path: root/src/cmd/objdump/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/cmd/objdump/Makefile')
-rw-r--r--src/cmd/objdump/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/cmd/objdump/Makefile b/src/cmd/objdump/Makefile
new file mode 100644
index 000000000..1b66c26ba
--- /dev/null
+++ b/src/cmd/objdump/Makefile
@@ -0,0 +1,10 @@
+all: x86.go armasm.go
+
+x86.go: bundle
+ ./bundle -p main -x x86_ rsc.io/x86/x86asm | gofmt >x86.go
+
+armasm.go: bundle
+ ./bundle -p main -x arm_ rsc.io/arm/armasm | gofmt >armasm.go
+
+bundle:
+ go build -o bundle code.google.com/p/rsc/cmd/bundle