summaryrefslogtreecommitdiff
path: root/src/cmd/vet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/cmd/vet/Makefile')
-rw-r--r--src/cmd/vet/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/cmd/vet/Makefile b/src/cmd/vet/Makefile
index 45bd29170..67c7e1997 100644
--- a/src/cmd/vet/Makefile
+++ b/src/cmd/vet/Makefile
@@ -5,8 +5,10 @@
# Assumes go/types is installed
test testshort:
go build -tags 'vet_test gotypes'
- ../../../test/errchk ./vet -printfuncs='Warn:1,Warnf:1' *.go *.s
+ ../../../test/errchk ./vet -printfuncs='Warn:1,Warnf:1' test_*.go test_*.s
test_notypes:
go build -tags 'vet_test'
- ../../../test/errchk ./vet -printfuncs='Warn:1,Warnf:1' *.go *.s
+ # Only those tests that do not depend on types.
+ # Excluded: test_print.go
+ ../../../test/errchk ./vet -printfuncs='Warn:1,Warnf:1' test_asm.go test_assign.go test_atomic.go test_buildtag.go test_buildtag_bad.go test_deadcode.go test_method.go test_rangeloop.go test_structtag.go test_taglit.go test_*.s