summaryrefslogtreecommitdiff
path: root/src/lib/malloc
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/malloc')
-rw-r--r--src/lib/malloc/Makefile68
-rw-r--r--src/lib/malloc/malloc.go24
2 files changed, 92 insertions, 0 deletions
diff --git a/src/lib/malloc/Makefile b/src/lib/malloc/Makefile
new file mode 100644
index 000000000..771896005
--- /dev/null
+++ b/src/lib/malloc/Makefile
@@ -0,0 +1,68 @@
+# Copyright 2009 The Go Authors. All rights reserved.
+# Use of this source code is governed by a BSD-style
+# license that can be found in the LICENSE file.
+
+# DO NOT EDIT. Automatically generated by gobuild.
+# gobuild -m >Makefile
+
+D=
+
+O_arm=5
+O_amd64=6
+O_386=8
+OS=568vq
+
+O=$(O_$(GOARCH))
+GC=$(O)g -I_obj
+CC=$(O)c -FVw
+AS=$(O)a
+AR=6ar
+
+default: packages
+
+clean:
+ rm -rf *.[$(OS)] *.a [$(OS)].out _obj
+
+test: packages
+ gotest
+
+coverage: packages
+ gotest
+ 6cov -g `pwd` | grep -v '_test\.go:'
+
+%.$O: %.go
+ $(GC) $*.go
+
+%.$O: %.c
+ $(CC) $*.c
+
+%.$O: %.s
+ $(AS) $*.s
+
+O1=\
+ malloc.$O\
+
+
+phases: a1
+_obj$D/malloc.a: phases
+
+a1: $(O1)
+ $(AR) grc _obj$D/malloc.a malloc.$O
+ rm -f $(O1)
+
+
+newpkg: clean
+ mkdir -p _obj$D
+ $(AR) grc _obj$D/malloc.a
+
+$(O1): newpkg
+$(O2): a1
+
+nuke: clean
+ rm -f $(GOROOT)/pkg$D/malloc.a
+
+packages: _obj$D/malloc.a
+
+install: packages
+ test -d $(GOROOT)/pkg && mkdir -p $(GOROOT)/pkg$D
+ cp _obj$D/malloc.a $(GOROOT)/pkg$D/malloc.a
diff --git a/src/lib/malloc/malloc.go b/src/lib/malloc/malloc.go
new file mode 100644
index 000000000..8e4397a0b
--- /dev/null
+++ b/src/lib/malloc/malloc.go
@@ -0,0 +1,24 @@
+// Copyright 2009 The Go Authors. All rights reserved.
+// Use of this source code is governed by a BSD-style
+// license that can be found in the LICENSE file.
+
+// Go declarations for malloc.
+// The actual functions are written in C
+// and part of the runtime library.
+
+package malloc
+
+type Stats struct {
+ Alloc uint64;
+ Sys uint64;
+ Stacks uint64;
+ InusePages uint64;
+ NextGC uint64;
+ EnableGC bool;
+}
+
+func Alloc(uint64) *byte
+func Free(*byte)
+func GetStats() *Stats
+func Lookup(*byte) (*byte, uintptr)
+func GC()