summaryrefslogtreecommitdiff
path: root/src/lib/os
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/os')
-rw-r--r--src/lib/os/Makefile5
-rw-r--r--src/lib/os/env.go2
-rw-r--r--src/lib/os/file.go2
3 files changed, 5 insertions, 4 deletions
diff --git a/src/lib/os/Makefile b/src/lib/os/Makefile
index b563da3f3..e7b49e5b9 100644
--- a/src/lib/os/Makefile
+++ b/src/lib/os/Makefile
@@ -3,7 +3,7 @@
# license that can be found in the LICENSE file.
# DO NOT EDIT. Automatically generated by gobuild.
-# gobuild -m dir_${GOARCH}_${GOOS}.go env.go error.go file.go stat_${GOARCH}_${GOOS}.go time.go types.go exec.go >Makefile
+# gobuild -m dir_${GOARCH}_${GOOS}.go env.go error.go file.go proc.go stat_${GOARCH}_${GOOS}.go time.go types.go exec.go >Makefile
D=
@@ -41,6 +41,7 @@ coverage: packages
O1=\
error.$O\
+ proc.$O\
types.$O\
O2=\
@@ -60,7 +61,7 @@ phases: a1 a2 a3 a4
_obj$D/os.a: phases
a1: $(O1)
- $(AR) grc _obj$D/os.a error.$O types.$O
+ $(AR) grc _obj$D/os.a error.$O proc.$O types.$O
rm -f $(O1)
a2: $(O2)
diff --git a/src/lib/os/env.go b/src/lib/os/env.go
index e7df309e0..748750413 100644
--- a/src/lib/os/env.go
+++ b/src/lib/os/env.go
@@ -19,7 +19,7 @@ var env map[string] string;
func copyenv() {
env = make(map[string] string);
- for i, s := range sys.Envs {
+ for i, s := range os.Envs {
for j := 0; j < len(s); j++ {
if s[j] == '=' {
env[s[0:j]] = s[j+1:len(s)];
diff --git a/src/lib/os/file.go b/src/lib/os/file.go
index fa1784a42..9b22a896d 100644
--- a/src/lib/os/file.go
+++ b/src/lib/os/file.go
@@ -132,7 +132,7 @@ func (file *File) Write(b []byte) (ret int, err Error) {
if e == syscall.EPIPE {
file.nepipe++;
if file.nepipe >= 10 {
- sys.Exit(syscall.EPIPE);
+ os.Exit(syscall.EPIPE);
}
} else {
file.nepipe = 0;