summaryrefslogtreecommitdiff
path: root/src/pkg/ebnf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/pkg/ebnf/Makefile')
-rw-r--r--src/pkg/ebnf/Makefile69
1 files changed, 69 insertions, 0 deletions
diff --git a/src/pkg/ebnf/Makefile b/src/pkg/ebnf/Makefile
new file mode 100644
index 000000000..06c0fc832
--- /dev/null
+++ b/src/pkg/ebnf/Makefile
@@ -0,0 +1,69 @@
+# Copyright 2009 The Go Authors. All rights reserved.
+# Use of this source code is governed by a BSD-style
+# license that can be found in the LICENSE file.
+
+
+# DO NOT EDIT. Automatically generated by gobuild.
+# gobuild -m ebnf.go parser.go >Makefile
+
+D=
+
+include $(GOROOT)/src/Make.$(GOARCH)
+AR=gopack
+
+default: packages
+
+clean:
+ rm -rf *.[$(OS)] *.a [$(OS)].out _obj
+
+test: packages
+ gotest
+
+coverage: packages
+ gotest
+ 6cov -g $$(pwd) | grep -v '_test\.go:'
+
+%.$O: %.go
+ $(GC) -I_obj $*.go
+
+%.$O: %.c
+ $(CC) $*.c
+
+%.$O: %.s
+ $(AS) $*.s
+
+O1=\
+ ebnf.$O\
+
+O2=\
+ parser.$O\
+
+
+phases: a1 a2
+_obj$D/ebnf.a: phases
+
+a1: $(O1)
+ $(AR) grc _obj$D/ebnf.a ebnf.$O
+ rm -f $(O1)
+
+a2: $(O2)
+ $(AR) grc _obj$D/ebnf.a parser.$O
+ rm -f $(O2)
+
+
+newpkg: clean
+ mkdir -p _obj$D
+ $(AR) grc _obj$D/ebnf.a
+
+$(O1): newpkg
+$(O2): a1
+$(O3): a2
+
+nuke: clean
+ rm -f $(GOROOT)/pkg/$(GOOS)_$(GOARCH)$D/ebnf.a
+
+packages: _obj$D/ebnf.a
+
+install: packages
+ test -d $(GOROOT)/pkg && mkdir -p $(GOROOT)/pkg/$(GOOS)_$(GOARCH)$D
+ cp _obj$D/ebnf.a $(GOROOT)/pkg/$(GOOS)_$(GOARCH)$D/ebnf.a