summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/lib/runtime/386/asm.s (renamed from src/runtime/386/asm.s)0
-rw-r--r--src/lib/runtime/386/closure.c (renamed from src/runtime/386/closure.c)0
-rw-r--r--src/lib/runtime/386/traceback.c (renamed from src/runtime/386/traceback.c)0
-rwxr-xr-xsrc/lib/runtime/386/vlop.s (renamed from src/runtime/386/vlop.s)0
-rwxr-xr-xsrc/lib/runtime/386/vlrt.c (renamed from src/runtime/386/vlrt.c)0
-rw-r--r--src/lib/runtime/amd64/asm.s (renamed from src/runtime/amd64/asm.s)0
-rw-r--r--src/lib/runtime/amd64/closure.c (renamed from src/runtime/amd64/closure.c)0
-rw-r--r--src/lib/runtime/amd64/traceback.c (renamed from src/runtime/amd64/traceback.c)0
-rw-r--r--src/lib/runtime/arm/asm.s (renamed from src/runtime/arm/asm.s)0
-rw-r--r--src/lib/runtime/arm/closure.c (renamed from src/runtime/arm/closure.c)0
-rw-r--r--src/lib/runtime/arm/traceback.s (renamed from src/runtime/arm/traceback.s)0
-rw-r--r--src/lib/runtime/array.c (renamed from src/runtime/array.c)0
-rw-r--r--src/lib/runtime/cgo2c.c (renamed from src/runtime/cgo2c.c)0
-rw-r--r--src/lib/runtime/chan.c (renamed from src/runtime/chan.c)0
-rw-r--r--src/lib/runtime/darwin/386/defs.h (renamed from src/runtime/darwin/386/defs.h)0
-rwxr-xr-xsrc/lib/runtime/darwin/386/rt0.s (renamed from src/runtime/darwin/386/rt0.s)0
-rw-r--r--src/lib/runtime/darwin/386/signal.c (renamed from src/runtime/darwin/386/signal.c)0
-rw-r--r--src/lib/runtime/darwin/386/sys.s (renamed from src/runtime/darwin/386/sys.s)0
-rw-r--r--src/lib/runtime/darwin/amd64/defs.h (renamed from src/runtime/darwin/amd64/defs.h)0
-rw-r--r--src/lib/runtime/darwin/amd64/rt0.s (renamed from src/runtime/darwin/amd64/rt0.s)0
-rw-r--r--src/lib/runtime/darwin/amd64/signal.c (renamed from src/runtime/darwin/amd64/signal.c)0
-rw-r--r--src/lib/runtime/darwin/amd64/sys.s (renamed from src/runtime/darwin/amd64/sys.s)0
-rw-r--r--src/lib/runtime/darwin/defs.c (renamed from src/runtime/darwin/defs.c)0
-rw-r--r--src/lib/runtime/darwin/os.h (renamed from src/runtime/darwin/os.h)0
-rw-r--r--src/lib/runtime/darwin/signals.h (renamed from src/runtime/darwin/signals.h)0
-rw-r--r--src/lib/runtime/darwin/thread.c (renamed from src/runtime/darwin/thread.c)0
-rw-r--r--src/lib/runtime/extern.go (renamed from src/lib/runtime/runtime.go)0
-rw-r--r--src/lib/runtime/float.c (renamed from src/runtime/float.c)0
-rw-r--r--src/lib/runtime/float_go.cgo (renamed from src/runtime/float_go.cgo)0
-rw-r--r--src/lib/runtime/hashmap.c (renamed from src/runtime/hashmap.c)0
-rw-r--r--src/lib/runtime/hashmap.h (renamed from src/runtime/hashmap.h)0
-rw-r--r--src/lib/runtime/iface.c (renamed from src/runtime/iface.c)0
-rwxr-xr-xsrc/lib/runtime/linux/386/defs.h (renamed from src/runtime/linux/386/defs.h)0
-rwxr-xr-xsrc/lib/runtime/linux/386/rt0.s (renamed from src/runtime/linux/386/rt0.s)0
-rw-r--r--src/lib/runtime/linux/386/signal.c (renamed from src/runtime/linux/386/signal.c)0
-rwxr-xr-xsrc/lib/runtime/linux/386/sys.s (renamed from src/runtime/linux/386/sys.s)0
-rw-r--r--src/lib/runtime/linux/amd64/defs.h (renamed from src/runtime/linux/amd64/defs.h)0
-rw-r--r--src/lib/runtime/linux/amd64/rt0.s (renamed from src/runtime/linux/amd64/rt0.s)0
-rw-r--r--src/lib/runtime/linux/amd64/signal.c (renamed from src/runtime/linux/amd64/signal.c)0
-rw-r--r--src/lib/runtime/linux/amd64/sys.s (renamed from src/runtime/linux/amd64/sys.s)0
-rw-r--r--src/lib/runtime/linux/arm/defs.h (renamed from src/runtime/linux/arm/defs.h)0
-rw-r--r--src/lib/runtime/linux/arm/rt0.s (renamed from src/runtime/linux/arm/rt0.s)0
-rw-r--r--src/lib/runtime/linux/arm/signal.c (renamed from src/runtime/linux/arm/signal.c)0
-rw-r--r--src/lib/runtime/linux/arm/sys.s (renamed from src/runtime/linux/arm/sys.s)0
-rw-r--r--src/lib/runtime/linux/defs.c (renamed from src/runtime/linux/defs.c)0
-rw-r--r--src/lib/runtime/linux/defs1.c (renamed from src/runtime/linux/defs1.c)0
-rw-r--r--src/lib/runtime/linux/defs2.c (renamed from src/runtime/linux/defs2.c)0
-rw-r--r--src/lib/runtime/linux/defs_arm.c (renamed from src/runtime/linux/defs_arm.c)0
-rw-r--r--src/lib/runtime/linux/os.h (renamed from src/runtime/linux/os.h)0
-rw-r--r--src/lib/runtime/linux/signals.h (renamed from src/runtime/linux/signals.h)0
-rw-r--r--src/lib/runtime/linux/thread.c (renamed from src/runtime/linux/thread.c)0
-rw-r--r--src/lib/runtime/malloc.c (renamed from src/runtime/malloc.c)0
-rw-r--r--src/lib/runtime/malloc.h (renamed from src/runtime/malloc.h)0
-rw-r--r--src/lib/runtime/malloc_go.cgo (renamed from src/runtime/malloc_go.cgo)0
-rw-r--r--src/lib/runtime/mcache.c (renamed from src/runtime/mcache.c)0
-rw-r--r--src/lib/runtime/mcentral.c (renamed from src/runtime/mcentral.c)0
-rw-r--r--src/lib/runtime/mem.c (renamed from src/runtime/mem.c)0
-rw-r--r--src/lib/runtime/mfixalloc.c (renamed from src/runtime/mfixalloc.c)0
-rw-r--r--src/lib/runtime/mgc0.c (renamed from src/runtime/mgc0.c)0
-rw-r--r--src/lib/runtime/mheap.c (renamed from src/runtime/mheap.c)0
-rw-r--r--src/lib/runtime/mheapmap32.c (renamed from src/runtime/mheapmap32.c)0
-rw-r--r--src/lib/runtime/mheapmap32.h (renamed from src/runtime/mheapmap32.h)0
-rw-r--r--src/lib/runtime/mheapmap64.c (renamed from src/runtime/mheapmap64.c)0
-rw-r--r--src/lib/runtime/mheapmap64.h (renamed from src/runtime/mheapmap64.h)0
-rw-r--r--src/lib/runtime/msize.c (renamed from src/runtime/msize.c)0
-rw-r--r--src/lib/runtime/print.c (renamed from src/runtime/print.c)0
-rw-r--r--src/lib/runtime/proc.c (renamed from src/runtime/proc.c)0
-rw-r--r--src/lib/runtime/rune.c (renamed from src/runtime/rune.c)15
-rw-r--r--src/lib/runtime/runtime.c (renamed from src/runtime/runtime.c)0
-rw-r--r--src/lib/runtime/runtime.h (renamed from src/runtime/runtime.h)0
-rw-r--r--src/lib/runtime/sema.c (renamed from src/runtime/sema.c)0
-rw-r--r--src/lib/runtime/sema_go.cgo (renamed from src/runtime/sema_go.cgo)0
-rw-r--r--src/lib/runtime/string.c (renamed from src/runtime/string.c)0
-rw-r--r--src/lib/runtime/symtab.c (renamed from src/runtime/symtab.c)0
-rw-r--r--src/runtime/Makefile119
75 files changed, 15 insertions, 119 deletions
diff --git a/src/runtime/386/asm.s b/src/lib/runtime/386/asm.s
index 5d3c4261a..5d3c4261a 100644
--- a/src/runtime/386/asm.s
+++ b/src/lib/runtime/386/asm.s
diff --git a/src/runtime/386/closure.c b/src/lib/runtime/386/closure.c
index 6ccbe3b8b..6ccbe3b8b 100644
--- a/src/runtime/386/closure.c
+++ b/src/lib/runtime/386/closure.c
diff --git a/src/runtime/386/traceback.c b/src/lib/runtime/386/traceback.c
index 05724d9ac..05724d9ac 100644
--- a/src/runtime/386/traceback.c
+++ b/src/lib/runtime/386/traceback.c
diff --git a/src/runtime/386/vlop.s b/src/lib/runtime/386/vlop.s
index 803276ce2..803276ce2 100755
--- a/src/runtime/386/vlop.s
+++ b/src/lib/runtime/386/vlop.s
diff --git a/src/runtime/386/vlrt.c b/src/lib/runtime/386/vlrt.c
index 093cca70d..093cca70d 100755
--- a/src/runtime/386/vlrt.c
+++ b/src/lib/runtime/386/vlrt.c
diff --git a/src/runtime/amd64/asm.s b/src/lib/runtime/amd64/asm.s
index 6fc01bbc9..6fc01bbc9 100644
--- a/src/runtime/amd64/asm.s
+++ b/src/lib/runtime/amd64/asm.s
diff --git a/src/runtime/amd64/closure.c b/src/lib/runtime/amd64/closure.c
index 5717d3c5e..5717d3c5e 100644
--- a/src/runtime/amd64/closure.c
+++ b/src/lib/runtime/amd64/closure.c
diff --git a/src/runtime/amd64/traceback.c b/src/lib/runtime/amd64/traceback.c
index 16d7bed72..16d7bed72 100644
--- a/src/runtime/amd64/traceback.c
+++ b/src/lib/runtime/amd64/traceback.c
diff --git a/src/runtime/arm/asm.s b/src/lib/runtime/arm/asm.s
index 232ab4ddf..232ab4ddf 100644
--- a/src/runtime/arm/asm.s
+++ b/src/lib/runtime/arm/asm.s
diff --git a/src/runtime/arm/closure.c b/src/lib/runtime/arm/closure.c
index 024018d5a..024018d5a 100644
--- a/src/runtime/arm/closure.c
+++ b/src/lib/runtime/arm/closure.c
diff --git a/src/runtime/arm/traceback.s b/src/lib/runtime/arm/traceback.s
index e69de29bb..e69de29bb 100644
--- a/src/runtime/arm/traceback.s
+++ b/src/lib/runtime/arm/traceback.s
diff --git a/src/runtime/array.c b/src/lib/runtime/array.c
index bbd57b03e..bbd57b03e 100644
--- a/src/runtime/array.c
+++ b/src/lib/runtime/array.c
diff --git a/src/runtime/cgo2c.c b/src/lib/runtime/cgo2c.c
index 3905f7e6d..3905f7e6d 100644
--- a/src/runtime/cgo2c.c
+++ b/src/lib/runtime/cgo2c.c
diff --git a/src/runtime/chan.c b/src/lib/runtime/chan.c
index be65bcbc1..be65bcbc1 100644
--- a/src/runtime/chan.c
+++ b/src/lib/runtime/chan.c
diff --git a/src/runtime/darwin/386/defs.h b/src/lib/runtime/darwin/386/defs.h
index b66a5d8b4..b66a5d8b4 100644
--- a/src/runtime/darwin/386/defs.h
+++ b/src/lib/runtime/darwin/386/defs.h
diff --git a/src/runtime/darwin/386/rt0.s b/src/lib/runtime/darwin/386/rt0.s
index 5b52e912c..5b52e912c 100755
--- a/src/runtime/darwin/386/rt0.s
+++ b/src/lib/runtime/darwin/386/rt0.s
diff --git a/src/runtime/darwin/386/signal.c b/src/lib/runtime/darwin/386/signal.c
index 3a63c4b38..3a63c4b38 100644
--- a/src/runtime/darwin/386/signal.c
+++ b/src/lib/runtime/darwin/386/signal.c
diff --git a/src/runtime/darwin/386/sys.s b/src/lib/runtime/darwin/386/sys.s
index bbcb622d5..bbcb622d5 100644
--- a/src/runtime/darwin/386/sys.s
+++ b/src/lib/runtime/darwin/386/sys.s
diff --git a/src/runtime/darwin/amd64/defs.h b/src/lib/runtime/darwin/amd64/defs.h
index 1076e4c10..1076e4c10 100644
--- a/src/runtime/darwin/amd64/defs.h
+++ b/src/lib/runtime/darwin/amd64/defs.h
diff --git a/src/runtime/darwin/amd64/rt0.s b/src/lib/runtime/darwin/amd64/rt0.s
index 0a0011781..0a0011781 100644
--- a/src/runtime/darwin/amd64/rt0.s
+++ b/src/lib/runtime/darwin/amd64/rt0.s
diff --git a/src/runtime/darwin/amd64/signal.c b/src/lib/runtime/darwin/amd64/signal.c
index 45e5e8d47..45e5e8d47 100644
--- a/src/runtime/darwin/amd64/signal.c
+++ b/src/lib/runtime/darwin/amd64/signal.c
diff --git a/src/runtime/darwin/amd64/sys.s b/src/lib/runtime/darwin/amd64/sys.s
index b46c823ae..b46c823ae 100644
--- a/src/runtime/darwin/amd64/sys.s
+++ b/src/lib/runtime/darwin/amd64/sys.s
diff --git a/src/runtime/darwin/defs.c b/src/lib/runtime/darwin/defs.c
index 1ed662957..1ed662957 100644
--- a/src/runtime/darwin/defs.c
+++ b/src/lib/runtime/darwin/defs.c
diff --git a/src/runtime/darwin/os.h b/src/lib/runtime/darwin/os.h
index 2a3ca87bd..2a3ca87bd 100644
--- a/src/runtime/darwin/os.h
+++ b/src/lib/runtime/darwin/os.h
diff --git a/src/runtime/darwin/signals.h b/src/lib/runtime/darwin/signals.h
index 4051dc4dc..4051dc4dc 100644
--- a/src/runtime/darwin/signals.h
+++ b/src/lib/runtime/darwin/signals.h
diff --git a/src/runtime/darwin/thread.c b/src/lib/runtime/darwin/thread.c
index 79267085e..79267085e 100644
--- a/src/runtime/darwin/thread.c
+++ b/src/lib/runtime/darwin/thread.c
diff --git a/src/lib/runtime/runtime.go b/src/lib/runtime/extern.go
index 6fb5756d6..6fb5756d6 100644
--- a/src/lib/runtime/runtime.go
+++ b/src/lib/runtime/extern.go
diff --git a/src/runtime/float.c b/src/lib/runtime/float.c
index 5122f359a..5122f359a 100644
--- a/src/runtime/float.c
+++ b/src/lib/runtime/float.c
diff --git a/src/runtime/float_go.cgo b/src/lib/runtime/float_go.cgo
index 518d55950..518d55950 100644
--- a/src/runtime/float_go.cgo
+++ b/src/lib/runtime/float_go.cgo
diff --git a/src/runtime/hashmap.c b/src/lib/runtime/hashmap.c
index b3022ca14..b3022ca14 100644
--- a/src/runtime/hashmap.c
+++ b/src/lib/runtime/hashmap.c
diff --git a/src/runtime/hashmap.h b/src/lib/runtime/hashmap.h
index ff93e9ee3..ff93e9ee3 100644
--- a/src/runtime/hashmap.h
+++ b/src/lib/runtime/hashmap.h
diff --git a/src/runtime/iface.c b/src/lib/runtime/iface.c
index 6c933b1b2..6c933b1b2 100644
--- a/src/runtime/iface.c
+++ b/src/lib/runtime/iface.c
diff --git a/src/runtime/linux/386/defs.h b/src/lib/runtime/linux/386/defs.h
index 112fc7b09..112fc7b09 100755
--- a/src/runtime/linux/386/defs.h
+++ b/src/lib/runtime/linux/386/defs.h
diff --git a/src/runtime/linux/386/rt0.s b/src/lib/runtime/linux/386/rt0.s
index 7717c37e8..7717c37e8 100755
--- a/src/runtime/linux/386/rt0.s
+++ b/src/lib/runtime/linux/386/rt0.s
diff --git a/src/runtime/linux/386/signal.c b/src/lib/runtime/linux/386/signal.c
index 7dfca6bb4..7dfca6bb4 100644
--- a/src/runtime/linux/386/signal.c
+++ b/src/lib/runtime/linux/386/signal.c
diff --git a/src/runtime/linux/386/sys.s b/src/lib/runtime/linux/386/sys.s
index 419973a5c..419973a5c 100755
--- a/src/runtime/linux/386/sys.s
+++ b/src/lib/runtime/linux/386/sys.s
diff --git a/src/runtime/linux/amd64/defs.h b/src/lib/runtime/linux/amd64/defs.h
index 43b047523..43b047523 100644
--- a/src/runtime/linux/amd64/defs.h
+++ b/src/lib/runtime/linux/amd64/defs.h
diff --git a/src/runtime/linux/amd64/rt0.s b/src/lib/runtime/linux/amd64/rt0.s
index 55be5bcee..55be5bcee 100644
--- a/src/runtime/linux/amd64/rt0.s
+++ b/src/lib/runtime/linux/amd64/rt0.s
diff --git a/src/runtime/linux/amd64/signal.c b/src/lib/runtime/linux/amd64/signal.c
index 55215176d..55215176d 100644
--- a/src/runtime/linux/amd64/signal.c
+++ b/src/lib/runtime/linux/amd64/signal.c
diff --git a/src/runtime/linux/amd64/sys.s b/src/lib/runtime/linux/amd64/sys.s
index f90c704fa..f90c704fa 100644
--- a/src/runtime/linux/amd64/sys.s
+++ b/src/lib/runtime/linux/amd64/sys.s
diff --git a/src/runtime/linux/arm/defs.h b/src/lib/runtime/linux/arm/defs.h
index caad66989..caad66989 100644
--- a/src/runtime/linux/arm/defs.h
+++ b/src/lib/runtime/linux/arm/defs.h
diff --git a/src/runtime/linux/arm/rt0.s b/src/lib/runtime/linux/arm/rt0.s
index 024547ddd..024547ddd 100644
--- a/src/runtime/linux/arm/rt0.s
+++ b/src/lib/runtime/linux/arm/rt0.s
diff --git a/src/runtime/linux/arm/signal.c b/src/lib/runtime/linux/arm/signal.c
index 024018d5a..024018d5a 100644
--- a/src/runtime/linux/arm/signal.c
+++ b/src/lib/runtime/linux/arm/signal.c
diff --git a/src/runtime/linux/arm/sys.s b/src/lib/runtime/linux/arm/sys.s
index f5db32305..f5db32305 100644
--- a/src/runtime/linux/arm/sys.s
+++ b/src/lib/runtime/linux/arm/sys.s
diff --git a/src/runtime/linux/defs.c b/src/lib/runtime/linux/defs.c
index 35fa02953..35fa02953 100644
--- a/src/runtime/linux/defs.c
+++ b/src/lib/runtime/linux/defs.c
diff --git a/src/runtime/linux/defs1.c b/src/lib/runtime/linux/defs1.c
index 0fe3506ad..0fe3506ad 100644
--- a/src/runtime/linux/defs1.c
+++ b/src/lib/runtime/linux/defs1.c
diff --git a/src/runtime/linux/defs2.c b/src/lib/runtime/linux/defs2.c
index aa0331a37..aa0331a37 100644
--- a/src/runtime/linux/defs2.c
+++ b/src/lib/runtime/linux/defs2.c
diff --git a/src/runtime/linux/defs_arm.c b/src/lib/runtime/linux/defs_arm.c
index eaec05154..eaec05154 100644
--- a/src/runtime/linux/defs_arm.c
+++ b/src/lib/runtime/linux/defs_arm.c
diff --git a/src/runtime/linux/os.h b/src/lib/runtime/linux/os.h
index c61619367..c61619367 100644
--- a/src/runtime/linux/os.h
+++ b/src/lib/runtime/linux/os.h
diff --git a/src/runtime/linux/signals.h b/src/lib/runtime/linux/signals.h
index 1fb49c513..1fb49c513 100644
--- a/src/runtime/linux/signals.h
+++ b/src/lib/runtime/linux/signals.h
diff --git a/src/runtime/linux/thread.c b/src/lib/runtime/linux/thread.c
index cc9ba161b..cc9ba161b 100644
--- a/src/runtime/linux/thread.c
+++ b/src/lib/runtime/linux/thread.c
diff --git a/src/runtime/malloc.c b/src/lib/runtime/malloc.c
index 81cdfb300..81cdfb300 100644
--- a/src/runtime/malloc.c
+++ b/src/lib/runtime/malloc.c
diff --git a/src/runtime/malloc.h b/src/lib/runtime/malloc.h
index 9b3d6b811..9b3d6b811 100644
--- a/src/runtime/malloc.h
+++ b/src/lib/runtime/malloc.h
diff --git a/src/runtime/malloc_go.cgo b/src/lib/runtime/malloc_go.cgo
index 6dcdaece2..6dcdaece2 100644
--- a/src/runtime/malloc_go.cgo
+++ b/src/lib/runtime/malloc_go.cgo
diff --git a/src/runtime/mcache.c b/src/lib/runtime/mcache.c
index ae2594023..ae2594023 100644
--- a/src/runtime/mcache.c
+++ b/src/lib/runtime/mcache.c
diff --git a/src/runtime/mcentral.c b/src/lib/runtime/mcentral.c
index 5c9f720c0..5c9f720c0 100644
--- a/src/runtime/mcentral.c
+++ b/src/lib/runtime/mcentral.c
diff --git a/src/runtime/mem.c b/src/lib/runtime/mem.c
index 7ed299eb0..7ed299eb0 100644
--- a/src/runtime/mem.c
+++ b/src/lib/runtime/mem.c
diff --git a/src/runtime/mfixalloc.c b/src/lib/runtime/mfixalloc.c
index dd4f3f251..dd4f3f251 100644
--- a/src/runtime/mfixalloc.c
+++ b/src/lib/runtime/mfixalloc.c
diff --git a/src/runtime/mgc0.c b/src/lib/runtime/mgc0.c
index d58d6ce44..d58d6ce44 100644
--- a/src/runtime/mgc0.c
+++ b/src/lib/runtime/mgc0.c
diff --git a/src/runtime/mheap.c b/src/lib/runtime/mheap.c
index d0cf2237b..d0cf2237b 100644
--- a/src/runtime/mheap.c
+++ b/src/lib/runtime/mheap.c
diff --git a/src/runtime/mheapmap32.c b/src/lib/runtime/mheapmap32.c
index 420ca2d83..420ca2d83 100644
--- a/src/runtime/mheapmap32.c
+++ b/src/lib/runtime/mheapmap32.c
diff --git a/src/runtime/mheapmap32.h b/src/lib/runtime/mheapmap32.h
index 0a16ccd10..0a16ccd10 100644
--- a/src/runtime/mheapmap32.h
+++ b/src/lib/runtime/mheapmap32.h
diff --git a/src/runtime/mheapmap64.c b/src/lib/runtime/mheapmap64.c
index 1886ba529..1886ba529 100644
--- a/src/runtime/mheapmap64.c
+++ b/src/lib/runtime/mheapmap64.c
diff --git a/src/runtime/mheapmap64.h b/src/lib/runtime/mheapmap64.h
index 127b773f7..127b773f7 100644
--- a/src/runtime/mheapmap64.h
+++ b/src/lib/runtime/mheapmap64.h
diff --git a/src/runtime/msize.c b/src/lib/runtime/msize.c
index 25e22637d..25e22637d 100644
--- a/src/runtime/msize.c
+++ b/src/lib/runtime/msize.c
diff --git a/src/runtime/print.c b/src/lib/runtime/print.c
index 5295e338d..5295e338d 100644
--- a/src/runtime/print.c
+++ b/src/lib/runtime/print.c
diff --git a/src/runtime/proc.c b/src/lib/runtime/proc.c
index 1d065e6d2..1d065e6d2 100644
--- a/src/runtime/proc.c
+++ b/src/lib/runtime/proc.c
diff --git a/src/runtime/rune.c b/src/lib/runtime/rune.c
index 2acf421cb..ca4f9ac6a 100644
--- a/src/runtime/rune.c
+++ b/src/lib/runtime/rune.c
@@ -1,6 +1,21 @@
/*
* The authors of this software are Rob Pike and Ken Thompson.
* Copyright (c) 2002 by Lucent Technologies.
+ * Portions Copyright 2009 The Go Authors. All rights reserved.
+ * Permission to use, copy, modify, and distribute this software for any
+ * purpose without fee is hereby granted, provided that this entire notice
+ * is included in all copies of any software which is or includes a copy
+ * or modification of this software and in all copies of the supporting
+ * documentation for such software.
+ * THIS SOFTWARE IS BEING PROVIDED "AS IS", WITHOUT ANY EXPRESS OR IMPLIED
+ * WARRANTY. IN PARTICULAR, NEITHER THE AUTHORS NOR LUCENT TECHNOLOGIES MAKE ANY
+ * REPRESENTATION OR WARRANTY OF ANY KIND CONCERNING THE MERCHANTABILITY
+ * OF THIS SOFTWARE OR ITS FITNESS FOR ANY PARTICULAR PURPOSE.
+ */
+
+/*
+ * The authors of this software are Rob Pike and Ken Thompson.
+ * Copyright (c) 2002 by Lucent Technologies.
* Permission to use, copy, modify, and distribute this software for any
* purpose without fee is hereby granted, provided that this entire notice
* is included in all copies of any software which is or includes a copy
diff --git a/src/runtime/runtime.c b/src/lib/runtime/runtime.c
index c5ba3e6a5..c5ba3e6a5 100644
--- a/src/runtime/runtime.c
+++ b/src/lib/runtime/runtime.c
diff --git a/src/runtime/runtime.h b/src/lib/runtime/runtime.h
index 749364f95..749364f95 100644
--- a/src/runtime/runtime.h
+++ b/src/lib/runtime/runtime.h
diff --git a/src/runtime/sema.c b/src/lib/runtime/sema.c
index 5e5b07aa6..5e5b07aa6 100644
--- a/src/runtime/sema.c
+++ b/src/lib/runtime/sema.c
diff --git a/src/runtime/sema_go.cgo b/src/lib/runtime/sema_go.cgo
index eb4082a0d..eb4082a0d 100644
--- a/src/runtime/sema_go.cgo
+++ b/src/lib/runtime/sema_go.cgo
diff --git a/src/runtime/string.c b/src/lib/runtime/string.c
index 5bfe8196f..5bfe8196f 100644
--- a/src/runtime/string.c
+++ b/src/lib/runtime/string.c
diff --git a/src/runtime/symtab.c b/src/lib/runtime/symtab.c
index b4802715e..b4802715e 100644
--- a/src/runtime/symtab.c
+++ b/src/lib/runtime/symtab.c
diff --git a/src/runtime/Makefile b/src/runtime/Makefile
deleted file mode 100644
index ad236491f..000000000
--- a/src/runtime/Makefile
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 2009 The Go Authors. All rights reserved.
-# Use of this source code is governed by a BSD-style
-# license that can be found in the LICENSE file.
-
-# Set SIZE to 32 or 64.
-SIZE_386=32
-SIZE_amd64=64
-SIZE_arm=32
-SIZE=$(SIZE_$(GOARCH))
-
-# Setup CFLAGS. Add -D_64BIT on 64-bit platforms (sorry).
-CFLAGS_64=-D_64BIT
-CFLAGS=-I$(GOOS) -I$(GOOS)/$(GOARCH) -wF $(CFLAGS_$(SIZE))
-
-# Set O to right letter.
-O_386=8
-O_amd64=6
-O_arm=5
-O=$(O_$(GOARCH))
-
-# Tools
-CC=$(O)c
-AS=$(O)a
-AR=6ar # sic
-
-LIB=lib.a
-
-# 386-specific object files
-OFILES_386=\
- vlop.$O\
- vlrt.$O\
-
-OFILES=\
- array.$O\
- asm.$O\
- chan.$O\
- closure.$O\
- float.$O\
- float_go.$O\
- hashmap.$O\
- iface.$O\
- malloc.$O\
- malloc_go.$O\
- mcache.$O\
- mcentral.$O\
- mem.$O\
- mfixalloc.$O\
- mgc0.$O\
- mheap.$O\
- mheapmap$(SIZE).$O\
- msize.$O\
- print.$O\
- proc.$O\
- rune.$O\
- runtime.$O\
- rt0.$O\
- sema.$O\
- sema_go.$O\
- signal.$O\
- string.$O\
- symtab.$O\
- sys.$O\
- thread.$O\
- traceback.$O\
- $(OFILES_$(GOARCH))\
-
-HFILES=\
- runtime.h\
- hashmap.h\
- malloc.h\
- $(GOOS)/os.h\
- $(GOOS)/$(GOARCH)/defs.h\
-
-install: $(LIB) runtime.acid
- cp $(LIB) $(GOROOT)/lib/lib_$(GOARCH)_$(GOOS).a
- cp runtime.acid $(GOROOT)/acid/runtime.acid
-
-$(LIB): $(OFILES)
- $(AR) rc $(LIB) $(OFILES)
-
-$(OFILES): $(HFILES)
-
-nuke:
- rm -f *.[568] *.a $(GOROOT)/lib/$(LIB)
-
-clean:
- rm -f *.[568] *.a runtime.acid cgo2c
-
-%.$O: %.c
- $(CC) $(CFLAGS) $<
-
-%.$O: $(GOARCH)/%.c
- $(CC) $(CFLAGS) $<
-
-%.$O: $(GOOS)/%.c
- $(CC) $(CFLAGS) $<
-
-%.$O: $(GOOS)/$(GOARCH)/%.c
- $(CC) $(CFLAGS) $<
-
-%.$O: $(GOARCH)/%.s
- $(AS) $<
-
-%.$O: $(GOOS)/$(GOARCH)/%.s
- $(AS) $<
-
-cgo2c: cgo2c.c
- quietgcc -o $@ $<
-
-%.c: %.cgo cgo2c
- ./cgo2c $< > $@.tmp
- mv -f $@.tmp $@
-
-runtime.acid: runtime.h proc.c
- $(CC) -a proc.c >runtime.acid
-
-chan.acid: runtime.h chan.c
- $(CC) -a chan.c >chan.acid
-