summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoachim Breitner <nomeata@debian.org>2010-05-07 21:35:18 +0400
committerJoachim Breitner <nomeata@debian.org>2010-05-07 21:35:18 +0400
commit553ffa89324a4b38ea12674ae4174e45cc3329ac (patch)
tree79a60d03f0fa8f3282b763cfc7c22022d119efba
parent0e44a2927d3ba6b4348b2dffb0196997ac64f32f (diff)
downloadDHG_packages-553ffa89324a4b38ea12674ae4174e45cc3329ac.tar.gz
haskell-hsh: Add threaded flag to cabal file and implement logic in debian/rules to detect whether a threaded runtime is available at build time. (Closes: #542842)
-rw-r--r--p/haskell-hsh/debian/changelog8
-rwxr-xr-xp/haskell-hsh/debian/rules3
2 files changed, 11 insertions, 0 deletions
diff --git a/p/haskell-hsh/debian/changelog b/p/haskell-hsh/debian/changelog
index c049a96ae..35c668b89 100644
--- a/p/haskell-hsh/debian/changelog
+++ b/p/haskell-hsh/debian/changelog
@@ -1,3 +1,11 @@
+haskell-hsh (2.0.3-3) UNRELEASED; urgency=low
+
+ * Add threaded flag to cabal file and implement logic in debian/rules to
+ detect whether a threaded runtime is available at build time. (Closes:
+ #542842)
+
+ -- Joachim Breitner <nomeata@debian.org> Fri, 07 May 2010 19:34:25 +0200
+
haskell-hsh (2.0.3-2) unstable; urgency=low
[ Erik de Castro Lopo ]
diff --git a/p/haskell-hsh/debian/rules b/p/haskell-hsh/debian/rules
index bc087e2c1..44e0d20f7 100755
--- a/p/haskell-hsh/debian/rules
+++ b/p/haskell-hsh/debian/rules
@@ -1,5 +1,8 @@
#!/usr/bin/make -f
+# If no threaded RTS is found, disable it
+DEB_SETUP_GHC6_CONFIGURE_ARGS := $(shell test -e /usr/lib/ghc-$(GHC6_VERSION)/libHSrts_thr.a || echo --flags=-threaded)
+
# Standard way of building Haskell libraries .
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/hlibrary.mk