summaryrefslogtreecommitdiff
path: root/p/haskell-regex-base/debian/rules
diff options
context:
space:
mode:
authorJoachim Breitner <mail@joachim-breitner.de>2009-11-18 17:05:10 +0300
committerJoachim Breitner <mail@joachim-breitner.de>2009-11-18 17:05:10 +0300
commit25253b324ed43c85f251c4f93063711d43378fd8 (patch)
treedb8102fed0d4399299a989cab9427886e8a266fd /p/haskell-regex-base/debian/rules
parent28b44517810ee4c088071575efc72b041c2adcd6 (diff)
downloadDHG_packages-25253b324ed43c85f251c4f93063711d43378fd8.tar.gz
haskell-regex-base: Use hlibrary.mk (Closes: #556806)
Diffstat (limited to 'p/haskell-regex-base/debian/rules')
-rwxr-xr-xp/haskell-regex-base/debian/rules78
1 files changed, 2 insertions, 76 deletions
diff --git a/p/haskell-regex-base/debian/rules b/p/haskell-regex-base/debian/rules
index 4c8999a65..683e77bcf 100755
--- a/p/haskell-regex-base/debian/rules
+++ b/p/haskell-regex-base/debian/rules
@@ -1,78 +1,4 @@
#!/usr/bin/make -f
-# -*- makefile -*-
-#
-# Based on dh-make template containing work of Joey Hess, Craig Small
-# and Bill Allombert.
-#
-# Include dpatch
-include /usr/share/dpatch/dpatch.make
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# This has to be exported to make some magic below work.
-export DH_OPTIONS
-
-
-setup: patch-stamp
- dh_testdir
- ghc --make Setup -o setup -package Cabal
-
-build: build-stamp
-build-stamp: setup
- touch $@
-
-clean: clean-patched unpatch
-clean-patched:
- dh_testdir
- dh_testroot
- rm -f build-stamp
- if [ -x setup ] && [ -e .setup-config ]; then ./setup clean ; fi
- rm -rf setup Setup.hi Setup.ho Setup.o .*config* dist html
- dh_clean
-
-install: install-arch install-indep
-install-arch: build-stamp
- dh_testdir
- dh_testroot
- dh_clean -k -s
- dh_installdirs -s
- dh_haskell -s
- dh_install -s
-
-install-indep: build-stamp
- dh_testdir
- dh_testroot
- dh_clean -k -i
- dh_installdirs -i
- dh_haskell -i
- dh_install -i
-
-# Must not depend on anything. This is to be called by
-# binary-arch/binary-indep
-# in another 'make' thread.
-binary-common:
- dh_testdir
- dh_testroot
- dh_installchangelogs
- dh_installdocs
- dh_compress -X.haddock
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_haskell_depends
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-# Build architecture independant packages using the common target.
-binary-indep: install-indep
- $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
-
-# Build architecture dependant packages using the common target.
-binary-arch: install-arch
- $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
-
-binary: binary-arch binary-indep
-.PHONY: binary binary-arch binary-indep build clean clean-patched install install-arch install-indep
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/hlibrary.mk