summaryrefslogtreecommitdiff
path: root/upgrade.sh
diff options
context:
space:
mode:
authorJoachim Breitner <mail@joachim-breitner.de>2015-08-13 13:52:27 +0200
committerJoachim Breitner <mail@joachim-breitner.de>2015-08-13 13:55:28 +0200
commit1605b1de66bc43497e7464d53d8ef6a1ca1e4dcb (patch)
treece209e887e1884cfa66f4b79dbddca2e10458ed0 /upgrade.sh
parent7d976944016e146843a6a0929674f767b6a60ee3 (diff)
downloadDHG_packages-1605b1de66bc43497e7464d53d8ef6a1ca1e4dcb.tar.gz
Remove scripts
and refer to pkg-haskell-tools in the README.
Diffstat (limited to 'upgrade.sh')
-rwxr-xr-xupgrade.sh73
1 files changed, 0 insertions, 73 deletions
diff --git a/upgrade.sh b/upgrade.sh
deleted file mode 100755
index 23f5fd106..000000000
--- a/upgrade.sh
+++ /dev/null
@@ -1,73 +0,0 @@
-#!/bin/bash
-
-set -e
-
-if [ ! -d debian ]
-then
- echo "No debian/ directory found!"
- echo "Run me in the packaging directory."
- exit 1
-fi
-
-if [ "$1" = "-D" ]
-then
- dist="$2"
- shift
- shift
-else
- dist=unstable
-fi
-
-
-cabal_name="$(cat debian/watch | grep http | cut -d/ -f5)"
-package="$(grep-dctrl -n -s Source . < debian/control)"
-old_version=`dpkg-parsechangelog -ldebian/changelog -c1 | grep-dctrl -n -s Version .`
-old_version=`echo $old_version | cut -d- -f1` # this could be improved
-if echo $old_version | fgrep -q : ; then
- old_version=`echo $old_version | cut -d: -f2-`
- epoch=`echo $old_version | cut -d: -f1`:
-else
- epoch=''
-fi
-
-version=$(grep "^$cabal_name " ../../../package-plan/packages.txt|cut -d\ -f2)
-
-if [ -z "$version" ]
-then
- echo "could not detect version to upgrade to."
- exit 1
-fi
-
-if [ "$version" = "$old_version" ]
-then
- echo "No new version to upgrade to."
- exit 1
-fi
-
-debchange --changelog debian/changelog --newversion="$epoch$version-1" 'New upstream release'
-origtargz -u
-
-if grep -q '^DEB_ENABLE_TESTS = yes' debian/rules
-then
- test=""
-else
- test="--no-tests"
-fi
-
-cabal-debian --official --upgrade $test
-find debian/ -name '*~' -delete
-
-dch -D $dist -r ''
-
-git commit . -q -m "$cabal_name: Upgrading from $old_version to $version"
-
-echo "Upgraded $cabal_name to $version"
-echo "Please check git show HEAD for sanity."
-echo "Please check http://hdiff.luite.com/cgit/$cabal_name/diff/?id=$version&id2=$old_version for interesting changes."
-if test -d debian/patches
-then
- echo "Please refresh the patches"
-fi
-
-
-