summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Koch <konqueror@gmx.de>2007-06-28 15:14:46 +0000
committerMichael Koch <konqueror@gmx.de>2007-06-28 15:14:46 +0000
commit9a22f5239e74868ae877ed4449deb1cb2e36b102 (patch)
treec32c92152a5c645e1bdde19f0843d0954d68f0de
parentcd7eefa4b3b2a78c822904c5d2ac09a3f035c675 (diff)
downloadjava-common-9a22f5239e74868ae877ed4449deb1cb2e36b102.tar.gz
java-common (0.26) unstable; urgency=lowdebian/0.26
* Fixed typo in package description. Closes: #363985. -- Michael Koch <konqueror@gmx.de> Thu, 28 Jun 2007 13:12:04 -0100
-rw-r--r--Makefile8
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rw-r--r--etc/jvm6
-rw-r--r--share/java-common.sh36
-rwxr-xr-xshare/jvm-find.sh5
6 files changed, 14 insertions, 49 deletions
diff --git a/Makefile b/Makefile
index 1234fca..8acb798 100644
--- a/Makefile
+++ b/Makefile
@@ -56,13 +56,19 @@ policy.txt: policy.xml
#-rm -f dump.html
jw -b txt $(DSL) $<
-install: debian-java-policy-install debian-java-faq-install dummy-install
+install: debian-java-policy-install debian-java-faq-install dummy-install script-install
dummy-install:
mkdir -p $(PUBLISHDIR)/dummy-packages
cp dummy/README $(PUBLISHDIR)/dummy-packages
cp dummy/*.control $(PUBLISHDIR)/dummy-packages
+script-install:
+ mkdir -p $(DESTDIR)/usr/sbin
+ install -m 755 scripts/update-java-alternatives $(DESTDIR)/usr/sbin/
+ mkdir -p $(DESTDIR)/usr/share/man/man8
+ install -m 755 scripts/update-java-alternatives.8 $(DESTDIR)/usr/share/man/man8/
+
debian-java-policy-install:
install -m 0444 $(OUTPUTS) $(PUBLISHDIR)
cp -a debian-java-policy $(PUBLISHDIR)
diff --git a/debian/changelog b/debian/changelog
index c6f5b7e..5975e3b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+java-common (0.26) unstable; urgency=low
+
+ * Fixed typo in package description. Closes: #363985.
+
+ -- Michael Koch <konqueror@gmx.de> Thu, 28 Jun 2007 13:12:04 -0100
+
java-common (0.25) unstable; urgency=low
[Matthias Klose]
diff --git a/debian/control b/debian/control
index 45c1f58..0f880f0 100644
--- a/debian/control
+++ b/debian/control
@@ -19,5 +19,5 @@ Description: Base of all Java packages
* The Debian-Java-FAQ which provides information on the status of
Java support in Debian, available compilers, virtual machines, Java
programs and libraries as well as on legal issues.
- * Information on how to create dummy packages to fullfill java2
+ * Information on how to create dummy packages to fulfill java2
requirements.
diff --git a/etc/jvm b/etc/jvm
deleted file mode 100644
index 7f94252..0000000
--- a/etc/jvm
+++ /dev/null
@@ -1,6 +0,0 @@
-# This file defines the default system JVM search order. Each
-# JVM should list their JAVA_HOME compatible directory in this file.
-# The default system JVM is the first one available from top to
-# bottom.
-
-/usr
diff --git a/share/java-common.sh b/share/java-common.sh
deleted file mode 100644
index c0db858..0000000
--- a/share/java-common.sh
+++ /dev/null
@@ -1,36 +0,0 @@
-function jvm_scan_file() {
- file="$1"
-
- grep -v '#' "$file" | while read jvm; do
- if [ -n "$jvm" -a -x "$jvm/bin/java" ]; then
- echo -n $jvm
- return
- fi
- done
-}
-
-function jvm_find() {
- local jvm
-
- if [ -n "$JAVA_HOME" ]; then
- jvm="$JAVA_HOME"
- fi
-
- for file in \
- "$HOME/.jvm.d/$1" \
- "$HOME/.jvm" \
- "/etc/jvm.d/$1" \
- "/etc/jvm"; do \
- if [ -z "$jvm" ]; then
- if [ -r "$file" ]; then
- jvm="$(jvm_scan_file "$file")"
- fi
- fi
- done
-
- echo -n "$jvm"
-}
-
-function jvm_config() {
- echo JAVA_HOME="$(jvm_find "$1")"
-}
diff --git a/share/jvm-find.sh b/share/jvm-find.sh
deleted file mode 100755
index 653e2e7..0000000
--- a/share/jvm-find.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-. $(dirname $0)/java-common.sh
-
-jvm_config "$@"