summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Klose <doko@debian.org>2009-05-18 11:31:58 +0000
committerMatthias Klose <doko@debian.org>2009-05-18 11:31:58 +0000
commitf95174aab19c714cb8a5317cda739351e3d9e3f6 (patch)
tree666cffdcc25b2ff647a09cbd1d8f1306348aac34
parent593755e13197f317ab6a6ecc4ff2cf83e0966976 (diff)
downloadjava-common-debian/0.32.tar.gz
java-common (0.32) unstable; urgency=lowdebian/0.32
* Build the default-* packages on hppa. -- Matthias Klose <doko@debian.org> Sun, 17 May 2009 23:21:22 +0200 java-common (0.31) unstable; urgency=low * Build the default-* packages on alpha again. -- Matthias Klose <doko@debian.org> Sun, 01 Feb 2009 12:41:46 +0100
-rw-r--r--debian/changelog12
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules13
3 files changed, 26 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 316ab0a..201ae52 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+java-common (0.32) unstable; urgency=low
+
+ * Build the default-* packages on hppa.
+
+ -- Matthias Klose <doko@debian.org> Sun, 17 May 2009 23:21:22 +0200
+
+java-common (0.31) unstable; urgency=low
+
+ * Build the default-* packages on alpha again.
+
+ -- Matthias Klose <doko@debian.org> Sun, 01 Feb 2009 12:41:46 +0100
+
java-common (0.30) unstable; urgency=low
* Fix description generation for default-jre. Closes: #476978.
diff --git a/debian/control b/debian/control
index 2deadac..beb84bd 100644
--- a/debian/control
+++ b/debian/control
@@ -5,11 +5,11 @@ Maintainer: Debian Java Mailing List <debian-java@lists.debian.org>
Uploaders: Stefan Gybas <sgybas@debian.org>, Arnaud Vandyck <avdyk@debian.org>, Michael Koch <konqueror@gmx.de>, Matthias Klose <doko@debian.org>
Build-Depends: debhelper (>= 5)
Build-Depends-Indep: debiandoc-sgml, docbook-utils, docbook-xml, dpsyco-devel, lynx
-Standards-Version: 3.7.3
+Standards-Version: 3.8.1
Package: java-common
Architecture: all
-Suggests: equivs
+Suggests: default-jre, equivs
Description: Base of all Java packages
This package must be installed in the system if a Java environment
is desired. It covers useful information for Java users in
diff --git a/debian/rules b/debian/rules
index e9c3757..f69bbae 100755
--- a/debian/rules
+++ b/debian/rules
@@ -25,12 +25,23 @@ provides = java java2 java5
dversion = 1.5-$(jrel)
jvmdir = java-gcj
-ifneq (,$(filter $(DEB_HOST_ARCH), alpha arm hppa))
+ifneq (,$(filter $(DEB_HOST_ARCH), arm))
p_jre =
p_headless =
p_jdk =
endif
+ifneq (,$(filter $(DEB_HOST_ARCH), hppa))
+ p_jre = gcj-jre
+ p_jhl = gcj-jre-headless
+ p_jdk = gcj-jdk
+ v_jre =
+ v_jdk =
+ provides = java java2 java5
+ dversion = 1.5-$(jrel)
+ jvmdir = java-gcj
+endif
+
jre_provides = $(call mk_cslist,$(provides),runtime)
jhl_provides = $(call mk_cslist,$(provides),runtime-headless)
jdk_provides = $(call mk_cslist,$(provides),sdk)