summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmmanuel Bourg <ebourg@apache.org>2015-09-25 17:43:09 +0200
committerEmmanuel Bourg <ebourg@apache.org>2015-09-25 17:43:09 +0200
commitb5b8cfafdf9d2743d9ee29b5fab49206d2c3155f (patch)
treef07644ea631b27f5d547d923742f5a67cd534129
parent1b427e72e04f473cc4c21e43d023cd40242d9561 (diff)
downloadjava-common-b5b8cfafdf9d2743d9ee29b5fab49206d2c3155f.tar.gz
Vertical alignment for update-java-alternatives --list
-rw-r--r--debian/changelog1
-rwxr-xr-xscripts/update-java-alternatives2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 0ca4f03..c3e5620 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ java-common (0.54) UNRELEASED; urgency=medium
* Team upload.
* Use OpenJDK 8 on mips, mipsel and mips64el.
* update-java-alternatives now supports bash completion (Closes: #777550)
+ * The output of update-java-alternatives --list is now aligned vertically
* Removed the unused classpath-from-jars-1 example
* Removed the old dummy control files
* Removed the README about the old default-jdk-builddep transition
diff --git a/scripts/update-java-alternatives b/scripts/update-java-alternatives
index 6dbc92b..9eea19c 100755
--- a/scripts/update-java-alternatives
+++ b/scripts/update-java-alternatives
@@ -123,7 +123,7 @@ do_list()
alias=$(basename ${i%.jinfo})
alias=${alias#.}
prio=$(awk -F= '/priority=/ {print $2}' $i)
- echo $alias $prio $top/$alias
+ printf "%-30s %-10s %s\n" $alias "$prio " $top/$alias
[ -n "$verbose" ] && egrep "$which" $i
done
}