summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--debian/java-compiler-dummy.postinst.debhelper14
-rw-r--r--debian/java-compiler-dummy.prerm.debhelper10
-rw-r--r--debian/java-virtual-machine-dummy.postinst.debhelper14
-rw-r--r--debian/java-virtual-machine-dummy.prerm.debhelper10
-rwxr-xr-xpublish.sh4
6 files changed, 2 insertions, 52 deletions
diff --git a/Makefile b/Makefile
index 529f8f7..240ddf7 100644
--- a/Makefile
+++ b/Makefile
@@ -17,6 +17,8 @@ LANG=C
LC_CTYPE=C
all: debian-java-policy debian-java-faq-gen
+publish: policy.html
+ scp debian-java-policy.html/*.html opal@people.debian.org:public_html/java/policy.html
# Policy part
MAKEOUT=policy.txt policy.ps
diff --git a/debian/java-compiler-dummy.postinst.debhelper b/debian/java-compiler-dummy.postinst.debhelper
deleted file mode 100644
index 7ae4911..0000000
--- a/debian/java-compiler-dummy.postinst.debhelper
+++ /dev/null
@@ -1,14 +0,0 @@
-# Automatically added by dh_installdocs
-if [ "$1" = "configure" ]; then
- if [ -d /usr/doc -a ! -e /usr/doc/java-compiler-dummy -a -d /usr/share/doc/java-compiler-dummy ]; then
- ln -sf ../share/doc/java-compiler-dummy /usr/doc/java-compiler-dummy
- fi
-fi
-# End automatically added section
-# Automatically added by dh_installdocs
-if [ "$1" = "configure" ]; then
- if [ -d /usr/doc -a ! -e /usr/doc/java-compiler-dummy -a -d /usr/share/doc/java-compiler-dummy ]; then
- ln -sf ../share/doc/java-compiler-dummy /usr/doc/java-compiler-dummy
- fi
-fi
-# End automatically added section
diff --git a/debian/java-compiler-dummy.prerm.debhelper b/debian/java-compiler-dummy.prerm.debhelper
deleted file mode 100644
index d0e11ef..0000000
--- a/debian/java-compiler-dummy.prerm.debhelper
+++ /dev/null
@@ -1,10 +0,0 @@
-# Automatically added by dh_installdocs
-if [ \( "$1" = "upgrade" -o "$1" = "remove" \) -a -L /usr/doc/java-compiler-dummy ]; then
- rm -f /usr/doc/java-compiler-dummy
-fi
-# End automatically added section
-# Automatically added by dh_installdocs
-if [ \( "$1" = "upgrade" -o "$1" = "remove" \) -a -L /usr/doc/java-compiler-dummy ]; then
- rm -f /usr/doc/java-compiler-dummy
-fi
-# End automatically added section
diff --git a/debian/java-virtual-machine-dummy.postinst.debhelper b/debian/java-virtual-machine-dummy.postinst.debhelper
deleted file mode 100644
index 4516d13..0000000
--- a/debian/java-virtual-machine-dummy.postinst.debhelper
+++ /dev/null
@@ -1,14 +0,0 @@
-# Automatically added by dh_installdocs
-if [ "$1" = "configure" ]; then
- if [ -d /usr/doc -a ! -e /usr/doc/java-virtual-machine-dummy -a -d /usr/share/doc/java-virtual-machine-dummy ]; then
- ln -sf ../share/doc/java-virtual-machine-dummy /usr/doc/java-virtual-machine-dummy
- fi
-fi
-# End automatically added section
-# Automatically added by dh_installdocs
-if [ "$1" = "configure" ]; then
- if [ -d /usr/doc -a ! -e /usr/doc/java-virtual-machine-dummy -a -d /usr/share/doc/java-virtual-machine-dummy ]; then
- ln -sf ../share/doc/java-virtual-machine-dummy /usr/doc/java-virtual-machine-dummy
- fi
-fi
-# End automatically added section
diff --git a/debian/java-virtual-machine-dummy.prerm.debhelper b/debian/java-virtual-machine-dummy.prerm.debhelper
deleted file mode 100644
index 88265c5..0000000
--- a/debian/java-virtual-machine-dummy.prerm.debhelper
+++ /dev/null
@@ -1,10 +0,0 @@
-# Automatically added by dh_installdocs
-if [ \( "$1" = "upgrade" -o "$1" = "remove" \) -a -L /usr/doc/java-virtual-machine-dummy ]; then
- rm -f /usr/doc/java-virtual-machine-dummy
-fi
-# End automatically added section
-# Automatically added by dh_installdocs
-if [ \( "$1" = "upgrade" -o "$1" = "remove" \) -a -L /usr/doc/java-virtual-machine-dummy ]; then
- rm -f /usr/doc/java-virtual-machine-dummy
-fi
-# End automatically added section
diff --git a/publish.sh b/publish.sh
deleted file mode 100755
index 0c6fe4c..0000000
--- a/publish.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-
-make policy.html
-scp debian-java-policy.html/*html opal@people.debian.org:public_html/java