summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog10
-rw-r--r--debian/java-common.doc-base.faq2
-rwxr-xr-xscripts/update-java-alternatives4
-rw-r--r--scripts/update-java-alternatives.88
4 files changed, 15 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 04bfb7d..076084b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,6 @@
-java-common (0.28) unstable; urgency=low
+java-common (0.28) UNRELEASED; urgency=low
+ [Matthias Klose]
* Build packages default-jre, default-jre-headless, default-jdk
and default-jdk-builddep.
Provides an abstraction for the preferred jre/jdk for a specific
@@ -9,7 +10,12 @@ java-common (0.28) unstable; urgency=low
http://lists.debian.org/debian-java/2008/03/msg00007.html.
* update-java-alternatives: Add --jre-headless option.
- -- Matthias Klose <doko@debian.org> Wed, 05 Mar 2008 18:52:44 +0100
+ [Michael Koch]
+ * Fix issues in scripts/update-java-alternatives.8
+ * Converted debian/java-common.doc-base.faq to utf-8 encoding.
+ * Fix bug in scripts/update-java-alternatives when usage is shown.
+
+ -- Michael Koch <konqueror@gmx.de> Tue, 01 Apr 2008 08:16:44 +0200
java-common (0.27) unstable; urgency=low
diff --git a/debian/java-common.doc-base.faq b/debian/java-common.doc-base.faq
index b37d7f5..84dfab0 100644
--- a/debian/java-common.doc-base.faq
+++ b/debian/java-common.doc-base.faq
@@ -1,6 +1,6 @@
Document: debian-java-faq
Title: Debian Java FAQ
-Author: Javier Fernández-Sanguino Peña
+Author: Javier Fernández-Sanguino Peña
Abstract: The Debian Java FAQ provide answers to many
usual questions regarding the use of the Java programming
language in the Debian GNU/Linux operating system. It
diff --git a/scripts/update-java-alternatives b/scripts/update-java-alternatives
index 71bc479..bffaa70 100755
--- a/scripts/update-java-alternatives
+++ b/scripts/update-java-alternatives
@@ -63,8 +63,8 @@ while [ "$#" -gt 0 ]; do
shift
done
-#[ "$#" -eq 0 ] || usage 1
-#[ -n "$action" ] || usage 1
+[ "$#" -eq 0 ] || usage 1
+[ -n "$action" ] || usage 1
which='^(hl|jre|jdk|plugin|DUMMY) '
if [ -n "$hlonly$jreonly$pluginonly" ]; then
diff --git a/scripts/update-java-alternatives.8 b/scripts/update-java-alternatives.8
index ebac2ea..07c4bcf 100644
--- a/scripts/update-java-alternatives.8
+++ b/scripts/update-java-alternatives.8
@@ -3,10 +3,10 @@
update-java-alternatives \- update alternatives for jre/sdk installations
.SH SYNOPSIS
.B update-java-alternatives [--jre] [--plugin] [-t|--test|-v|--verbose]
- -l|--list [<jname>]
- -s|--set <jname>
- -a|--auto
- -h|-?|--help
+ \-l|--list [<jname>]
+ \-s|--set <jname>
+ \-a|--auto
+ \-h|\-?|--help
.SH DESCRIPTION
update-java-alternatives updates all alternatives belonging to one runtime
or development kit for the Java language. A package does provide these