summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaximiliano Curia <maxy@debian.org>2014-02-05 15:11:54 +0100
committerMaximiliano Curia <maxy@debian.org>2014-02-05 15:11:54 +0100
commit7d9e428ca654b7d12e7fda76a2df1976bec95d13 (patch)
treec7ac1498edd0d8cee2795aa5de3d9ed702873a79
parent69dc9f29d8f0a5517d441197066a7150ad335d5c (diff)
downloadkde4libs-7d9e428ca654b7d12e7fda76a2df1976bec95d13.tar.gz
Refresh patches.
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/default_kde4_xdg_menu_prefix.diff18
-rw-r--r--debian/patches/hack_in_etc_kde4_in_kstandarddirs.diff10
-rw-r--r--debian/patches/hurd_support.diff24
-rw-r--r--debian/patches/kfreebsd_acl.diff8
-rw-r--r--debian/patches/kfreebsd_support.diff26
-rw-r--r--debian/patches/make_libkdeinit4_private.diff52
-rw-r--r--debian/patches/relax_plugin_kde_version_check.diff20
-rw-r--r--debian/patches/series1
9 files changed, 89 insertions, 72 deletions
diff --git a/debian/changelog b/debian/changelog
index b852f91..16691bf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,8 @@ kde4libs (4:4.12.2-1) UNRELEASED; urgency=medium
* New upstream release.
* Confirm symbols.
* Bump Standards-Version to 3.9.5, no changes needed.
+ * Remove patch: fix_kptyprocesstest.diff
+ * Refresh patches.
-- Maximiliano Curia <maxy@debian.org> Wed, 05 Feb 2014 14:39:15 +0100
diff --git a/debian/patches/default_kde4_xdg_menu_prefix.diff b/debian/patches/default_kde4_xdg_menu_prefix.diff
index 1e8c236..434c373 100644
--- a/debian/patches/default_kde4_xdg_menu_prefix.diff
+++ b/debian/patches/default_kde4_xdg_menu_prefix.diff
@@ -3,9 +3,11 @@
kded/vfolder_menu.cpp | 7 ++++---
2 files changed, 5 insertions(+), 4 deletions(-)
---- a/kded/CMakeLists.txt
-+++ b/kded/CMakeLists.txt
-@@ -74,7 +74,7 @@ install(TARGETS kbuildsycoca4 ${INSTALL_
+Index: kde4libs/kded/CMakeLists.txt
+===================================================================
+--- kde4libs.orig/kded/CMakeLists.txt 2014-02-05 14:54:26.195883775 +0100
++++ kde4libs/kded/CMakeLists.txt 2014-02-05 14:54:26.195883775 +0100
+@@ -74,7 +74,7 @@
if (WIN32)
install( FILES applications.menu DESTINATION ${SHARE_INSTALL_PREFIX}/xdg/menus )
else (WIN32)
@@ -14,9 +16,11 @@
endif (WIN32)
install( FILES kdedmodule.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
install( FILES kded.upd DESTINATION ${DATA_INSTALL_DIR}/kconf_update )
---- a/kded/vfolder_menu.cpp
-+++ b/kded/vfolder_menu.cpp
-@@ -770,8 +770,10 @@ VFolderMenu::locateMenuFile(const QStrin
+Index: kde4libs/kded/vfolder_menu.cpp
+===================================================================
+--- kde4libs.orig/kded/vfolder_menu.cpp 2014-02-05 14:54:26.195883775 +0100
++++ kde4libs/kded/vfolder_menu.cpp 2014-02-05 14:54:26.195883775 +0100
+@@ -774,8 +774,10 @@
QString result;
QString xdgMenuPrefix = QString::fromLocal8Bit(qgetenv("XDG_MENU_PREFIX"));
@@ -29,7 +33,7 @@
QFileInfo fileInfo(fileName);
QString fileNameOnly = fileInfo.fileName();
-@@ -781,7 +783,6 @@ VFolderMenu::locateMenuFile(const QStrin
+@@ -785,7 +787,6 @@
QString baseName = QDir::cleanPath(m_docInfo.baseDir +
fileInfo.path() + '/' + fileNameOnly);
result = KStandardDirs::locate("xdgconf-menu", baseName);
diff --git a/debian/patches/hack_in_etc_kde4_in_kstandarddirs.diff b/debian/patches/hack_in_etc_kde4_in_kstandarddirs.diff
index d7a74da..13a864c 100644
--- a/debian/patches/hack_in_etc_kde4_in_kstandarddirs.diff
+++ b/debian/patches/hack_in_etc_kde4_in_kstandarddirs.diff
@@ -10,10 +10,12 @@ The priorities is as follows:
With this patch, we can also install all config files into /usr/ as they just can get
overridden by adding new files to /etc/kde4 by the sysadm.
---- a/kdecore/kernel/kstandarddirs.cpp
-+++ b/kdecore/kernel/kstandarddirs.cpp
-@@ -1175,6 +1175,10 @@ QStringList KStandardDirs::KStandardDirs
- if ((local || testdir.exists()) && !candidates.contains(path))
+Index: kde4libs/kdecore/kernel/kstandarddirs.cpp
+===================================================================
+--- kde4libs.orig/kdecore/kernel/kstandarddirs.cpp 2014-02-05 14:54:48.376405206 +0100
++++ kde4libs/kdecore/kernel/kstandarddirs.cpp 2014-02-05 14:54:48.372405112 +0100
+@@ -1167,6 +1167,10 @@
+ if ((local || testdir.exists()) && !candidates.contains(path, cs))
candidates.append(path);
}
+ // UGLY HACK - forward porting Chris CHeney's HACK - Rex Dieter
diff --git a/debian/patches/hurd_support.diff b/debian/patches/hurd_support.diff
index a1a5a06..7e5d389 100644
--- a/debian/patches/hurd_support.diff
+++ b/debian/patches/hurd_support.diff
@@ -6,11 +6,13 @@ Description: preliminary GNU/Hurd support
which are not implemented and will always fail.
Forwarded: no
Last-Update: 2012-10-01
---- a/kdecore/kernel/kstandarddirs.cpp
-+++ b/kdecore/kernel/kstandarddirs.cpp
-@@ -73,6 +73,10 @@
- #include <QtCore/QFileInfo>
- #include <QtCore/QSettings>
+Index: kde4libs/kdecore/kernel/kstandarddirs.cpp
+===================================================================
+--- kde4libs.orig/kdecore/kernel/kstandarddirs.cpp 2014-02-05 14:55:06.328827225 +0100
++++ kde4libs/kdecore/kernel/kstandarddirs.cpp 2014-02-05 14:55:06.328827225 +0100
+@@ -79,6 +79,10 @@
+ static Qt::CaseSensitivity cs = Qt::CaseSensitive;
+ #endif
+#ifndef MAXPATHLEN
+# define MAXPATHLEN 1024
@@ -19,8 +21,10 @@ Last-Update: 2012-10-01
class KStandardDirs::KStandardDirsPrivate
{
public:
---- a/kinit/lnusertemp.c
-+++ b/kinit/lnusertemp.c
+Index: kde4libs/kinit/lnusertemp.c
+===================================================================
+--- kde4libs.orig/kinit/lnusertemp.c 2014-02-05 14:55:06.328827225 +0100
++++ kde4libs/kinit/lnusertemp.c 2014-02-05 14:55:06.328827225 +0100
@@ -36,6 +36,10 @@
#include <limits.h>
#endif
@@ -32,8 +36,10 @@ Last-Update: 2012-10-01
int check_tmp_dir(const char *tmp_dir, int check_ownership);
int create_link(const char *file, const char *tmp_dir);
int build_link(const char* tmp, const char *tmp_prefix, const char *kde_prefix);
---- a/cmake/modules/FindKDE4Internal.cmake
-+++ b/cmake/modules/FindKDE4Internal.cmake
+Index: kde4libs/cmake/modules/FindKDE4Internal.cmake
+===================================================================
+--- kde4libs.orig/cmake/modules/FindKDE4Internal.cmake 2014-02-05 14:55:06.328827225 +0100
++++ kde4libs/cmake/modules/FindKDE4Internal.cmake 2014-02-05 14:55:06.328827225 +0100
@@ -1220,8 +1220,8 @@
endif (CMAKE_SYSTEM_NAME MATCHES Linux OR CMAKE_SYSTEM_NAME STREQUAL GNU OR CMAKE_SYSTEM_NAME MATCHES kFreeBSD)
diff --git a/debian/patches/kfreebsd_acl.diff b/debian/patches/kfreebsd_acl.diff
index a990afe..cadf256 100644
--- a/debian/patches/kfreebsd_acl.diff
+++ b/debian/patches/kfreebsd_acl.diff
@@ -1,7 +1,7 @@
-Index: kde4libs-4.11.3/kio/kfile/kpropertiesdialog.cpp
+Index: kde4libs/kio/kfile/kpropertiesdialog.cpp
===================================================================
---- kde4libs-4.11.3.orig/kio/kfile/kpropertiesdialog.cpp 2013-11-07 08:55:21.000000000 +0000
-+++ kde4libs-4.11.3/kio/kfile/kpropertiesdialog.cpp 2013-11-07 10:15:09.000000000 +0000
+--- kde4libs.orig/kio/kfile/kpropertiesdialog.cpp 2014-02-05 15:08:05.955141270 +0100
++++ kde4libs/kio/kfile/kpropertiesdialog.cpp 2014-02-05 15:08:05.951141176 +0100
@@ -53,6 +53,15 @@
#include <time.h>
#include <sys/stat.h>
@@ -18,7 +18,7 @@ Index: kde4libs-4.11.3/kio/kfile/kpropertiesdialog.cpp
}
#include <unistd.h>
#include <errno.h>
-@@ -1896,7 +1905,7 @@
+@@ -1889,7 +1898,7 @@
static bool fileSystemSupportsACL( const QByteArray& path )
{
bool fileSystemSupportsACLs = false;
diff --git a/debian/patches/kfreebsd_support.diff b/debian/patches/kfreebsd_support.diff
index ed25435..e33324d 100644
--- a/debian/patches/kfreebsd_support.diff
+++ b/debian/patches/kfreebsd_support.diff
@@ -5,8 +5,8 @@ cmake.
Index: kde4libs/ConfigureChecks.cmake
===================================================================
---- kde4libs.orig/ConfigureChecks.cmake 2013-09-04 11:33:40.403081551 +0000
-+++ kde4libs/ConfigureChecks.cmake 2013-09-04 11:33:40.323084729 +0000
+--- kde4libs.orig/ConfigureChecks.cmake 2014-02-05 14:54:38.164165135 +0100
++++ kde4libs/ConfigureChecks.cmake 2014-02-05 14:54:38.160165041 +0100
@@ -138,11 +138,11 @@
set(UTIL_LIBRARY util)
endif (login_in_libutil)
@@ -24,9 +24,9 @@ Index: kde4libs/ConfigureChecks.cmake
if (login_in_libutil)
Index: kde4libs/kio/kfile/kpropertiesdialog.cpp
===================================================================
---- kde4libs.orig/kio/kfile/kpropertiesdialog.cpp 2013-09-04 11:33:40.403081551 +0000
-+++ kde4libs/kio/kfile/kpropertiesdialog.cpp 2013-09-04 11:33:40.327084571 +0000
-@@ -1901,7 +1901,15 @@
+--- kde4libs.orig/kio/kfile/kpropertiesdialog.cpp 2014-02-05 14:54:38.164165135 +0100
++++ kde4libs/kio/kfile/kpropertiesdialog.cpp 2014-02-05 14:54:38.160165041 +0100
+@@ -1894,7 +1894,15 @@
fileSystemSupportsACLs = ( statfs( path.data(), &buf ) == 0 ) && ( buf.f_flags & MNT_ACLS );
#else
fileSystemSupportsACLs =
@@ -45,8 +45,8 @@ Index: kde4libs/kio/kfile/kpropertiesdialog.cpp
}
Index: kde4libs/kioslave/file/file.cpp
===================================================================
---- kde4libs.orig/kioslave/file/file.cpp 2013-09-04 11:33:40.403081551 +0000
-+++ kde4libs/kioslave/file/file.cpp 2013-09-04 11:33:40.331084412 +0000
+--- kde4libs.orig/kioslave/file/file.cpp 2014-02-05 14:54:38.164165135 +0100
++++ kde4libs/kioslave/file/file.cpp 2014-02-05 14:54:38.160165041 +0100
@@ -310,8 +310,10 @@
}
@@ -60,8 +60,8 @@ Index: kde4libs/kioslave/file/file.cpp
// This is mandatory in all slaves (for KRun/BrowserRun to work)
Index: kde4libs/kioslave/file/file_unix.cpp
===================================================================
---- kde4libs.orig/kioslave/file/file_unix.cpp 2013-09-04 11:33:40.403081551 +0000
-+++ kde4libs/kioslave/file/file_unix.cpp 2013-09-04 11:33:40.363083141 +0000
+--- kde4libs.orig/kioslave/file/file_unix.cpp 2014-02-05 14:54:38.164165135 +0100
++++ kde4libs/kioslave/file/file_unix.cpp 2014-02-05 14:54:38.160165041 +0100
@@ -145,8 +145,10 @@
}
@@ -86,8 +86,8 @@ Index: kde4libs/kioslave/file/file_unix.cpp
acl = acl_get_fd(src_fd);
Index: kde4libs/kpty/kpty.cpp
===================================================================
---- kde4libs.orig/kpty/kpty.cpp 2013-09-04 11:33:40.403081551 +0000
-+++ kde4libs/kpty/kpty.cpp 2013-09-04 11:33:40.399081710 +0000
+--- kde4libs.orig/kpty/kpty.cpp 2014-02-05 14:54:38.164165135 +0100
++++ kde4libs/kpty/kpty.cpp 2014-02-05 14:54:38.164165135 +0100
@@ -109,24 +109,24 @@
# define _NEW_TTY_CTRL
#endif
@@ -127,8 +127,8 @@ Index: kde4libs/kpty/kpty.cpp
#include <kdebug.h>
Index: kde4libs/cmake/modules/FindKDE4Internal.cmake
===================================================================
---- kde4libs.orig/cmake/modules/FindKDE4Internal.cmake 2013-09-04 11:33:40.403081551 +0000
-+++ kde4libs/cmake/modules/FindKDE4Internal.cmake 2013-09-04 11:35:51.201883364 +0000
+--- kde4libs.orig/cmake/modules/FindKDE4Internal.cmake 2014-02-05 14:54:38.164165135 +0100
++++ kde4libs/cmake/modules/FindKDE4Internal.cmake 2014-02-05 14:54:38.164165135 +0100
@@ -1093,7 +1093,7 @@
endif (APPLE)
diff --git a/debian/patches/make_libkdeinit4_private.diff b/debian/patches/make_libkdeinit4_private.diff
index 36c1560..4de849f 100644
--- a/debian/patches/make_libkdeinit4_private.diff
+++ b/debian/patches/make_libkdeinit4_private.diff
@@ -21,8 +21,8 @@ The patch also adds support for "kdeinit" resource type to KDE Platform
libraries.
Index: kde4libs/CreateKDELibsDependenciesFile.cmake
===================================================================
---- kde4libs.orig/CreateKDELibsDependenciesFile.cmake 2013-09-04 11:31:32.144178278 +0000
-+++ kde4libs/CreateKDELibsDependenciesFile.cmake 2013-09-04 11:31:32.128178914 +0000
+--- kde4libs.orig/CreateKDELibsDependenciesFile.cmake 2014-02-05 14:54:04.179366178 +0100
++++ kde4libs/CreateKDELibsDependenciesFile.cmake 2014-02-05 14:54:04.175366084 +0100
@@ -32,6 +32,7 @@
make_install_path_absolute(KDE4_LIB_INSTALL_DIR ${LIB_INSTALL_DIR})
make_install_path_absolute(KDE4_IMPORTS_INSTALL_DIR ${IMPORTS_INSTALL_DIR})
@@ -41,8 +41,8 @@ Index: kde4libs/CreateKDELibsDependenciesFile.cmake
set(KDE4_SBIN_INSTALL_DIR \"${KDE4_SBIN_INSTALL_DIR}\")
Index: kde4libs/cmake/modules/FindKDE4Internal.cmake
===================================================================
---- kde4libs.orig/cmake/modules/FindKDE4Internal.cmake 2013-09-04 11:31:32.144178278 +0000
-+++ kde4libs/cmake/modules/FindKDE4Internal.cmake 2013-09-04 11:31:32.128178914 +0000
+--- kde4libs.orig/cmake/modules/FindKDE4Internal.cmake 2014-02-05 14:54:04.179366178 +0100
++++ kde4libs/cmake/modules/FindKDE4Internal.cmake 2014-02-05 14:54:04.175366084 +0100
@@ -871,6 +871,7 @@
_set_fancy(INCLUDE_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/include" "The subdirectory to the header prefix")
@@ -51,7 +51,7 @@ Index: kde4libs/cmake/modules/FindKDE4Internal.cmake
_set_fancy(IMPORTS_INSTALL_DIR "${PLUGIN_INSTALL_DIR}/imports" "The subdirectory relative to the install prefix where imports will be installed")
_set_fancy(CONFIG_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/config" "The config file install dir")
_set_fancy(DATA_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/apps" "The parent directory where applications can install their data")
-@@ -1391,6 +1392,10 @@
+@@ -1406,6 +1407,10 @@
endif (CMAKE_C_COMPILER MATCHES "icc")
@@ -64,8 +64,8 @@ Index: kde4libs/cmake/modules/FindKDE4Internal.cmake
Index: kde4libs/cmake/modules/KDE4Macros.cmake
===================================================================
---- kde4libs.orig/cmake/modules/KDE4Macros.cmake 2013-09-04 11:31:32.144178278 +0000
-+++ kde4libs/cmake/modules/KDE4Macros.cmake 2013-09-04 11:31:32.132178755 +0000
+--- kde4libs.orig/cmake/modules/KDE4Macros.cmake 2014-02-05 14:54:04.179366178 +0100
++++ kde4libs/cmake/modules/KDE4Macros.cmake 2014-02-05 14:54:04.175366084 +0100
@@ -834,6 +834,17 @@
endif(NOT _res_position EQUAL -1)
endif (Q_WS_MAC)
@@ -86,8 +86,8 @@ Index: kde4libs/cmake/modules/KDE4Macros.cmake
Index: kde4libs/kinit/CMakeLists.txt
===================================================================
---- kde4libs.orig/kinit/CMakeLists.txt 2013-09-04 11:31:32.144178278 +0000
-+++ kde4libs/kinit/CMakeLists.txt 2013-09-04 11:31:32.132178755 +0000
+--- kde4libs.orig/kinit/CMakeLists.txt 2014-02-05 14:54:04.179366178 +0100
++++ kde4libs/kinit/CMakeLists.txt 2014-02-05 14:54:04.175366084 +0100
@@ -58,6 +58,17 @@
install(TARGETS kdeinit4 ${INSTALL_TARGETS_DEFAULT_ARGS} )
@@ -108,8 +108,8 @@ Index: kde4libs/kinit/CMakeLists.txt
set(kwrapper_SRCS kwrapper_win.cpp )
Index: kde4libs/config-prefix.h.cmake
===================================================================
---- kde4libs.orig/config-prefix.h.cmake 2013-09-04 11:31:32.144178278 +0000
-+++ kde4libs/config-prefix.h.cmake 2013-09-04 11:31:32.132178755 +0000
+--- kde4libs.orig/config-prefix.h.cmake 2014-02-05 14:54:04.179366178 +0100
++++ kde4libs/config-prefix.h.cmake 2014-02-05 14:54:04.175366084 +0100
@@ -12,6 +12,7 @@
#define __KDE_EXECPREFIX "NONE"
@@ -120,8 +120,8 @@ Index: kde4libs/config-prefix.h.cmake
#define INCLUDE_INSTALL_DIR "${INCLUDE_INSTALL_DIR}"
Index: kde4libs/kdecore/kde-config.cpp
===================================================================
---- kde4libs.orig/kdecore/kde-config.cpp 2013-09-04 11:31:32.144178278 +0000
-+++ kde4libs/kdecore/kde-config.cpp 2013-09-04 11:31:32.132178755 +0000
+--- kde4libs.orig/kdecore/kde-config.cpp 2014-02-05 14:54:04.179366178 +0100
++++ kde4libs/kdecore/kde-config.cpp 2014-02-05 14:54:04.175366084 +0100
@@ -144,6 +144,7 @@
"html", I18N_NOOP("HTML documentation"),
"icon", I18N_NOOP("Icons"),
@@ -132,9 +132,9 @@ Index: kde4libs/kdecore/kde-config.cpp
"locale", I18N_NOOP("Translation files for KLocale"),
Index: kde4libs/kdecore/kernel/kstandarddirs.cpp
===================================================================
---- kde4libs.orig/kdecore/kernel/kstandarddirs.cpp 2013-09-04 11:31:32.144178278 +0000
-+++ kde4libs/kdecore/kernel/kstandarddirs.cpp 2013-09-04 11:31:32.136178596 +0000
-@@ -165,6 +165,8 @@
+--- kde4libs.orig/kdecore/kernel/kstandarddirs.cpp 2014-02-05 14:54:04.179366178 +0100
++++ kde4libs/kdecore/kernel/kstandarddirs.cpp 2014-02-05 14:54:04.175366084 +0100
+@@ -171,6 +171,8 @@
menus
xdgconf-autostart
autostart
@@ -143,7 +143,7 @@ Index: kde4libs/kdecore/kernel/kstandarddirs.cpp
*/
static const char types_string[] =
-@@ -219,6 +221,8 @@
+@@ -225,6 +227,8 @@
"menus\0"
"xdgconf-autostart\0"
"autostart\0"
@@ -152,7 +152,7 @@ Index: kde4libs/kdecore/kernel/kstandarddirs.cpp
"\0";
static const int types_indices[] = {
-@@ -228,7 +232,7 @@
+@@ -234,7 +238,7 @@
248, 258, 275, 285, 301, 305, 309, 316,
326, 336, 354, 359, 377, 387, 403, 416,
429, 442, 448, 463, 471, 484, 504, 217,
@@ -163,8 +163,8 @@ Index: kde4libs/kdecore/kernel/kstandarddirs.cpp
static void tokenize(QStringList& token, const QString& str,
Index: kde4libs/kdecore/kernel/kstandarddirs_unix.cpp
===================================================================
---- kde4libs.orig/kdecore/kernel/kstandarddirs_unix.cpp 2013-09-04 11:31:32.144178278 +0000
-+++ kde4libs/kdecore/kernel/kstandarddirs_unix.cpp 2013-09-04 11:31:32.136178596 +0000
+--- kde4libs.orig/kdecore/kernel/kstandarddirs_unix.cpp 2014-02-05 14:54:04.179366178 +0100
++++ kde4libs/kdecore/kernel/kstandarddirs_unix.cpp 2014-02-05 14:54:04.175366084 +0100
@@ -40,6 +40,8 @@
return QFile::decodeName(KCFG_INSTALL_DIR "/");
if (strcmp("kdedir", type) == 0)
@@ -176,8 +176,8 @@ Index: kde4libs/kdecore/kernel/kstandarddirs_unix.cpp
if (strcmp("data", type) == 0)
Index: kde4libs/kdecore/kernel/kstandarddirs_win.cpp
===================================================================
---- kde4libs.orig/kdecore/kernel/kstandarddirs_win.cpp 2013-09-04 11:31:32.144178278 +0000
-+++ kde4libs/kdecore/kernel/kstandarddirs_win.cpp 2013-09-04 11:31:32.136178596 +0000
+--- kde4libs.orig/kdecore/kernel/kstandarddirs_win.cpp 2014-02-05 14:54:04.179366178 +0100
++++ kde4libs/kdecore/kernel/kstandarddirs_win.cpp 2014-02-05 14:54:04.175366084 +0100
@@ -47,6 +47,8 @@
return share() + QLatin1String("config.kcfg/");
if (strcmp("kdedir", type) == 0)
@@ -189,8 +189,8 @@ Index: kde4libs/kdecore/kernel/kstandarddirs_win.cpp
if (strcmp("data", type) == 0)
Index: kde4libs/kdecore/util/kpluginloader.cpp
===================================================================
---- kde4libs.orig/kdecore/util/kpluginloader.cpp 2013-09-04 11:31:32.144178278 +0000
-+++ kde4libs/kdecore/util/kpluginloader.cpp 2013-09-04 11:31:32.136178596 +0000
+--- kde4libs.orig/kdecore/util/kpluginloader.cpp 2014-02-05 14:54:04.179366178 +0100
++++ kde4libs/kdecore/util/kpluginloader.cpp 2014-02-05 14:54:04.175366084 +0100
@@ -113,6 +113,13 @@
libname = fileinfo.path() + QLatin1String("/lib") + fileinfo.fileName();
#endif
@@ -207,8 +207,8 @@ Index: kde4libs/kdecore/util/kpluginloader.cpp
if (!kdeinit) {
Index: kde4libs/kinit/kinit.cpp
===================================================================
---- kde4libs.orig/kinit/kinit.cpp 2013-09-04 11:31:32.144178278 +0000
-+++ kde4libs/kinit/kinit.cpp 2013-09-04 11:31:32.136178596 +0000
+--- kde4libs.orig/kinit/kinit.cpp 2014-02-05 14:54:04.179366178 +0100
++++ kde4libs/kinit/kinit.cpp 2014-02-05 14:54:04.175366084 +0100
@@ -498,11 +498,23 @@
// try to match an absolute path to an executable binary (either in bin/ or in libexec/)
// to a kdeinit module in the same prefix
diff --git a/debian/patches/relax_plugin_kde_version_check.diff b/debian/patches/relax_plugin_kde_version_check.diff
index de1c208..a16d31a 100644
--- a/debian/patches/relax_plugin_kde_version_check.diff
+++ b/debian/patches/relax_plugin_kde_version_check.diff
@@ -16,19 +16,23 @@ Forwarded: not-needed
Origin: vendor
Last-Update: 2010-06-22
---- a/kdecore/util/kpluginloader.cpp
-+++ b/kdecore/util/kpluginloader.cpp
-@@ -243,7 +243,6 @@ bool KPluginLoader::load()
+Index: kde4libs/kdecore/util/kpluginloader.cpp
+===================================================================
+--- kde4libs.orig/kdecore/util/kpluginloader.cpp 2014-02-05 15:07:11.485862527 +0100
++++ kde4libs/kdecore/util/kpluginloader.cpp 2014-02-05 15:07:30.750314800 +0100
+@@ -243,7 +243,6 @@
d->verificationData = (KDEPluginVerificationData *) lib.resolve("kde_plugin_verification_data");
if (d->verificationData) {
if (d->verificationData->dataVersion < KDEPluginVerificationData::PluginVerificationDataVersion
-- || (d->verificationData->KDEVersion > KDE_VERSION)
- || (KDE_VERSION_MAJOR << 16 != (d->verificationData->KDEVersion & 0xFF0000)))
+- || ((d->verificationData->KDEVersion & 0xFFFF00) > (KDE_VERSION & 0xFFFF00)) // newer minor version
+ || (KDE_VERSION_MAJOR << 16 != (d->verificationData->KDEVersion & 0xFF0000))) // different major version
{
d->errorString = i18n("The plugin '%1' uses an incompatible KDE library (%2).", d->name, QString::fromLatin1(d->verificationData->KDEVersionString));
---- a/plasma/version.cpp
-+++ b/plasma/version.cpp
-@@ -58,12 +58,11 @@ bool isPluginVersionCompatible(unsigned
+Index: kde4libs/plasma/version.cpp
+===================================================================
+--- kde4libs.orig/plasma/version.cpp 2014-02-05 15:07:11.485862527 +0100
++++ kde4libs/plasma/version.cpp 2014-02-05 15:07:11.485862527 +0100
+@@ -58,12 +58,11 @@
// we require PLASMA_VERSION_MAJOR and PLASMA_VERSION_MINOR
const quint32 minVersion = PLASMA_MAKE_VERSION(PLASMA_VERSION_MAJOR, 0, 0);
diff --git a/debian/patches/series b/debian/patches/series
index cd5bcc7..3d384b7 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -27,5 +27,4 @@ kde4libs_interpret_qvarianttype_as_qmetatypetype.diff
debian_standardsdirtest.diff
kstringhandlertest_fix.diff
disable_bogus_test.diff
-fix_kptyprocesstest.diff
disable_bogus_tests