summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2011-03-09 15:13:38 +0200
committerModestas Vainius <modestas@vainius.eu>2011-03-09 15:13:38 +0200
commit7b281b929718c1d195ed399a4765712930f83463 (patch)
tree82e44931c433746e1d62d7b59e282d4e60eb49e7
parent111c1694786d46f34d3569051c3b36f4109c3317 (diff)
downloadpkg-kde-tools-7b281b929718c1d195ed399a4765712930f83463.tar.gz
Prefix link_with_{as_needed,no_undefined} variables with dqk_.
Use more or less unified naming scheme.
-rw-r--r--qt-kde-team/2/debian-qt-kde.mk18
1 files changed, 9 insertions, 9 deletions
diff --git a/qt-kde-team/2/debian-qt-kde.mk b/qt-kde-team/2/debian-qt-kde.mk
index e42a23e..46106ef 100644
--- a/qt-kde-team/2/debian-qt-kde.mk
+++ b/qt-kde-team/2/debian-qt-kde.mk
@@ -21,22 +21,22 @@ $(call set_command_options,dh_auto_%, += --parallel)
# Link with --as-needed by default
# (subject to be moved to kde dh addon/debhelper buildsystem)
-link_with_as_needed ?= yes
-ifneq (,$(findstring yes, $(link_with_as_needed)))
- link_with_as_needed := no
+dqk_link_with_as_needed ?= yes
+ifneq (,$(findstring yes, $(dqk_link_with_as_needed)))
+ dqk_link_with_as_needed := no
ifeq (,$(findstring no-as-needed, $(DEB_BUILD_OPTIONS)))
- link_with_as_needed := yes
+ dqk_link_with_as_needed := yes
export LDFLAGS += -Wl,--as-needed
endif
endif
# Set the link_with_no_undefined=no in order to disable linking with
-# --no-undefined (default value is inherited from $(link_with_as_needed))
-link_with_no_undefined ?= $(link_with_as_needed)
-ifneq (,$(findstring yes, $(link_with_no_undefined)))
- link_with_no_undefined := no
+# --no-undefined (default value is inherited from $(dqk_link_with_as_needed))
+dqk_link_with_no_undefined ?= $(dqk_link_with_as_needed)
+ifneq (,$(findstring yes, $(dqk_link_with_no_undefined)))
+ dqk_link_with_no_undefined := no
ifeq (,$(findstring no-no-undefined, $(DEB_BUILD_OPTIONS)))
- link_with_no_undefined := yes
+ dqk_link_with_no_undefined := yes
export LDFLAGS += -Wl,--no-undefined
endif
endif