summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRohan Garg <rohan@kde.org>2014-09-01 15:52:31 +0200
committerRohan Garg <rohan@kde.org>2014-09-01 15:52:31 +0200
commit1387e463e59a9bef75cc8d2c26e5927600f309b8 (patch)
tree3e09479586e0dd25f6ec1b2d914d11337a660b63
parente90e2dbd7f1b0b7bf0e3644105838136c6bf24f6 (diff)
downloadpkg-kde-tools-1387e463e59a9bef75cc8d2c26e5927600f309b8.tar.gz
Use KDE_INSTALL_USE_QT_SYS_PATHS to do the right thing automatically.
and drop useless calls.
-rw-r--r--datalib/kf5_flags4
-rw-r--r--perllib/Debian/Debhelper/Buildsystem/kf5.pm1
-rw-r--r--qt-kde-team/3/debian-qt-kde.mk4
3 files changed, 1 insertions, 8 deletions
diff --git a/datalib/kf5_flags b/datalib/kf5_flags
index 287f837..a9aa075 100644
--- a/datalib/kf5_flags
+++ b/datalib/kf5_flags
@@ -1,6 +1,4 @@
-DCMAKE_BUILD_TYPE=Debian
-DCMAKE_USE_RELATIVE_PATHS=ON
--DCMAKE_INSTALL_QTPLUGINDIR=qt5/plugins
--DCMAKE_INSTALL_QTQUICKIMPORTSDIR=qt5/imports
--DCMAKE_INSTALL_QMLDIR=qt5/qml
-DCMAKE_INSTALL_SYSCONFDIR=/etc
+-DKDE_INSTALL_USE_QT_SYS_PATHS=ON
diff --git a/perllib/Debian/Debhelper/Buildsystem/kf5.pm b/perllib/Debian/Debhelper/Buildsystem/kf5.pm
index d7bbe68..0ffb779 100644
--- a/perllib/Debian/Debhelper/Buildsystem/kf5.pm
+++ b/perllib/Debian/Debhelper/Buildsystem/kf5.pm
@@ -44,7 +44,6 @@ sub get_kf5_flags {
# Unescape flags using shell
$flags = `$^X -w -Mstrict -e 'print join("\\x1e", \@ARGV);' -- $escaped_flags`;
- $flags = $flags . "\x1e-DECM_MKSPECS_INSTALL_DIR=/usr/lib/" . dpkg_architecture_value('DEB_HOST_MULTIARCH') . "/qt5/mkspecs/modules/";
return split("\x1e", $flags);
}
diff --git a/qt-kde-team/3/debian-qt-kde.mk b/qt-kde-team/3/debian-qt-kde.mk
index 8a3aa15..09c290a 100644
--- a/qt-kde-team/3/debian-qt-kde.mk
+++ b/qt-kde-team/3/debian-qt-kde.mk
@@ -52,10 +52,6 @@ ifneq (,$(findstring yes, $(dqk_link_with_no_undefined)))
endif
endif
-# Since cmake 2.6.2 or higher is required from now on, enable relative paths to
-# get more ccache hits.
-$(call set_command_options,dh_auto_configure, += "-u-DCMAKE_USE_RELATIVE_PATHS=ON")
-
# Run dh_sameversiondep
run_dh_sameversiondep:
dh_sameversiondep