summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Shachnev <mitya57@gmail.com>2014-05-03 10:15:01 +0400
committerDmitry Shachnev <mitya57@gmail.com>2014-05-03 10:15:01 +0400
commitb8f95bed1012b9a444650937f28fe920f77e7a84 (patch)
tree4849aeb202923bd69070b12205e8d2c2807c3fba
parent2c5f5f2c7741de5293788fdedf7ff0fe16c04d92 (diff)
downloadpkg-kde-tools-b8f95bed1012b9a444650937f28fe920f77e7a84.tar.gz
Apply a patch from Ubuntu to add arm64 and ppc64el support.
-rw-r--r--debian/changelog5
-rw-r--r--perllib/Debian/PkgKde/SymbolsHelper/Substs/TypeSubst.pm16
2 files changed, 13 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 2cda493..0e94477 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,10 @@
pkg-kde-tools (0.15.14) UNRELEASED; urgency=medium
+ [ William Grant ]
+ * perllib/Debian/PkgKde/SymbolsHelper/Substs/TypeSubst.pm:
+ - Anchor architecture matches to the ends of the string, to avoid
+ erroneously mapping qreal to float on arm64.
+ - Add arm64 and ppc64el to the 64-bit matches.
-- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Sat, 03 May 2014 10:12:14 +0400
diff --git a/perllib/Debian/PkgKde/SymbolsHelper/Substs/TypeSubst.pm b/perllib/Debian/PkgKde/SymbolsHelper/Substs/TypeSubst.pm
index 4cfe8da..77eb423 100644
--- a/perllib/Debian/PkgKde/SymbolsHelper/Substs/TypeSubst.pm
+++ b/perllib/Debian/PkgKde/SymbolsHelper/Substs/TypeSubst.pm
@@ -161,7 +161,7 @@ sub new {
sub _expand {
my ($self, $arch) = @_;
- return ($arch =~ /amd64|ia64|alpha|s390|sparc64|ppc64|mips64|mips64el/) ? "m" : "j";
+ return ($arch =~ /^(amd64|ia64|alpha|s390|s390x|sparc64|ppc64|ppc64el|mips64|mips64el|arm64)$/) ? 'm' : 'j';
}
package Debian::PkgKde::SymbolsHelper::Substs::TypeSubst::ssize_t;
@@ -180,7 +180,7 @@ sub new {
sub _expand {
my ($self, $arch) = @_;
- return ($arch =~ /amd64|ia64|alpha|s390|sparc64|ppc64|mips64|mips64el/) ? 'l' : 'i';
+ return ($arch =~ /^(amd64|ia64|alpha|s390|s390x|sparc64|ppc64|ppc64el|mips64|mips64el|arm64)$/) ? 'l' : 'i';
}
package Debian::PkgKde::SymbolsHelper::Substs::TypeSubst::int64_t;
@@ -199,7 +199,7 @@ sub new {
sub _expand {
my ($self, $arch) = @_;
- return ($arch =~ /amd64|ia64|alpha|s390x|sparc64|ppc64|mips64|mips64el/) ? 'l' : 'x';
+ return ($arch =~ /^(amd64|ia64|alpha|s390x|sparc64|ppc64|ppc64el|mips64|mips64el|arm64)$/) ? 'l' : 'x';
}
package Debian::PkgKde::SymbolsHelper::Substs::TypeSubst::uint64_t;
@@ -218,7 +218,7 @@ sub new {
sub _expand {
my ($self, $arch) = @_;
- return ($arch =~ /amd64|ia64|alpha|s390x|sparc64|ppc64|mips64|mips64el/) ? 'm' : 'y';
+ return ($arch =~ /^(amd64|ia64|alpha|s390x|sparc64|ppc64|ppc64el|mips64|mips64el|arm64)$/) ? 'm' : 'y';
}
package Debian::PkgKde::SymbolsHelper::Substs::TypeSubst::qptrdiff;
@@ -237,7 +237,7 @@ sub new {
sub _expand {
my ($self, $arch) = @_;
- return ($arch =~ /amd64|ia64|alpha|s390x|sparc64|ppc64|mips64|mips64el/) ? 'x' : 'i';
+ return ($arch =~ /^(amd64|ia64|alpha|s390x|sparc64|ppc64|ppc64el|mips64|mips64el|arm64)$/) ? 'x' : 'i';
}
package Debian::PkgKde::SymbolsHelper::Substs::TypeSubst::quintptr;
@@ -256,7 +256,7 @@ sub new {
sub _expand {
my ($self, $arch) = @_;
- return ($arch =~ /amd64|ia64|alpha|s390x|sparc64|ppc64|mips64|mips64el/) ? 'y' : 'j';
+ return ($arch =~ /^(amd64|ia64|alpha|s390x|sparc64|ppc64|ppc64el|mips64|mips64el|arm64)$/) ? 'y' : 'j';
}
package Debian::PkgKde::SymbolsHelper::Substs::TypeSubst::intptr_t;
@@ -275,7 +275,7 @@ sub new {
sub _expand {
my ($self, $arch) = @_;
- return ($arch =~ /amd64|ia64|alpha|s390x|sparc64|ppc64|mips64|mips64el/) ? 'l' : 'i';
+ return ($arch =~ /^(amd64|ia64|alpha|s390x|sparc64|ppc64|ppc64el|mips64|mips64el|arm64)$/) ? 'l' : 'i';
}
package Debian::PkgKde::SymbolsHelper::Substs::TypeSubst::qreal;
@@ -294,7 +294,7 @@ sub new {
sub _expand {
my ($self, $arch) = @_;
- return ($arch =~ /(arm|sh4)/) ? 'f' : 'd';
+ return ($arch =~ /^(arm|armeb|armel|armhf|sh4)$/) ? 'f' : 'd';
}
package Debian::PkgKde::SymbolsHelper::Substs::TypeSubst;