summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2010-06-04 01:03:33 +0300
committerModestas Vainius <modestas@vainius.eu>2010-06-04 01:03:33 +0300
commitfccfe43bb77c08788228bda20d5bbaa20cb44e84 (patch)
tree5b77ef9ea92f7e69428fa2fb3b563a5f449febae
parent23a8279a7d376825751c1a46bbbc3f02c0887a6a (diff)
downloadpkg-kde-tools-fccfe43bb77c08788228bda20d5bbaa20cb44e84.tar.gz
pkgkde-getbuildlogs: load HTTP::Request & friends in the INIT block.
This will pass syntax check without libwww-perl installed (Closes: #584375).
-rw-r--r--debian/changelog2
-rwxr-xr-xpkgkde-getbuildlogs12
2 files changed, 5 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index afef5a2..0039ca5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,7 @@
pkg-kde-tools (0.9.1) UNRELEASED; urgency=low
+ * pkgkde-getbuildlogs: load HTTP::Request & friends in the INIT block in
+ order to pass syntax check without libwww-perl installed (Closes: #584375).
-- Modestas Vainius <modax@debian.org> Fri, 04 Jun 2010 00:54:11 +0300
diff --git a/pkgkde-getbuildlogs b/pkgkde-getbuildlogs
index 4a39aca..4e9cdd7 100755
--- a/pkgkde-getbuildlogs
+++ b/pkgkde-getbuildlogs
@@ -26,21 +26,15 @@ use File::Spec;
use IO::Uncompress::Inflate qw(inflate);
# Load extra modules (from libwww-perl and its dependencies)
-BEGIN {
+INIT {
eval "use HTTP::Request";
if ($@) {
error "in order to use this utility, you have to install libwww-perl package";
}
+ eval "use URI; use URI::QueryParam; use URI::Escape;";
+ eval "use HTTP::Response; use LWP::UserAgent; use HTML::LinkExtor; use HTML::Parser;";
}
-use URI;
-use URI::QueryParam;
-use URI::Escape;
-use HTTP::Response;
-use LWP::UserAgent;
-use HTML::LinkExtor;
-use HTML::Parser;
-
sub usage {
usageerr "[ -d destdir ] [ -v version ] [ -a arch ] [ -o ] [ package ] [ distribution ]";
}