summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/README.Debian38
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control19
-rw-r--r--debian/copyright40
-rw-r--r--debian/install1
-rwxr-xr-xdebian/rules30
-rw-r--r--makefiles/1/cdbs/kde.mk8
-rw-r--r--makefiles/1/variables.mk18
9 files changed, 160 insertions, 0 deletions
diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644
index 0000000..e17ccfc
--- /dev/null
+++ b/debian/README.Debian
@@ -0,0 +1,38 @@
+pkg-kde-tools for Debian
+------------------------
+
+ These snippets should be universal usable. If your package uses cdbs, you should be able to just
+ include the kde4.mk file.
+ If you use other tools, include the variables.mk file and run cmake with $(DEB_CMAKE_KDE4_FLAGS) to get
+ the kde4 default vars.
+
+Examples:
+
+A cdbs using package:
+
+#!/usr/bin/make -f
+
+include /usr/share/pkg-kde-tools/makefiles/1/cdbs/kde.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+
+#end makefile
+
+A non-cdbs-using package could start with something like the following and end up like any other cmake using package.
+
+#!/usr/bin/make -f
+
+include /usr/share/pkg-kde-tools/makefiles/1/variables.mk
+
+builddir/Makefile:
+ mkdir -p builddir
+ cd builddir && cmake .. $(DEB_CMAKE_KDE4_FLAGS)
+
+build-stamp: builddir/Makefile
+ $(MAKE) -C builddir
+ touch $@
+
+#end snippet
+
+
+
+ -- Sune Vuorela <debian@pusling.com> Thu, 18 Sep 2008 21:39:35 +0200
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..e0b202e
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+pkg-kde-tools (0.1) unstable; urgency=low
+
+ * Initial Release.
+
+ -- Sune Vuorela <debian@pusling.com> Thu, 18 Sep 2008 21:39:35 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..12ac30e
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,19 @@
+Source: pkg-kde-tools
+Section: devel
+Priority: extra
+Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
+Build-Depends: debhelper (>= 5)
+Standards-Version: 3.8.0
+Uploaders: Sune Vuorela <debian@pusling.com>
+
+Package: pkg-kde-tools
+Architecture: all
+Suggests: debhelper, cdbs
+Description: common makesnippets and other build scripts for KDE4 related packages
+ This package contains makefiles setting the default build arguments for KDE4
+ packages.
+ .
+ Currently, it is only a few makesnippets, but it will grow larger in the future.
+ .
+ NOTE: if you use cdbs or debhelper, you need to build-depend on those as well,
+ as this package is expected to be useful in cases without debhelper or cdbs.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..756bea5
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,40 @@
+This package was debianized by Sune Vuorela <debian@pusling.com> on
+Thu, 18 Sep 2008 21:39:35 +0200.
+
+Upstream Authors:
+
+ Sune Vuorela <debian@pusling.com>
+ Modestas Vainius <modestas@vainius.eu>
+ Fathi Boudra <fabo@debian.org>
+ Ana Beatriz Guerrero Lopes <ana@debian.org>
+ Armin Berres <trigger+debian@space-based.de>
+
+Copyright:
+
+ Copyright 2007-2008 Sune Vuorela <debian@pusling.com>
+ Copyright 2007-2008 Modestas Vainius <modestat@vainius.eu>
+ Copyright 2007-2008 Fathi Boudra <fabo@debian.org>
+ Copyright 2007-2008 Ana Beatriz Guerrero Lopes <ana@debian.org>
+ Copyright 2007-2008 Armin Berres <trigger+debian@space-based.de>
+
+License:
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL-2'.
+
+The Debian packaging is (C) 2008, Sune Vuorela <debian@pusling.com> and
+is licensed under any license, including the GPL, see above.
diff --git a/debian/install b/debian/install
new file mode 100644
index 0000000..adf8c68
--- /dev/null
+++ b/debian/install
@@ -0,0 +1 @@
+makefiles /usr/share/pkg-kde-tools/
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..db23f73
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,30 @@
+#!/usr/bin/make -f
+build:
+ #nop - just a set of scripts.
+
+clean:
+ dh_testdir
+ dh_testroot
+ dh_clean
+
+binary-arch:
+ #policy requires this.
+
+binary-indep:
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep
+.PHONY: clean binary-indep binary-arch binary build
diff --git a/makefiles/1/cdbs/kde.mk b/makefiles/1/cdbs/kde.mk
new file mode 100644
index 0000000..264d8b6
--- /dev/null
+++ b/makefiles/1/cdbs/kde.mk
@@ -0,0 +1,8 @@
+include /usr/share/cdbs/1/class/cmake.mk
+
+# Include default KDE 4 cmake configuration variables
+include /usr/share/pkg-kde-tools/makefiles/1/variables.mk
+# Pass standard KDE 4 flags to cmake via appropriate CDBS variable
+DEB_CMAKE_EXTRA_FLAGS += $(DEB_CMAKE_KDE4_FLAGS) $(DEB_CMAKE_CUSTOM_FLAGS)
+
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
diff --git a/makefiles/1/variables.mk b/makefiles/1/variables.mk
new file mode 100644
index 0000000..dc316dd
--- /dev/null
+++ b/makefiles/1/variables.mk
@@ -0,0 +1,18 @@
+# KDE 4 global configuration file installation directory
+DEB_CONFIG_INSTALL_DIR ?= /usr/share/kde4/config
+
+# Standard Debian KDE 4 cmake flags
+DEB_CMAKE_KDE4_FLAGS += \
+ -DCMAKE_BUILD_TYPE=Debian \
+ -DKDE4_ENABLE_FINAL=$(KDE4-ENABLE-FINAL) \
+ -DKDE4_BUILD_TESTS=false \
+ -DKDE_DISTRIBUTION_TEXT="Debian packages" \
+ -DKDE_DEFAULT_HOME=.kde4 \
+ -DCMAKE_SKIP_RPATH=true \
+ -DKDE4_USE_ALWAYS_FULL_RPATH=false \
+ -DCONFIG_INSTALL_DIR=$(DEB_CONFIG_INSTALL_DIR) \
+ -DDATA_INSTALL_DIR=/usr/share/kde4/apps \
+ -DHTML_INSTALL_DIR=/usr/share/doc/kde4/HTML \
+ -DKCFG_INSTALL_DIR=/usr/share/kde4/config.kcfg \
+ -DLIB_INSTALL_DIR=/usr/lib \
+ -DSYSCONF_INSTALL_DIR=/etc