summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Nelson <pyro@debian.org>2006-01-16 18:43:44 +0000
committerBrian Nelson <pyro@debian.org>2006-01-16 18:43:44 +0000
commit2de9c3c169eee594038610fc210ef7ed83aa5375 (patch)
treede6d1edc619964081df124128d77382f8c98aa68
parenta323f739cc40e01648d302d8c231532deacf63f7 (diff)
downloadqt4-x11-2de9c3c169eee594038610fc210ef7ed83aa5375.tar.gz
* debian/patches/12_mips_atomic_ops.dpatch: applied fixes from Isaac
Clerencia <isaac@debian.org>, as the last patch was not good enough to fix the FTBFS bug (Closes: #335831)
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/12_mips_atomic_ops.dpatch20
2 files changed, 17 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 178fa1d..88f00ff 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,7 +10,11 @@ qt4-x11 (4.1.0-3) UNRELEASED; urgency=low
* Added gif support (Closes: #348092)
- -- Brian Nelson <pyro@debian.org> Sat, 14 Jan 2006 12:11:32 -0800
+ * debian/patches/12_mips_atomic_ops.dpatch: applied fixes from Isaac
+ Clerencia <isaac@debian.org>, as the last patch was not good enough to
+ fix the FTBFS bug (Closes: #335831)
+
+ -- Brian Nelson <pyro@debian.org> Mon, 16 Jan 2006 10:43:26 -0800
qt4-x11 (4.1.0-2) unstable; urgency=low
diff --git a/debian/patches/12_mips_atomic_ops.dpatch b/debian/patches/12_mips_atomic_ops.dpatch
index f1cd8f4..c3f9a21 100644
--- a/debian/patches/12_mips_atomic_ops.dpatch
+++ b/debian/patches/12_mips_atomic_ops.dpatch
@@ -6,8 +6,8 @@
@DPATCH@
diff -urNad qt4-x11-4.1.0~/src/corelib/arch/mips/qatomic32.s qt4-x11-4.1.0/src/corelib/arch/mips/qatomic32.s
---- qt4-x11-4.1.0~/src/corelib/arch/mips/qatomic32.s 2005-12-16 06:52:19.000000000 -0500
-+++ qt4-x11-4.1.0/src/corelib/arch/mips/qatomic32.s 2006-01-07 10:47:37.000000000 -0500
+--- qt4-x11-4.1.0~/src/corelib/arch/mips/qatomic32.s 2005-12-16 03:52:19.000000000 -0800
++++ qt4-x11-4.1.0/src/corelib/arch/mips/qatomic32.s 2006-01-16 10:39:45.000000000 -0800
@@ -6,10 +6,12 @@
.globl q_atomic_test_and_set_int
.ent q_atomic_test_and_set_int
@@ -21,7 +21,7 @@ diff -urNad qt4-x11-4.1.0~/src/corelib/arch/mips/qatomic32.s qt4-x11-4.1.0/src/c
beqz $2,1b
nop
jr $31
-@@ -21,10 +23,12 @@
+@@ -21,6 +23,7 @@
.globl q_atomic_test_and_set_acquire_int
.ent q_atomic_test_and_set_acquire_int
q_atomic_test_and_set_acquire_int:
@@ -29,16 +29,20 @@ diff -urNad qt4-x11-4.1.0~/src/corelib/arch/mips/qatomic32.s qt4-x11-4.1.0/src/c
1: ll $8,0($4)
bne $8,$5,2f
move $2,$6
- sc $2,0($4)
-+ .set mips0
- beqz $2,1b
+@@ -30,6 +33,7 @@
+ jr $31
nop
+ 2: sync
++ .set mips0
jr $31
-@@ -38,10 +42,12 @@
+ move $2,$0
+ .end q_atomic_test_and_set_acquire_int
+@@ -37,11 +41,13 @@
+ .globl q_atomic_test_and_set_release_int
.ent q_atomic_test_and_set_release_int
q_atomic_test_and_set_release_int:
- sync
+ .set mips2
+ sync
1: ll $8,0($4)
bne $8,$5,2f
move $2,$6