summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Nelson <pyro@debian.org>2006-06-04 20:56:06 +0000
committerBrian Nelson <pyro@debian.org>2006-06-04 20:56:06 +0000
commitdee2e18489bc93ff52ecb4a3ffa60a76a5f40843 (patch)
tree1aaa0d8ecb008113b8a05271ec888c637be4987d
parent4a4f9588dbf74aceb93d5b22d85fa1f23a191441 (diff)
downloadqt4-x11-dee2e18489bc93ff52ecb4a3ffa60a76a5f40843.tar.gz
* debian/patches/17_alpha_ice.dpatch: updated for the current upstream
release to fix another occurrence of the alpha ICE in a different location in the code (Closes: #368883) (first attempt)
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/17_alpha_ice.dpatch26
2 files changed, 32 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 1cb737c..bbe0df3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+qt4-x11 (4.1.3-2) UNRELEASED; urgency=high
+
+ * debian/patches/17_alpha_ice.dpatch: updated for the current upstream
+ release to fix another occurrence of the alpha ICE in a different
+ location in the code (Closes: #368883) (first attempt)
+
+ -- Brian Nelson <pyro@debian.org> Sun, 4 Jun 2006 13:55:27 -0700
+
qt4-x11 (4.1.3-1) unstable; urgency=high
* New upstream release
diff --git a/debian/patches/17_alpha_ice.dpatch b/debian/patches/17_alpha_ice.dpatch
index 8529bff..8956550 100644
--- a/debian/patches/17_alpha_ice.dpatch
+++ b/debian/patches/17_alpha_ice.dpatch
@@ -6,7 +6,7 @@
@DPATCH@
diff -urNad qt4-x11-4.1.3~/src/corelib/global/qlibraryinfo.cpp qt4-x11-4.1.3/src/corelib/global/qlibraryinfo.cpp
--- qt4-x11-4.1.3~/src/corelib/global/qlibraryinfo.cpp 2006-05-14 03:46:59.000000000 -0700
-+++ qt4-x11-4.1.3/src/corelib/global/qlibraryinfo.cpp 2006-06-03 11:55:29.000000000 -0700
++++ qt4-x11-4.1.3/src/corelib/global/qlibraryinfo.cpp 2006-06-04 10:51:07.000000000 -0700
@@ -47,14 +47,7 @@
{
public:
@@ -39,9 +39,31 @@ diff -urNad qt4-x11-4.1.3~/src/corelib/global/qlibraryinfo.cpp qt4-x11-4.1.3/src
QLibrarySettings::QLibrarySettings()
{
settings = QLibraryInfoPrivate::findConfiguration();
+diff -urNad qt4-x11-4.1.3~/src/corelib/thread/qthreadstorage.h qt4-x11-4.1.3/src/corelib/thread/qthreadstorage.h
+--- qt4-x11-4.1.3~/src/corelib/thread/qthreadstorage.h 2006-05-14 03:46:59.000000000 -0700
++++ qt4-x11-4.1.3/src/corelib/thread/qthreadstorage.h 2006-06-04 13:46:52.000000000 -0700
+@@ -109,8 +109,7 @@
+
+ Q_DISABLE_COPY(QThreadStorage)
+
+- static inline void deleteData(void *x)
+- { delete reinterpret_cast<T&>(x); }
++ static inline void deleteData(void *x);
+
+ public:
+ inline QThreadStorage() : d(deleteData) { }
+@@ -128,6 +127,8 @@
+ { qThreadStorage_setLocalData(d, &t); }
+ };
+
++void QThreadStorage::deleteData(void *x) { delete reinterpret_cast<T&>(x); }
++
+ QT_END_HEADER
+
+ #endif // QT_NO_THREAD
diff -urNad qt4-x11-4.1.3~/src/corelib/tools/qhash.h qt4-x11-4.1.3/src/corelib/tools/qhash.h
--- qt4-x11-4.1.3~/src/corelib/tools/qhash.h 2006-05-14 03:46:59.000000000 -0700
-+++ qt4-x11-4.1.3/src/corelib/tools/qhash.h 2006-06-03 11:55:29.000000000 -0700
++++ qt4-x11-4.1.3/src/corelib/tools/qhash.h 2006-06-04 10:51:07.000000000 -0700
@@ -405,7 +405,7 @@
}