summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Nelson <pyro@debian.org>2006-06-03 18:59:50 +0000
committerBrian Nelson <pyro@debian.org>2006-06-03 18:59:50 +0000
commit85bf3cf2bf3bb26be503094773022d20c2a62394 (patch)
treef5b442768d331d71bac3dc6c601178068eb9259a
parent89adcd1fb8cbb8db8aa47d9400b51a0b0546207a (diff)
downloadqt4-x11-85bf3cf2bf3bb26be503094773022d20c2a62394.tar.gz
Cleaned up, fix 17_alpha_ice patch so that it applies properly
-rw-r--r--debian/patches/00list4
-rw-r--r--debian/patches/16_hppa_ldcw_fix.dpatch2
-rw-r--r--debian/patches/17_alpha_ice.dpatch35
3 files changed, 12 insertions, 29 deletions
diff --git a/debian/patches/00list b/debian/patches/00list
index 7ffc1a0..64eb689 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -3,5 +3,5 @@
12_mips_atomic_ops
13_arm_ftbfs_fixes
14_kfreebsd_build_fix
-16_hppa_ldcw_fix.dpatch
-17_alpha_ice.dpatch
+16_hppa_ldcw_fix
+17_alpha_fix
diff --git a/debian/patches/16_hppa_ldcw_fix.dpatch b/debian/patches/16_hppa_ldcw_fix.dpatch
index 779341d..0405799 100644
--- a/debian/patches/16_hppa_ldcw_fix.dpatch
+++ b/debian/patches/16_hppa_ldcw_fix.dpatch
@@ -2,7 +2,7 @@
## 15_hppa_ldcw.dpatch by <lamont@bld-4.mmjgroup.com>
##
## All lines beginning with `## DP:' are a description of the patch.
-## DP: No description.
+## DP: patch from Ubuntu to properly support hppa
@DPATCH@
diff -urNad qt4-x11-4.1.0~/src/corelib/arch/parisc/q_ldcw.s qt4-x11-4.1.0/src/corelib/arch/parisc/q_ldcw.s
diff --git a/debian/patches/17_alpha_ice.dpatch b/debian/patches/17_alpha_ice.dpatch
index a064881..8529bff 100644
--- a/debian/patches/17_alpha_ice.dpatch
+++ b/debian/patches/17_alpha_ice.dpatch
@@ -4,25 +4,9 @@
## DP: No description.
@DPATCH@
-diff -u qt4-x11-4.1.2/debian/changelog qt4-x11-4.1.2/debian/changelog
---- qt4-x11-4.1.2/debian/changelog
-+++ qt4-x11-4.1.2/debian/changelog
-@@ -1,3 +1,11 @@
-+qt4-x11 (4.1.2-2.1) unstable; urgency=low
-+
-+ * Non-maintainer upload.
-+ * Workaround for -fvisibility-inlines-hidden on alpha: break out the
-+ static methods so they're not inlined. Closes: #368883.
-+
-+ -- Steve Langasek <vorlon@debian.org> Tue, 30 May 2006 19:56:44 -0700
-+
- qt4-x11 (4.1.2-2) unstable; urgency=low
-
- * debian/libqt4-debug-dev.install, debian/libqt4-dev.install: added
-only in patch2:
-unchanged:
---- qt4-x11-4.1.2.orig/src/corelib/global/qlibraryinfo.cpp
-+++ qt4-x11-4.1.2/src/corelib/global/qlibraryinfo.cpp
+diff -urNad qt4-x11-4.1.3~/src/corelib/global/qlibraryinfo.cpp qt4-x11-4.1.3/src/corelib/global/qlibraryinfo.cpp
+--- qt4-x11-4.1.3~/src/corelib/global/qlibraryinfo.cpp 2006-05-14 03:46:59.000000000 -0700
++++ qt4-x11-4.1.3/src/corelib/global/qlibraryinfo.cpp 2006-06-03 11:55:29.000000000 -0700
@@ -47,14 +47,7 @@
{
public:
@@ -38,8 +22,8 @@ unchanged:
+ static void cleanup();
static QSettings *configuration()
{
- QLibrarySettings *ls = qt_library_settings();
-@@ -64,6 +57,15 @@
+ #ifdef QT_NO_THREAD
+@@ -75,6 +68,15 @@
Q_GLOBAL_STATIC(QLibrarySettings, qt_library_settings)
};
@@ -55,11 +39,10 @@ unchanged:
QLibrarySettings::QLibrarySettings()
{
settings = QLibraryInfoPrivate::findConfiguration();
-only in patch2:
-unchanged:
---- qt4-x11-4.1.2.orig/src/corelib/tools/qhash.h
-+++ qt4-x11-4.1.2/src/corelib/tools/qhash.h
-@@ -396,7 +396,7 @@
+diff -urNad qt4-x11-4.1.3~/src/corelib/tools/qhash.h qt4-x11-4.1.3/src/corelib/tools/qhash.h
+--- qt4-x11-4.1.3~/src/corelib/tools/qhash.h 2006-05-14 03:46:59.000000000 -0700
++++ qt4-x11-4.1.3/src/corelib/tools/qhash.h 2006-06-03 11:55:29.000000000 -0700
+@@ -405,7 +405,7 @@
}
template <class Key, class T>