summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Nelson <pyro@debian.org>2006-03-01 07:52:06 +0000
committerBrian Nelson <pyro@debian.org>2006-03-01 07:52:06 +0000
commit86dea1f6f57a8a2bcb7717662dabb556f582bc88 (patch)
tree5f9dd04ae8a1cf0740e11c317e73cc42d4811246
parentf8f3c792134c6ca5b1687db429f4bb53dd3a0b8b (diff)
downloadqt4-x11-86dea1f6f57a8a2bcb7717662dabb556f582bc88.tar.gz
- debian/patches/15_alpha_ftbfs_fix.dpatch: removed, integrated upstream
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/15_alpha_ftbfs_fix.dpatch21
3 files changed, 2 insertions, 23 deletions
diff --git a/debian/changelog b/debian/changelog
index 3cd666a..034fa4b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
qt4-x11 (4.1.1-1) UNRELEASED; urgency=low
* New upstream release
+ - debian/patches/15_alpha_ftbfs_fix.dpatch: removed, integrated upstream
* debian/control: updated libqt4-debug-dev priority to match that of the
override file
@@ -11,7 +12,7 @@ qt4-x11 (4.1.1-1) UNRELEASED; urgency=low
* debian/libqt4-gui.install: added libqmng.so and libqgif.so plugins
(Closes: #354266)
- -- Brian Nelson <pyro@debian.org> Tue, 28 Feb 2006 14:53:24 -0800
+ -- Brian Nelson <pyro@debian.org> Tue, 28 Feb 2006 23:47:57 -0800
qt4-x11 (4.1.0-3) unstable; urgency=low
diff --git a/debian/patches/00list b/debian/patches/00list
index b513764..3a98067 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -3,4 +3,3 @@
12_mips_atomic_ops
13_arm_ftbfs_fixes
14_kfreebsd_build_fix
-15_alpha_ftbfs_fix
diff --git a/debian/patches/15_alpha_ftbfs_fix.dpatch b/debian/patches/15_alpha_ftbfs_fix.dpatch
deleted file mode 100755
index cf0778a..0000000
--- a/debian/patches/15_alpha_ftbfs_fix.dpatch
+++ /dev/null
@@ -1,21 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 15_alpha_ftbfs_fix.dpatch by Brian Nelson <pyro@debian.org>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Rename q_atomic_test_and_set_release_ptr to
-## DP: q_atomic_test_and_set_ptr, as suggested by Isaac Clerencia
-## DP: <isaac@debian.org>, to fix a FTBFS on alpha.
-
-@DPATCH@
-diff -urNad qt4-x11-4.1.0~/src/corelib/arch/alpha/arch/qatomic.h qt4-x11-4.1.0/src/corelib/arch/alpha/arch/qatomic.h
---- qt4-x11-4.1.0~/src/corelib/arch/alpha/arch/qatomic.h 2005-12-16 03:52:24.000000000 -0800
-+++ qt4-x11-4.1.0/src/corelib/arch/alpha/arch/qatomic.h 2006-01-10 09:12:35.000000000 -0800
-@@ -87,7 +87,7 @@
- return ret;
- }
-
--inline int q_atomic_test_and_set_release_ptr(volatile void *ptr, void *expected, void *newval)
-+inline int q_atomic_test_and_set_ptr(volatile void *ptr, void *expected, void *newval)
- {
- register void *ret;
- asm volatile("1:\n"