summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Nelson <pyro@debian.org>2006-06-21 16:55:29 +0000
committerBrian Nelson <pyro@debian.org>2006-06-21 16:55:29 +0000
commitc562f386abf5d253b17a49e8d8983fe1e3c9ae4e (patch)
tree5caf4cda2e4e412de767083cb3818d687cf6f9bf
parent76f334345bdb21138cc46a05da4f60d8e558133e (diff)
downloadqt4-x11-c562f386abf5d253b17a49e8d8983fe1e3c9ae4e.tar.gz
* debian/patches/19_s390_atomic: patch from Bastian Blank to fix
including of s390 specific atomic header. (Closes: #370241)
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/00list1
-rw-r--r--debian/patches/19_s390_atomic.dpatch19
3 files changed, 27 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index fe928bd..9185f1d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+qt4-x11 (4.1.3-3) UNRELEASED; urgency=low
+
+ * debian/patches/19_s390_atomic: patch from Bastian Blank to fix
+ including of s390 specific atomic header. (Closes: #370241)
+
+ -- Brian Nelson <pyro@debian.org> Wed, 21 Jun 2006 09:54:33 -0700
+
qt4-x11 (4.1.3-2) unstable; urgency=high
* patches/18_disable_opengl_visibility: disable -fvisibility-inlines-hidden
diff --git a/debian/patches/00list b/debian/patches/00list
index c7d0f92..56e483b 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -6,3 +6,4 @@
16_hppa_ldcw_fix
17_alpha_ice
18_disable_opengl_visibility
+19_s390_atomic
diff --git a/debian/patches/19_s390_atomic.dpatch b/debian/patches/19_s390_atomic.dpatch
new file mode 100644
index 0000000..72100b6
--- /dev/null
+++ b/debian/patches/19_s390_atomic.dpatch
@@ -0,0 +1,19 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 19_s390_atomic.dpatch by Bastian Blank <waldi@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: No description.
+
+@DPATCH@
+diff -urNad qt4-x11-4.1.3~/src/corelib/arch/s390/arch/qatomic.h qt4-x11-4.1.3/src/corelib/arch/s390/arch/qatomic.h
+--- qt4-x11-4.1.3~/src/corelib/arch/s390/arch/qatomic.h 2006-05-14 10:47:14.000000000 +0000
++++ qt4-x11-4.1.3/src/corelib/arch/s390/arch/qatomic.h 2006-06-21 16:02:04.000000000 +0000
+@@ -24,6 +24,8 @@
+ #ifndef S390_QATOMIC_H
+ #define S390_QATOMIC_H
+
++#include <QtCore/qglobal.h>
++
+ QT_BEGIN_HEADER
+
+ #define __CS_LOOP(ptr, op_val, op_string) ({ \