summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Nelson <pyro@debian.org>2006-06-05 05:18:47 +0000
committerBrian Nelson <pyro@debian.org>2006-06-05 05:18:47 +0000
commitc6927117d692fb9a01e35b7a1c06aabcb14efaed (patch)
tree87becc1dc5480f122754335685284e336a7d78ab
parentdee2e18489bc93ff52ecb4a3ffa60a76a5f40843 (diff)
downloadqt4-x11-c6927117d692fb9a01e35b7a1c06aabcb14efaed.tar.gz
Reverted the alpha patch update since it didn't work. Let's just fix
the damn compiler instead.
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/17_alpha_ice.dpatch26
2 files changed, 2 insertions, 32 deletions
diff --git a/debian/changelog b/debian/changelog
index bbe0df3..1cb737c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,11 +1,3 @@
-qt4-x11 (4.1.3-2) UNRELEASED; urgency=high
-
- * debian/patches/17_alpha_ice.dpatch: updated for the current upstream
- release to fix another occurrence of the alpha ICE in a different
- location in the code (Closes: #368883) (first attempt)
-
- -- Brian Nelson <pyro@debian.org> Sun, 4 Jun 2006 13:55:27 -0700
-
qt4-x11 (4.1.3-1) unstable; urgency=high
* New upstream release
diff --git a/debian/patches/17_alpha_ice.dpatch b/debian/patches/17_alpha_ice.dpatch
index 8956550..8529bff 100644
--- a/debian/patches/17_alpha_ice.dpatch
+++ b/debian/patches/17_alpha_ice.dpatch
@@ -6,7 +6,7 @@
@DPATCH@
diff -urNad qt4-x11-4.1.3~/src/corelib/global/qlibraryinfo.cpp qt4-x11-4.1.3/src/corelib/global/qlibraryinfo.cpp
--- qt4-x11-4.1.3~/src/corelib/global/qlibraryinfo.cpp 2006-05-14 03:46:59.000000000 -0700
-+++ qt4-x11-4.1.3/src/corelib/global/qlibraryinfo.cpp 2006-06-04 10:51:07.000000000 -0700
++++ qt4-x11-4.1.3/src/corelib/global/qlibraryinfo.cpp 2006-06-03 11:55:29.000000000 -0700
@@ -47,14 +47,7 @@
{
public:
@@ -39,31 +39,9 @@ diff -urNad qt4-x11-4.1.3~/src/corelib/global/qlibraryinfo.cpp qt4-x11-4.1.3/src
QLibrarySettings::QLibrarySettings()
{
settings = QLibraryInfoPrivate::findConfiguration();
-diff -urNad qt4-x11-4.1.3~/src/corelib/thread/qthreadstorage.h qt4-x11-4.1.3/src/corelib/thread/qthreadstorage.h
---- qt4-x11-4.1.3~/src/corelib/thread/qthreadstorage.h 2006-05-14 03:46:59.000000000 -0700
-+++ qt4-x11-4.1.3/src/corelib/thread/qthreadstorage.h 2006-06-04 13:46:52.000000000 -0700
-@@ -109,8 +109,7 @@
-
- Q_DISABLE_COPY(QThreadStorage)
-
-- static inline void deleteData(void *x)
-- { delete reinterpret_cast<T&>(x); }
-+ static inline void deleteData(void *x);
-
- public:
- inline QThreadStorage() : d(deleteData) { }
-@@ -128,6 +127,8 @@
- { qThreadStorage_setLocalData(d, &t); }
- };
-
-+void QThreadStorage::deleteData(void *x) { delete reinterpret_cast<T&>(x); }
-+
- QT_END_HEADER
-
- #endif // QT_NO_THREAD
diff -urNad qt4-x11-4.1.3~/src/corelib/tools/qhash.h qt4-x11-4.1.3/src/corelib/tools/qhash.h
--- qt4-x11-4.1.3~/src/corelib/tools/qhash.h 2006-05-14 03:46:59.000000000 -0700
-+++ qt4-x11-4.1.3/src/corelib/tools/qhash.h 2006-06-04 10:51:07.000000000 -0700
++++ qt4-x11-4.1.3/src/corelib/tools/qhash.h 2006-06-03 11:55:29.000000000 -0700
@@ -405,7 +405,7 @@
}