summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Nelson <pyro@debian.org>2006-10-16 21:46:19 +0000
committerBrian Nelson <pyro@debian.org>2006-10-16 21:46:19 +0000
commit2a405241469b7c5089d9d69877b52aa9de58d928 (patch)
tree0e17d6d821528b8ec3ad6d86cadffed619f97fdc
parentb8fcc2336e11f61a9fdbdd047186dde9d233e01a (diff)
downloadqt4-x11-2a405241469b7c5089d9d69877b52aa9de58d928.tar.gz
* debian/patches/19_m68k_inotify_fix.dpatch: new patch to fix FTBFS on
m68k (Closes: #391902)
-rw-r--r--debian/changelog5
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/19_m68k_inotify_fix.dpatch23
3 files changed, 28 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 7a5dd81..aa53758 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,7 +8,10 @@ qt4-x11 (4.2.0-2) UNRELEASED; urgency=low
* Added a bunch of plugins and their debugging symbols to be installed
- -- Brian Nelson <pyro@debian.org> Mon, 16 Oct 2006 17:35:25 -0400
+ * debian/patches/19_m68k_inotify_fix.dpatch: new patch to fix FTBFS on
+ m68k (Closes: #391902)
+
+ -- Brian Nelson <pyro@debian.org> Mon, 16 Oct 2006 17:40:48 -0400
qt4-x11 (4.2.0-1) unstable; urgency=low
diff --git a/debian/patches/00list b/debian/patches/00list
index c7d0f92..709b685 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -6,3 +6,4 @@
16_hppa_ldcw_fix
17_alpha_ice
18_disable_opengl_visibility
+19_m68k_inotify_fix
diff --git a/debian/patches/19_m68k_inotify_fix.dpatch b/debian/patches/19_m68k_inotify_fix.dpatch
new file mode 100755
index 0000000..2d3ce14
--- /dev/null
+++ b/debian/patches/19_m68k_inotify_fix.dpatch
@@ -0,0 +1,23 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 19_m68k_inotify_fix.dpatch by Brian Nelson <pyro@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: From Roman Zippel <zippel@linux-m68k.org>: These defines are
+## DP: taken from the m68k tree, they should appear like this soon also
+## DP: in the upstream source.
+
+@DPATCH@
+diff -urNad qt4-x11-4.2.0~/src/corelib/io/qfilesystemwatcher_inotify.cpp qt4-x11-4.2.0/src/corelib/io/qfilesystemwatcher_inotify.cpp
+--- qt4-x11-4.2.0~/src/corelib/io/qfilesystemwatcher_inotify.cpp 2006-09-29 10:44:58.000000000 -0400
++++ qt4-x11-4.2.0/src/corelib/io/qfilesystemwatcher_inotify.cpp 2006-10-16 17:38:56.000000000 -0400
+@@ -84,6 +84,10 @@
+ # define __NR_inotify_init 284
+ # define __NR_inotify_add_watch 285
+ # define __NR_inotify_rm_watch 286
++#elif defined (__mc68000__)
++# define __NR_inotify_init 284
++# define __NR_inotify_add_watch 285
++# define __NR_inotify_rm_watch 286
+ #else
+ # error "This architecture is not supported. Please talk to qt-bugs@trolltech.com"
+ #endif