summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFathi Boudra <fabo@debian.org>2007-07-16 20:14:45 +0000
committerFathi Boudra <fabo@debian.org>2007-07-16 20:14:45 +0000
commit5f21108447f7957ce08112cd1c7badc4bfca7817 (patch)
tree7ac8861bc00ba3686b994c5ccdafaddca5f9d3fd
parent9fd28b4dbf25d2448651fc1cc8d8011fa999f5af (diff)
downloadqt4-x11-5f21108447f7957ce08112cd1c7badc4bfca7817.tar.gz
* Add 42_alpha_fetch_and_add patch to fix broken threading on alpha, hangs
uselessly on startup. fetch-and-add is supposed to return the original value before the addition. Thanks to Steve Langasek and Bradley Hughes. (Closes: #433031)
-rw-r--r--debian/changelog9
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/42_alpha_fetch_and_add.dpatch37
3 files changed, 47 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 3d9936b..58139a4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+qt4-x11 (4.3.0-4) unstable; urgency=low
+
+ * Add 42_alpha_fetch_and_add patch to fix broken threading on alpha, hangs
+ uselessly on startup. fetch-and-add is supposed to return the original
+ value before the addition. Thanks to Steve Langasek and Bradley Hughes.
+ (Closes: #433031)
+
+ -- Fathi Boudra <fboudra@free.fr> Mon, 16 Jul 2007 21:32:01 +0200
+
qt4-x11 (4.3.0-3) unstable; urgency=low
[Fathi Boudra]
diff --git a/debian/patches/00list b/debian/patches/00list
index c992642..031ad20 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -20,6 +20,7 @@
31_arm_eabi_fix
40_alpha_ice
41_disable_opengl_visibility
+42_alpha_fetch_and_add
50_kfreebsd_build_fix
51_kfreebsd_mkspecs
60_m68k_inotify_fix
diff --git a/debian/patches/42_alpha_fetch_and_add.dpatch b/debian/patches/42_alpha_fetch_and_add.dpatch
new file mode 100755
index 0000000..4a25ee2
--- /dev/null
+++ b/debian/patches/42_alpha_fetch_and_add.dpatch
@@ -0,0 +1,37 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 42_alpha_fetch_and_add.dpatch by Bradley Hughes <bhughes@trolltech.com>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: fetch-and-add is supposed to return the original value before the addition.
+
+@DPATCH@
+diff -urNad qt4-x11-4.3.0~/src/corelib/arch/qatomic_alpha.h qt4-x11-4.3.0/src/corelib/arch/qatomic_alpha.h
+--- qt4-x11-4.3.0~/src/corelib/arch/qatomic_alpha.h 2007-05-25 15:24:09.000000000 +0200
++++ qt4-x11-4.3.0/src/corelib/arch/qatomic_alpha.h 2007-07-16 21:52:20.000000000 +0200
+@@ -190,7 +190,7 @@
+ : "=&r" (old), "=&r" (tmp), "+m"(*ptr)
+ : "r" (value)
+ : "memory");
+- return old != -1;
++ return old;
+ }
+
+ inline int q_atomic_fetch_and_add_acquire_int(volatile int *ptr, int value)
+@@ -208,7 +208,7 @@
+ : "=&r" (old), "=&r" (tmp), "+m"(*ptr)
+ : "r" (value)
+ : "memory");
+- return old != -1;
++ return old;
+ }
+
+ inline int q_atomic_fetch_and_add_release_int(volatile int *ptr, int value)
+@@ -226,7 +226,7 @@
+ : "=&r" (old), "=&r" (tmp), "+m"(*ptr)
+ : "r" (value)
+ : "memory");
+- return old != -1;
++ return old;
+ }
+
+ #else // !Q_CC_GNU