summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Nelson <pyro@debian.org>2007-03-04 15:46:08 +0000
committerBrian Nelson <pyro@debian.org>2007-03-04 15:46:08 +0000
commit38d724e64b6e5dcec34eceef72d8f01fb762ef04 (patch)
tree6823aafaec5434a84aba772071051213a61d6231
parente2d67520a82324fc0a08874f34f3a5b91a4c5e24 (diff)
downloadqt4-x11-38d724e64b6e5dcec34eceef72d8f01fb762ef04.tar.gz
* Applied new patches for kFreeBSD and Hurd support
(Closes: #380097, #402007)
-rw-r--r--debian/changelog5
-rw-r--r--debian/patches/00list3
-rwxr-xr-xdebian/patches/50_kfreebsd_build_fix.dpatch81
-rw-r--r--debian/patches/51_kfreebsd_mkspecs.dpatch25
-rw-r--r--debian/patches/80_hurd_detection.dpatch27
-rw-r--r--debian/patches/80_hurd_max_path.dpatch14
-rwxr-xr-xdebian/rules9
7 files changed, 123 insertions, 41 deletions
diff --git a/debian/changelog b/debian/changelog
index 5ba0868..b0928f4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -18,7 +18,10 @@ qt4-x11 (4.2.2-1) UNRELEASED; urgency=low
* Re-arranged patches to group them by arch so that they're easier to
deal with
- -- Brian Nelson <pyro@debian.org> Sun, 4 Mar 2007 10:26:01 -0500
+ * Applied new patches for kFreeBSD and Hurd support
+ (Closes: #380097, #402007)
+
+ -- Brian Nelson <pyro@debian.org> Sun, 4 Mar 2007 10:45:49 -0500
qt4-x11 (4.2.1-2) unstable; urgency=low
diff --git a/debian/patches/00list b/debian/patches/00list
index f2bc30a..7be0821 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -7,7 +7,8 @@
40_alpha_ice
41_alpha_disable_opengl_visibility
50_kfreebsd_build_fix
+51_kfreebsd_mkspecs
60_m68k_inotify_fix
70_hppa_ldcw_fix
71_hppa_inotify_fix
-80_hurd_detection
+80_hurd_max_path
diff --git a/debian/patches/50_kfreebsd_build_fix.dpatch b/debian/patches/50_kfreebsd_build_fix.dpatch
index cbf6459..1d018a3 100755
--- a/debian/patches/50_kfreebsd_build_fix.dpatch
+++ b/debian/patches/50_kfreebsd_build_fix.dpatch
@@ -1,20 +1,79 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
-## 14_kfreebsd_build_fix.dpatch by Brian Nelson <pyro@debian.org> by way
-## of Petr Salinger <Petr.Salinger@t-systems.cz>
+## 14_kfreebsd_build_fix.dpatch by Petr Salinger <Petr.Salinger@seznam.cz>
##
## All lines beginning with `## DP:' are a description of the patch.
-## DP: Fixes FTBFS on GNU/kFreeBSD
+## DP: Fixes FTBFS on GNU/kFreeBSD by creating new Q_OS_GLIBC
@DPATCH@
-diff -urNad qt4-x11-4.0.1~/src/corelib/global/qglobal.h qt4-x11-4.0.1/src/corelib/global/qglobal.h
---- qt4-x11-4.0.1~/src/corelib/global/qglobal.h 2005-08-16 11:41:07.000000000 +0300
-+++ qt4-x11-4.0.1/src/corelib/global/qglobal.h 2005-12-13 18:19:47.000000000 +0200
-@@ -100,7 +100,7 @@
- # define Q_OS_ULTRIX
- #elif defined(sinix)
+diff -ur qt4-x11-4.2.1/src/corelib/global/qglobal.h qt4-x11-4.2.1/src/corelib/global/qglobal.h
+--- qt4-x11-4.2.1/src/corelib/global/qglobal.h 2006-10-20 17:35:14.000000000 +0200
++++ qt4-x11-4.2.1/src/corelib/global/qglobal.h 2006-12-06 23:06:11.000000000 +0100
+@@ -101,6 +102,12 @@
# define Q_OS_RELIANT
--#elif defined(__linux__) || defined(__linux)
-+#elif defined(__linux__) || defined(__linux) || defined(__GLIBC__)
+ #elif defined(__linux__) || defined(__linux)
# define Q_OS_LINUX
++# define Q_OS_GLIBC
++#elif defined(__GNU_HURD__) || defined(__GNU__)
++# define Q_OS_HURD
++# define Q_OS_GLIBC
++#elif defined(__GLIBC__)
++# define Q_OS_GLIBC
#elif defined(__FreeBSD__) || defined(__DragonFly__)
# define Q_OS_FREEBSD
+ # define Q_OS_BSD4
+@@ -121,8 +128,6 @@
+ # define Q_OS_AIX
+ #elif defined(__Lynx__)
+ # define Q_OS_LYNX
+-#elif defined(__GNU_HURD__)
+-# define Q_OS_HURD
+ #elif defined(__DGUX__)
+ # define Q_OS_DGUX
+ #elif defined(__QNXNTO__)
+diff -ur qt4-x11-4.2.1/src/corelib/plugin/qlibrary.cpp qt4-x11-4.2.1/src/corelib/plugin/qlibrary.cpp
+--- qt4-x11-4.2.1/src/corelib/plugin/qlibrary.cpp 2006-10-20 17:35:15.000000000 +0200
++++ qt4-x11-4.2.1/src/corelib/plugin/qlibrary.cpp 2006-12-07 09:01:45.000000000 +0100
+@@ -248,11 +248,11 @@
+
+ #if defined(Q_OS_UNIX)
+
+-#if defined(Q_OS_FREEBSD) || defined(Q_OS_LINUX)
++#if defined(Q_OS_FREEBSD) || defined(Q_OS_GLIBC)
+ # define USE_MMAP
+ # include <sys/types.h>
+ # include <sys/mman.h>
+-#endif // Q_OS_FREEBSD || Q_OS_LINUX
++#endif // Q_OS_FREEBSD || Q_OS_GLIBC
+
+ static long qt_find_pattern(const char *s, ulong s_len,
+ const char *pattern, ulong p_len)
+diff -ur qt4-x11-4.2.1/src/corelib/tools/qlocale.cpp qt4-x11-4.2.1/src/corelib/tools/qlocale.cpp
+--- qt4-x11-4.2.1/src/corelib/tools/qlocale.cpp 2006-10-20 17:35:15.000000000 +0200
++++ qt4-x11-4.2.1/src/corelib/tools/qlocale.cpp 2006-12-07 09:01:22.000000000 +0100
+@@ -47,7 +47,7 @@
+ #include <stdlib.h>
+ #include <qdebug.h>
+
+-#if defined(Q_OS_LINUX) && !defined(__UCLIBC__)
++#if defined(Q_OS_GLIBC) && !defined(__UCLIBC__)
+ # include <fenv.h>
+ #endif
+
+@@ -5639,7 +5639,7 @@
+ _control87(MCW_EM, MCW_EM);
+ #endif
+
+-#if defined(Q_OS_LINUX) && !defined(__UCLIBC__)
++#if defined(Q_OS_GLIBC) && !defined(__UCLIBC__)
+ fenv_t envp;
+ feholdexcept(&envp);
+ #endif
+@@ -5655,7 +5655,7 @@
+ #endif //_M_X64
+ #endif //Q_OS_WIN
+
+-#if defined(Q_OS_LINUX) && !defined(__UCLIBC__)
++#if defined(Q_OS_GLIBC) && !defined(__UCLIBC__)
+ fesetenv(&envp);
+ #endif
+
diff --git a/debian/patches/51_kfreebsd_mkspecs.dpatch b/debian/patches/51_kfreebsd_mkspecs.dpatch
new file mode 100644
index 0000000..3039acb
--- /dev/null
+++ b/debian/patches/51_kfreebsd_mkspecs.dpatch
@@ -0,0 +1,25 @@
+#! /bin/sh -e
+## 90_kfreebsd_mkspecs.dpatch by Petr Salinger <Petr.Salinger@seznam.cz>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Create mkspecs/glibc-g++ from mkspecs/linux-g++, needed by GNU/kFreeBSD
+## DP: we cannot use directly linux-g++ due to src/corelib/io/io.pri
+
+if [ $# -ne 1 ]; then
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+fi
+case "$1" in
+ -patch)
+ rm -rvf mkspecs/glibc-g++
+ cp -av mkspecs/linux-g++ mkspecs/glibc-g++
+ ;;
+ -unpatch)
+ rm -rvf mkspecs/glibc-g++
+ ;;
+ *)
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1;;
+esac
+
+exit 0
diff --git a/debian/patches/80_hurd_detection.dpatch b/debian/patches/80_hurd_detection.dpatch
deleted file mode 100644
index a6860f5..0000000
--- a/debian/patches/80_hurd_detection.dpatch
+++ /dev/null
@@ -1,27 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 20_hurd_detection.dpatch by Cyril Brulebois <cyril.brulebois@enst-bretagne.fr>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Enable GNU/Hurd detection
-
-@DPATCH@
-diff -Nur qt4-x11-4.1.3~/src/corelib/global/qglobal.h qt4-x11-4.1.3~/src/corelib/global/qglobal.h
---- qt4-x11-4.1.3~/src/corelib/global/qglobal.h 2006-07-21 11:51:19.000000000 +0000
-+++ qt4-x11-4.1.3/src/corelib/global/qglobal.h 2006-07-21 11:58:25.000000000 +0000
-@@ -69,6 +69,7 @@
- LYNX - LynxOS
- BSD4 - Any BSD 4.4 system
- UNIX - Any UNIX BSD/SYSV system
-+ HURD - Hurd
- */
-
- #if defined(__APPLE__) && (defined(__GNUC__) || defined(__xlC__) || defined(__xlc__))
-@@ -136,6 +137,8 @@
- # define Q_OS_UNIXWARE
- #elif defined(__svr4__) && defined(i386) /* Open UNIX 8 + GCC */
- # define Q_OS_UNIXWARE
-+#elif defined(__GNU__) /* To avoid confusion, like for mkspecs files */
-+# define Q_OS_HURD
- #elif defined(__MAKEDEPEND__)
- #else
- # error "Qt has not been ported to this OS - talk to qt-bugs@trolltech.com"
diff --git a/debian/patches/80_hurd_max_path.dpatch b/debian/patches/80_hurd_max_path.dpatch
new file mode 100644
index 0000000..60ffbcb
--- /dev/null
+++ b/debian/patches/80_hurd_max_path.dpatch
@@ -0,0 +1,14 @@
+diff -ur qt4-x11-4.2.1/src/corelib/io/qfsfileengine_unix.cpp qt4-x11-4.2.1-youpi/src/corelib/io/qfsfileengine_unix.cpp
+--- qt4-x11-4.2.1/src/corelib/io/qfsfileengine_unix.cpp 2006-10-20 15:35:14.000000000 +0000
++++ qt4-x11-4.2.1-youpi/src/corelib/io/qfsfileengine_unix.cpp 2007-01-21 19:52:35.000000000 +0000
+@@ -40,6 +40,10 @@
+ # include <private/qcore_mac_p.h>
+ #endif
+
++#ifndef PATH_MAX
++#define PATH_MAX 4096
++#endif
++
+ void QFSFileEnginePrivate::init()
+ {
+ }
diff --git a/debian/rules b/debian/rules
index 29ef8a0..ebf5e56 100755
--- a/debian/rules
+++ b/debian/rules
@@ -26,6 +26,13 @@ ifeq ($(DEB_HOST_ARCH),arm)
EXTRA_CONFIGURE_OPTS += -DQT_QLOCALE_USES_FCVT
endif
+ifeq ($(DEB_HOST_ARCH_OS),linux)
+ PLATFORM_ARG = linux-g++
+else
+ PLATFORM_ARG = glibc-g++
+endif
+
+
common-configure-arch::
./configure -confirm-license \
-prefix "/usr" \
@@ -35,7 +42,7 @@ common-configure-arch::
-plugindir "/usr/lib/qt4/plugins" \
-translationdir "/usr/share/qt4/translations" \
-sysconfdir "/etc/xdg" \
- -platform linux-g++ \
+ -platform $(PLATFORM_ARG) \
-debug-and-release \
-fast \
-no-rpath \