summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Nelson <pyro@debian.org>2007-03-03 22:18:08 +0000
committerBrian Nelson <pyro@debian.org>2007-03-03 22:18:08 +0000
commitc7d61ab906bd04edaecf6bb6e7fde29a3cbbd963 (patch)
tree9b2fe608602cc3785ea86fd8e65ac4458d789fb0
parent87d8229c13ff9e681c1a51712ecba4c21f93b0e1 (diff)
downloadqt4-x11-c7d61ab906bd04edaecf6bb6e7fde29a3cbbd963.tar.gz
* New upstream release (Closes: #410862)
* Added Riku Voipio's patch for ARM EABI (Closes: #408813) * debian/patches/22_launch_moc-qt4.dpatch: new patch to ensure the Qt4 version of moc is launched by qdbuscpp2xml (Closes: #399049) * Added a doc-base file for qt4-doc (Closes: #403290) * debian/qt4-designer.links: added a link /usr/share/qt4/bin/designer -> /usr/bin/designer-qt4 (Closes: #410885)
-rw-r--r--debian/changelog16
-rw-r--r--debian/patches/00list2
-rwxr-xr-xdebian/patches/19_m68k_inotify_fix.dpatch14
-rwxr-xr-xdebian/patches/22_launch_moc-qt4.dpatch19
-rw-r--r--debian/patches/90_arm_eabi_fix.dpatch36
-rw-r--r--debian/qt4-designer.links1
-rw-r--r--debian/qt4-doc.doc-base11
-rw-r--r--debian/qt4-doc.install2
-rwxr-xr-xdebian/rules2
9 files changed, 93 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index 9173416..c6e2d71 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,21 @@
-qt4-x11 (4.2.1-3) UNRELEASED; urgency=low
+qt4-x11 (4.2.2-1) UNRELEASED; urgency=low
+
+ * New upstream release (Closes: #410862)
* debian/rules: set the sysconfdir to /etc/xdg instead of /etc/qt4 to
match the QSettings documentation (Closes: #407297)
- -- Brian Nelson <pyro@debian.org> Mon, 29 Jan 2007 20:17:44 -0500
+ * Added Riku Voipio's patch for ARM EABI (Closes: #408813)
+
+ * debian/patches/22_launch_moc-qt4.dpatch: new patch to ensure the Qt4
+ version of moc is launched by qdbuscpp2xml (Closes: #399049)
+
+ * Added a doc-base file for qt4-doc (Closes: #403290)
+
+ * debian/qt4-designer.links: added a link /usr/share/qt4/bin/designer ->
+ /usr/bin/designer-qt4 (Closes: #410885)
+
+ -- Brian Nelson <pyro@debian.org> Sat, 3 Mar 2007 13:08:30 -0500
qt4-x11 (4.2.1-2) unstable; urgency=low
diff --git a/debian/patches/00list b/debian/patches/00list
index 77b1838..4f59234 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -9,3 +9,5 @@
19_m68k_inotify_fix
20_hppa_inotify_fix
21_hurd_detection
+22_launch_moc-qt4
+90_arm_eabi_fix
diff --git a/debian/patches/19_m68k_inotify_fix.dpatch b/debian/patches/19_m68k_inotify_fix.dpatch
index 2d3ce14..9dd507d 100755
--- a/debian/patches/19_m68k_inotify_fix.dpatch
+++ b/debian/patches/19_m68k_inotify_fix.dpatch
@@ -7,13 +7,13 @@
## DP: in the upstream source.
@DPATCH@
-diff -urNad qt4-x11-4.2.0~/src/corelib/io/qfilesystemwatcher_inotify.cpp qt4-x11-4.2.0/src/corelib/io/qfilesystemwatcher_inotify.cpp
---- qt4-x11-4.2.0~/src/corelib/io/qfilesystemwatcher_inotify.cpp 2006-09-29 10:44:58.000000000 -0400
-+++ qt4-x11-4.2.0/src/corelib/io/qfilesystemwatcher_inotify.cpp 2006-10-16 17:38:56.000000000 -0400
-@@ -84,6 +84,10 @@
- # define __NR_inotify_init 284
- # define __NR_inotify_add_watch 285
- # define __NR_inotify_rm_watch 286
+diff -urNad qt4-x11-4.2.2~/src/corelib/io/qfilesystemwatcher_inotify.cpp qt4-x11-4.2.2/src/corelib/io/qfilesystemwatcher_inotify.cpp
+--- qt4-x11-4.2.2~/src/corelib/io/qfilesystemwatcher_inotify.cpp 2006-11-27 12:26:05.000000000 -0500
++++ qt4-x11-4.2.2/src/corelib/io/qfilesystemwatcher_inotify.cpp 2007-03-03 12:30:28.000000000 -0500
+@@ -88,6 +88,10 @@
+ # define __NR_inotify_init 269
+ # define __NR_inotify_add_watch 270
+ # define __NR_inotify_rm_watch 271
+#elif defined (__mc68000__)
+# define __NR_inotify_init 284
+# define __NR_inotify_add_watch 285
diff --git a/debian/patches/22_launch_moc-qt4.dpatch b/debian/patches/22_launch_moc-qt4.dpatch
new file mode 100755
index 0000000..e5d7cdd
--- /dev/null
+++ b/debian/patches/22_launch_moc-qt4.dpatch
@@ -0,0 +1,19 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 22_launch_moc-qt4.dpatch by Brian Nelson <pyro@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Ensure the Qt4 version of moc is launched.
+
+@DPATCH@
+diff -urNad qt4-x11-4.2.2~/tools/qdbus/tools/qdbuscpp2xml/qdbuscpp2xml.cpp qt4-x11-4.2.2/tools/qdbus/tools/qdbuscpp2xml/qdbuscpp2xml.cpp
+--- qt4-x11-4.2.2~/tools/qdbus/tools/qdbuscpp2xml/qdbuscpp2xml.cpp 2006-11-27 12:26:30.000000000 -0500
++++ qt4-x11-4.2.2/tools/qdbus/tools/qdbuscpp2xml/qdbuscpp2xml.cpp 2007-03-03 12:53:16.000000000 -0500
+@@ -375,7 +375,7 @@
+ else {
+ // run moc on this file
+ QProcess proc;
+- proc.start(QLatin1String("moc"), QStringList() << QFile::decodeName(argv[i]));
++ proc.start(QLatin1String("moc-qt4"), QStringList() << QFile::decodeName(argv[i]));
+
+ if (!proc.waitForStarted()) {
+ fprintf(stderr, PROGRAMNAME ": could not execute moc! Aborting.\n");
diff --git a/debian/patches/90_arm_eabi_fix.dpatch b/debian/patches/90_arm_eabi_fix.dpatch
new file mode 100644
index 0000000..a826663
--- /dev/null
+++ b/debian/patches/90_arm_eabi_fix.dpatch
@@ -0,0 +1,36 @@
+#! /bin/sh -e
+## 90_armeabi.dpatch.dpatch by Lennert Buytenhek <buytenh@wantstofly.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Add support for EABI ARM platforms to Qt.
+
+if [ $# -lt 1 ]; then
+ echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
+ exit 1
+fi
+
+[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
+patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
+
+case "$1" in
+ -patch) patch -p1 ${patch_opts} < $0;;
+ -unpatch) patch -R -p1 ${patch_opts} < $0;;
+ *)
+ echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
+ exit 1;;
+esac
+
+exit 0
+
+@DPATCH@
+--- qt4-x11-4.2.1/src/corelib/global/qglobal.h.orig 2007-01-04 23:57:34.000000000 +0000
++++ qt4-x11-4.2.1/src/corelib/global/qglobal.h 2007-01-04 23:58:06.000000000 +0000
+@@ -290,7 +290,7 @@
+ # if defined(Q_OS_DARWIN) && __GNUC__ == 3 && (__GNUC_MINOR__ >= 1 && __GNUC_MINOR__ < 3)
+ # define Q_BROKEN_DEBUG_STREAM
+ # endif
+-# if (defined(__arm__) || defined(__ARMEL__)) && !defined(QT_MOC_CPP)
++# if (defined(__arm__) || defined(__ARMEL__)) && !defined(__ARM_EABI__) && !defined(QT_MOC_CPP)
+ # define Q_PACKED __attribute__ ((__packed__))
+ # define Q_NO_PACKED_REFERENCE
+ # endif
diff --git a/debian/qt4-designer.links b/debian/qt4-designer.links
new file mode 100644
index 0000000..d5bf5e5
--- /dev/null
+++ b/debian/qt4-designer.links
@@ -0,0 +1 @@
+usr/bin/designer-qt4 usr/share/qt4/bin/designer
diff --git a/debian/qt4-doc.doc-base b/debian/qt4-doc.doc-base
new file mode 100644
index 0000000..eaac3e8
--- /dev/null
+++ b/debian/qt4-doc.doc-base
@@ -0,0 +1,11 @@
+Document: qt4-doc
+Title: Qt4 Reference Documentation
+Author: Trolltech AS
+Abstract: Qt is a cross-platform C++ application framework. Qt's
+ primary feature is its rich set of widgets that provide standard GUI
+ functionality.
+Section: Apps/Programming
+
+Format: HTML
+Index: /usr/share/doc/qt4-doc/html/index.html
+Files: /usr/share/doc/qt4-doc/html/*.html
diff --git a/debian/qt4-doc.install b/debian/qt4-doc.install
index 382ff3e..c5ca431 100644
--- a/debian/qt4-doc.install
+++ b/debian/qt4-doc.install
@@ -1 +1,3 @@
usr/share/qt4/doc
+usr/share/qt4/examples
+usr/share/qt4/demos
diff --git a/debian/rules b/debian/rules
index 2bddb84..29ef8a0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,7 +20,7 @@ DEB_DH_INSTALL_ARGS := --exclude=.debug
DEB_MAKE_CLEAN_TARGET := confclean distclean
DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_INSTALL_CHANGELOGS_ALL := changes-4.2.1
+DEB_INSTALL_CHANGELOGS_ALL := changes-4.2.2
ifeq ($(DEB_HOST_ARCH),arm)
EXTRA_CONFIGURE_OPTS += -DQT_QLOCALE_USES_FCVT