summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFathi Boudra <fabo@debian.org>2007-12-07 13:09:20 +0000
committerFathi Boudra <fabo@debian.org>2007-12-07 13:09:20 +0000
commit4400fad164886996bbdacd39a9c743d956583157 (patch)
treeeae8240f50a7bf5f31a3229417e15675b56499cb
parent0fd889edc79e285304ed1d9e3af635d1aee04171 (diff)
downloadqt4-x11-4400fad164886996bbdacd39a9c743d956583157.tar.gz
* Disable "mips breaking abi" patch.
* Use --as-needed.
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/91_qmake_ldflags_as-needed.diff11
-rw-r--r--debian/patches/series3
-rwxr-xr-xdebian/rules3
4 files changed, 19 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 93f5f74..3531efa 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -12,8 +12,10 @@ qt4-x11 (4.3.3-1) unstable; urgency=low
* Bump Standards-Version to 3.7.3.
* Merge Kubuntu load ssl patch. Thanks to Jonathan Riddell.
* Add CDDL exception to debian/copyright.
- * Add 21_assume_no_fpu_for_embedded_devices patch.
- Thanks to Thiemo Seufer and Bradley Hughes. (Closes: #451046)
+ * Add 21_assume_no_fpu_for_embedded_devices patch. Thanks to Thiemo Seufer
+ and Bradley Hughes. Not Enabled yet: It breaks ABI on mips.
+ We will keep it for later (> 4.3.3-1).
+ * Add 91_qmake_ldflags_as-needed patch. Build with --as-needed linker flag.
* Remove qt-copy patches:
* 0163-fix-gcc43-support.
* 0185-fix-format-strings.
diff --git a/debian/patches/91_qmake_ldflags_as-needed.diff b/debian/patches/91_qmake_ldflags_as-needed.diff
new file mode 100644
index 0000000..e380c46
--- /dev/null
+++ b/debian/patches/91_qmake_ldflags_as-needed.diff
@@ -0,0 +1,11 @@
+--- a/mkspecs/common/g++.conf
++++ b/mkspecs/common/g++.conf
+@@ -32,7 +32,7 @@
+
+ QMAKE_LINK = g++
+ QMAKE_LINK_SHLIB = g++
+-QMAKE_LFLAGS +=
++QMAKE_LFLAGS += -Wl,--as-needed
+ QMAKE_LFLAGS_RELEASE +=
+ QMAKE_LFLAGS_DEBUG +=
+ QMAKE_LFLAGS_APP +=
diff --git a/debian/patches/series b/debian/patches/series
index 7862bb8..157bcdc 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -24,7 +24,7 @@
07_trust_dpkg-arch_over_uname-m.diff
08_load_ssl.diff
20_mips_atomic_ops.diff
-21_assume_no_fpu_for_embedded_devices.diff
+#21_assume_no_fpu_for_embedded_devices.diff
30_arm_ftbfs_fixes.diff
31_arm_eabi_fix.diff
40_alpha_ice.diff
@@ -34,3 +34,4 @@
70_hppa_ldcw_fix.diff
80_hurd_max_path.diff
90_qmake_cxxflags_fpermissive.diff
+91_qmake_ldflags_as-needed.diff
diff --git a/debian/rules b/debian/rules
index 32a2394..2226bba 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,6 +4,7 @@ export QTDIR := $(shell pwd)
export PATH := $(QTDIR)/bin:$(PATH)
export LD_LIBRARY_PATH := $(QTDIR)/lib:$(LD_LIBRARY_PATH)
export CXXFLAGS := -fpermissive
+export LDFLAGS := -Wl,--as-needed
QTVERSION := $(shell ls changes-* | cut -f2 -d '-')
CURRENTVERSION := $(shell head -1 debian/changelog | sed 's/[^(]*(\([^)]*\)).*/\1/')
@@ -35,7 +36,7 @@ ifeq ($(DEB_HOST_ARCH),arm)
EXTRA_CONFIGURE_OPTS += -DQT_QLOCALE_USES_FCVT
endif
-DEB_CONFIGURE_SCRIPT_ENV += CXXFLAGS=-fpermissive
+DEB_CONFIGURE_SCRIPT_ENV += CXXFLAGS="-fpermissive" LDFLAGS="-Wl,--as-needed"
ifeq ($(DEB_HOST_ARCH_OS),linux)
PLATFORM_ARG = linux-g++