summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFathi Boudra <fabo@debian.org>2008-03-09 14:52:18 +0000
committerFathi Boudra <fabo@debian.org>2008-03-09 14:52:18 +0000
commitba6d0a174ceed3d27f3837be2131ffd9c98cf204 (patch)
tree2b25a88818908cbd74a8b7d60e89a0aee224683a
parent04a801c3506e268d69b84c1a2064d17b4f45ec32 (diff)
downloadqt4-x11-ba6d0a174ceed3d27f3837be2131ffd9c98cf204.tar.gz
* Rename libqt4-debug to libqt4-dbg like other debug packages in Debian.
* Split WebKit and XML patterns in their own debug packages.
-rw-r--r--debian/control28
-rwxr-xr-xdebian/rules12
2 files changed, 31 insertions, 9 deletions
diff --git a/debian/control b/debian/control
index 0f8e759..ba677c9 100644
--- a/debian/control
+++ b/debian/control
@@ -331,15 +331,39 @@ Description: Qt 4 development files
This packages contains the header development files and development programs
such as qmake used for building Qt4 applications.
-Package: libqt4-debug
+Package: libqt4-dbg
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, libqt4-gui (= ${binary:Version})
+Depends: ${shlibs:Depends}, ${misc:Depends},
+ libqt4-gui (= ${binary:Version})
+Conflicts: libqt4-debug (<< 4.4.0~beta1-1)
+Replaces: libqt4-debug (<< 4.4.0~beta1-1)
Description: Qt 4 library debugging symbols
Qt is a cross-platform C++ application framework. Qt's primary feature
is its rich set of widgets that provide standard GUI functionality.
.
This packages contains the debugging symbols for the Qt 4 libraries.
+Package: libqt4-webkit-dbg
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends},
+ libqt4-webkit (= ${binary:Version})
+Description: Qt 4 WebKit library debugging symbols
+ Qt is a cross-platform C++ application framework. Qt's primary feature
+ is its rich set of widgets that provide standard GUI functionality.
+ .
+ This packages contains the debugging symbols for the Qt 4 WebKit library.
+
+Package: libqt4-xmlpatterns-dbg
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends},
+ libqt4-xmlpatterns (= ${binary:Version})
+Description: Qt 4 XML patterns library debugging symbols
+ Qt is a cross-platform C++ application framework. Qt's primary feature
+ is its rich set of widgets that provide standard GUI functionality.
+ .
+ This packages contains the debugging symbols for the Qt 4 XML patterns
+ library.
+
Package: qt4-designer
Architecture: any
Section: devel
diff --git a/debian/rules b/debian/rules
index a7ea1cd..b66af25 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,14 +16,13 @@ DEB_MAKE_BUILD_TARGET := sub-src sub-tools
DEB_MAKE_INSTALL_TARGET := INSTALL_ROOT=$(DEB_DESTDIR) install
DEB_DH_INSTALL_SOURCEDIR := debian/tmp
-# Ensure the *.debug files aren't included in any package other than
-# libqt4-debug.
+# Ensure the *.debug files aren't included in any package other than libqt4-dbg
DEB_DH_INSTALL_ARGS := --exclude=.debug
DEB_MAKE_CLEAN_TARGET := confclean distclean
DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_DH_STRIP_ARGS_libqt4-debug := --exclude=.debug
+DEB_DH_STRIP_ARGS_libqt4-dbg := --exclude=.debug
DEB_DH_SHLIBDEPS_ARGS_ALL := --exclude=.debug
@@ -191,10 +190,9 @@ binary-install/qt4-doc::
tar -cv demos/ | \
gzip -9 > debian/qt4-doc/usr/share/doc/qt4-doc/qt4-demos.tar.gz
-binary-install/libqt4-debug::
-# Run dh_install without the default DEB_DH_INSTALL_ARGS to install the
-# *.debug files.
- dh_install -plibqt4-debug --sourcedir=$(DEB_DH_INSTALL_SOURCEDIR)
+binary-install/libqt4-dbg::
+# Run dh_install without the default DEB_DH_INSTALL_ARGS to install the *.debug files
+ dh_install -plibqt4-dbg --sourcedir=$(DEB_DH_INSTALL_SOURCEDIR)
# Automatically install lintian overrides, stolen from debian-qt-kde.mk
$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%: