summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSune Vuorela <debian@pusling.com>2007-10-06 16:42:17 +0000
committerSune Vuorela <debian@pusling.com>2007-10-06 16:42:17 +0000
commit2c5d0a7f00050a96a9412a33d87a64c79294b66a (patch)
treee106768a50b75622282651343bbb50d4c8ef2d17
parent0b639a0ca0f573fcef424993977b220b8bc29099 (diff)
downloadqt4-x11-2c5d0a7f00050a96a9412a33d87a64c79294b66a.tar.gz
generate a shlibs.local file on build
-rw-r--r--debian/changelog4
-rwxr-xr-xdebian/rules11
2 files changed, 15 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index fb0567d..774c582 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -25,6 +25,10 @@ qt4-x11 (4.3.2-1) unstable; urgency=low
* Introduce QTVERSION.
* Fix qt4-config menu section. (Closes: 444896)
+ [Sune Vuorela]
+ * Have strict interdependencies between packages with a shlibs.local file
+ (Closing: #438746)
+
-- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Sat, 06 Oct 2007 07:00:54 +0200
qt4-x11 (4.3.1-2) unstable; urgency=low
diff --git a/debian/rules b/debian/rules
index ce0e476..2a4c7a9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -28,6 +28,8 @@ DEB_DH_STRIP_ARGS_libqt4-debug := --exclude=.debug
DEB_INSTALL_CHANGELOGS_ALL := changes-$(QTVERSION)
+CURRENTVERSION := $(shell head -1 debian/changelog | sed 's/[^(]*(\([^)]*\)).*/\1/')
+
DEB_INSTALL_DOCS_ALL := GPL_EXCEPTION_ADDENDUM.TXT
ifeq ($(DEB_HOST_ARCH),arm)
@@ -125,6 +127,8 @@ clean::
-o -name Makefile.Debug -print0 \
-o -name Makefile.Release -print0 \
| xargs -0r rm -f
+ #we generate this on build:
+ rm -f debian/shlibs.local
PKGCONFIGDIR := $(DEB_DESTDIR)/usr/lib/pkgconfig
common-install-arch::
@@ -178,3 +182,10 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).lintian \
debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
fi
+
+#generating shlibs local files
+$(patsubst %,binary-fixup/%,$(DEB_ALL_PACKAGES)) :: binary-fixup/%: binary-strip/%
+ if test -e debian/$(cdbs_curpkg)/DEBIAN/shlibs ; then \
+ sed 's/>=[^)]*/= $(CURRENTVERSION)/' debian/$(cdbs_curpkg)/DEBIAN/shlibs >> debian/shlibs.local ;\
+ fi
+