summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFathi Boudra <fabo@debian.org>2008-05-31 09:23:04 +0000
committerFathi Boudra <fabo@debian.org>2008-05-31 09:23:04 +0000
commitf49332c792ead8adaa49ff58250832e84ded20e8 (patch)
tree0298e9739c1748657468ccdfdfae4c32d03f7d08
parent403d292999dbe487f4d8b8573f289b0389b22a3d (diff)
downloadqt4-x11-f49332c792ead8adaa49ff58250832e84ded20e8.tar.gz
Refresh patches. prepare for next release.
I'll wait for ipv6 patch from Thiago.
-rw-r--r--debian/changelog14
-rw-r--r--debian/patches/0227-qdatastream-regression.diff4
-rw-r--r--debian/patches/0228-qsortfilterproxymodel-invalidate-noscroll.diff21
-rw-r--r--debian/patches/0230-qtextcontrol-selectnextword.diff33
-rw-r--r--debian/patches/09_qmake_lflags_as-needed.diff2
-rw-r--r--debian/patches/16_qsortfilterproxymodel_invalidate_noscroll.diff11
-rw-r--r--debian/patches/series3
7 files changed, 72 insertions, 16 deletions
diff --git a/debian/changelog b/debian/changelog
index 6b3221c..abb50e5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+qt4-x11 (4.4.0-3) UNRELEASED; urgency=low
+
+ * Add qt-copy patch:
+ * 0230-qtextcontrol-selectnextword
+ Fix Ctrl+Shift+Right in a khtml textarea when having more than one tab
+ open: QTextEdit should react to ShortcutOverride for the keys it handles
+ (was already partly done).
+
+ * 0231- !!! we wait for ipv6 fix !!!
+
+ -- Fathi Boudra <fabo@debian.org> Sat, 31 May 2008 09:23:04 +0200
+
qt4-x11 (4.4.0-2) unstable; urgency=low
+++ Changes by Fathi Boudra:
@@ -9,7 +21,7 @@ qt4-x11 (4.4.0-2) unstable; urgency=low
* Add qt-copy patch:
* 0227-qdatastream-regression
Fix a bug that causes all Qt3/2 applications to crash or hang under KDE4.
-
+
+++ Changes by Modestas Vainius:
* Add 16_qsortfilterproxymodel_invalidate_noscroll.diff patch which stops
diff --git a/debian/patches/0227-qdatastream-regression.diff b/debian/patches/0227-qdatastream-regression.diff
index d84e12a..17efc0e 100644
--- a/debian/patches/0227-qdatastream-regression.diff
+++ b/debian/patches/0227-qdatastream-regression.diff
@@ -1,5 +1,5 @@
-qt-bugs@ issue : none
-Trolltech task ID : None
+qt-bugs@ issue : N211089
+Trolltech task ID : 211301
bugs.kde.org number : None
applied: no
author: Dirk Mueller <mueller@kde.org>
diff --git a/debian/patches/0228-qsortfilterproxymodel-invalidate-noscroll.diff b/debian/patches/0228-qsortfilterproxymodel-invalidate-noscroll.diff
new file mode 100644
index 0000000..b6da2cc
--- /dev/null
+++ b/debian/patches/0228-qsortfilterproxymodel-invalidate-noscroll.diff
@@ -0,0 +1,21 @@
+qt-bugs@ issue : none
+Trolltech task ID : 204403
+bugs.kde.org number : none
+applied: no
+author: Mikko C. <mikko.cal@gmail.com>
+
+Calling QSortFilterProxyModel::invalidate causes view
+to scroll to the current item/index.
+This behavior was not present on the Qt4.3.x. Fixed in Qt4.4.1 snapshots
+
+--- a/src/gui/itemviews/qabstractitemview.cpp
++++ b/src/gui/itemviews/qabstractitemview.cpp
+@@ -2980,7 +2980,7 @@
+ if (q->isVisible()) {
+ q->doItemsLayout();
+ const QModelIndex current = q->currentIndex();
+- if (current.isValid())
++ if (current.isValid() && state == QAbstractItemView::EditingState)
+ q->scrollTo(current);
+ } else {
+ doDelayedItemsLayout();
diff --git a/debian/patches/0230-qtextcontrol-selectnextword.diff b/debian/patches/0230-qtextcontrol-selectnextword.diff
new file mode 100644
index 0000000..91ab87e
--- /dev/null
+++ b/debian/patches/0230-qtextcontrol-selectnextword.diff
@@ -0,0 +1,33 @@
+qt-bugs@ issue : N213258
+Trolltech task ID : 213259
+bugs.kde.org number : I guess there is one
+applied: no
+author: David Faure <faure@kde.org>
+
+Imagine a konqueror window with two tabs, and in the current tab there's a QTextEdit (in a web form).
+When typing Ctrl+Shift+Right, it is expected that the next word is selected.
+However, the QAction for "move this tab to the right" is triggered, which is unexpected.
+This wouldn't happen if the QTextEdit would react to the ShortcutOverride event which
+is sent first, for this exact purpose (so that widget-specific shortcuts are done first).
+QTextControl already handles some ShortcutOverride events, but not all of them.
+The patch below adds a few useful ones, i.e. possibly-conflicting ones. I guess one could
+be exhaustive and list all possible shortcuts there....
+
+
+--- a/src/gui/text/qtextcontrol.cpp
++++ b/src/gui/text/qtextcontrol.cpp
+@@ -1065,6 +1065,14 @@
+ || ke == QKeySequence::MoveToPreviousWord
+ || ke == QKeySequence::MoveToStartOfDocument
+ || ke == QKeySequence::MoveToEndOfDocument
++ || ke == QKeySequence::SelectNextWord
++ || ke == QKeySequence::SelectPreviousWord
++ || ke == QKeySequence::SelectStartOfLine
++ || ke == QKeySequence::SelectEndOfLine
++ || ke == QKeySequence::SelectStartOfBlock
++ || ke == QKeySequence::SelectEndOfBlock
++ || ke == QKeySequence::SelectStartOfDocument
++ || ke == QKeySequence::SelectEndOfDocument
+ ) {
+ ke->accept();
+ #endif
diff --git a/debian/patches/09_qmake_lflags_as-needed.diff b/debian/patches/09_qmake_lflags_as-needed.diff
index 3c6a848..5a6d11c 100644
--- a/debian/patches/09_qmake_lflags_as-needed.diff
+++ b/debian/patches/09_qmake_lflags_as-needed.diff
@@ -5,7 +5,7 @@ Bug reported to Trolltech.
--- a/configure
+++ b/configure
-@@ -500,6 +500,8 @@
+@@ -503,6 +503,8 @@
rm -f "$outpath/config.tests/.qmake.cache"
cp "$QMAKE_VARS_FILE" "$outpath/config.tests/.qmake.cache"
diff --git a/debian/patches/16_qsortfilterproxymodel_invalidate_noscroll.diff b/debian/patches/16_qsortfilterproxymodel_invalidate_noscroll.diff
deleted file mode 100644
index af51abb..0000000
--- a/debian/patches/16_qsortfilterproxymodel_invalidate_noscroll.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/gui/itemviews/qabstractitemview.cpp 2008-04-28 15:11:18.000000000 +0200
-+++ b/src/gui/itemviews/qabstractitemview.cpp 2008-04-10 01:00:58.000000000 +0200
-@@ -2980,7 +2982,7 @@
- if (q->isVisible()) {
- q->doItemsLayout();
- const QModelIndex current = q->currentIndex();
-- if (current.isValid())
-+ if (current.isValid() && state == QAbstractItemView::EditingState)
- q->scrollTo(current);
- } else {
- doDelayedItemsLayout();
diff --git a/debian/patches/series b/debian/patches/series
index d5eccb7..921a662 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -13,6 +13,8 @@
0225-invalidate-tabbar-geometry-on-refresh.diff
0226-qtreeview-column_resize_when_needed.diff
0227-qdatastream-regression.diff
+0228-qsortfilterproxymodel-invalidate-noscroll.diff
+0230-qtextcontrol-selectnextword.diff
# debian patches
01_qmake_for_debian.diff
@@ -26,7 +28,6 @@
12_fix_qmake_pkgconfig.diff
14_add_libraries_to_gui_build_where_actually_needed.diff
15_fix_qmake_makefile_generation.diff
-16_qsortfilterproxymodel_invalidate_noscroll.diff
20_mips_atomic_ops.diff
40_alpha_ice.diff
41_disable_opengl_visibility.diff